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Part – I Working with OpenOffice Calc

7.1 Introduction to spreadsheet

	 Spreadsheet is a very useful office 
automation tool to organise, analyse and 
store data in a tabular form. Spreadsheet 
was developed as computerized equivalent 
to paper-based accounting worksheets. 

	 Spreadsheet users can adjust any 
of the stored values and can observe the 
effects on the calculated values.  This 
is called "What if " analysis. Modern 
spreadsheet can have multiple interacting 
sheets and can display data either as text 
or numerals or in a graphical form.

7.1.1 Evolution of Spreadsheet

	 Daniel Bricklin and Bob Frankston 
developed the first spreadsheet called 
“VisiCalc” in 1979 for Apple II. In 1982, 
Lotus Corporation introduced “Lotus 
1-2-3”; Lotus 1-2-3 was the first to 
introduce cell names and macros. In 1987, 
Microsoft Corporation introduced Excel. 
Excel implemented a Graphical User 
Interface (GUI) and the ability to point 
and click using a mouse. There are lots of 
other spreadsheet applications; Microsoft 
Excel continues to be the most popular 
spreadsheet software.

Daniel Singer "Dan" 
Bricklin (born 16 July 
1951), often referred 
to as “The Father of 
the Spreadsheet”, is 

the American co-creator, with Bob 
Frankston, of the VisiCalc spreadsheet. 
He also founded Software Garden, Inc., 
of which he is currently President of 
Trellix Corporation, which is currently 
owned by Web.com.  He currently 
serves as the Chief Technology Officer 
of Alpha Software.

Daniel Singer "Dan" Bricklin
The Father of Spreadsheet

	 OpenOffice Calc is a popular open 
source spreadsheet application maintained 
by Apache Foundation. StarOffice calc 
was the parent application of OpenOffice 
Calc which was developed by a German 
Company namely, Star Division in 1985.

7.2 Working with OpenOffice Calc

	 Calc is the spreadsheet component 
of OpenOffice. You can enter any kind of 
data in a spreadsheet and then manipulate 
this data to produce certain results. 
Alternatively, you can enter data and 
then use Calc in a ‘What If...’ manner by 
changing some of the data and observing 
the results without having to retype the 
entire spreadsheet.
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VisiCalc ("Visible Calculator") was 
the first spreadsheet for personal 
computers, originally released for the 
Apple II by VisiCorp. It is considered  
that VisiCalc turned the microcomputer 
from a hobby for computer enthusiasts 
into a serious business tool, prompting 
IBM to introduce the IBM PC, two 
years later. It was sold over 700,000 
copies in six years, and as many as 1 
million copies over its history.

First Spreadsheet

7.2.1 Features of OpenOffice Calc:

•	 Connecting with Excel - Ability to 
open, edit, and save Microsoft Excel 
spreadsheets

•	 AutoSum - helps you to add the 
contents of a cluster of adjacent cells.

•	 List AutoFill - automatically extends 
cell formatting when a new item is 
added to the end of a list.

•	 AutoFill - allows you to quickly fill cells 
with repetitive or sequential data such 
as chronological dates or numbers, and 
repeated text. AutoFill can also be used 
to copy functions. You can also alter 
text and numbers with this feature.

•	 Charts - helps you in presenting a 
grvaphical representation of your data 
in the form of Pie, Bar, Line charts and 
more.

•	 Functions: which can be used to 
create formula to perform complex 
calculations on data

•	 Database functions: to arrange, store, 
and filter data

7.3 Creating a new worksheet

	 A new spreadsheet can be created 
through various methods. From windows, 
select 

Start → All Programs → OpenOffice → 
OpenOffice Calc (or)

From Star Center (Welcome Screen):

Double-click on “OpenOffice” icon the 
desktop

Now, a welcome screen appears as shown 
in Figure 7.1.  

	 This open screen is called as “Star 
Center”. Calc is one of the component of 
OpenOffice. So, it may be invoked from 
the “Star Center” by simply clicking on 
the “Spreadsheet” icon.   (or)

	 A new spreadsheet can also be 
created by selecting File → New → 
Spreadsheet from any OpenOffice 
Application. After using any one of the 
above said methods, OpenOffice Calc 
window appears as shown in Figure 7.2. 
The outline of the window is very similar to 
other application windows of OpenOffice. 
The main area of the Calc window is called 
as “Work area” or “Worksheet”. 

	 A worksheet is a grid of cells with a 
programmable calculator attached to each 
cell.  When you open a new spreadsheet, 
there are three worksheets available by 
default. You can include more sheets and 
organize them. 
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Figure 7.1 Opening Screen (Star Center) of OpenOffice
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Fig 7.2 OpenOffice Calc Window
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1. Title Bar 2. Control Buttons
3. Menu Bar 4. Tools Bar
5. Name Box / 
Address Box

6. Quick Function 
Wizard

7. Formula Bar / 
Input Line

8. Formatting 
Properties

9. Zoom 10. Scroll bar
11. Status Bar

7.3.1 Parts of the OpenOffice Calc 
Wi n d o w

	 Appearance of the Calc window is 
very similar to that of the Writer window. 
The workspace of writer is a big blank 
area. But, in calc, the grid of cells is the 
workspace. 

7.3.1.1 Title Bar

	 Top of the window is called the 
“Title Bar”. It is used to show the name 
of the file and name of the application. 
In OpenOffice calc, the default name for 
the first unsaved worksheet is “Untitled1”. 
When you save the file, Untitled will 
change to the name in which you saved.

7.3.1.2 Control Buttons:

	 In the right corner of title bar, (1) 
minimize, (2) maximize / restore and (3) 
close control buttons are available.

7.3.1.3 Menu Bar

	 Below the title bar is menu bar. 
Most of the menus are very similar to 
what you learnt in OpenOffice Writer. 

	 File - menu contains the commands 
of all file management tasks like, Create 
a new file, Open an existing file, Close 

the current file, Save a file, Save a file in 
another name, print file, Export file etc.

	 Edit - menu contains the editing 
commands like, cut, copy, paste, Undo, 
Redo, Fill etc., Most of the menu items are 
similar to Writer Edit menu. But, for Calc, 
some special editing options are available 
under this menu.

	 View - menu contains the 
commends which are used to modify the 
environment of calc.  

	 Insert – menu contains commands 
for inserting various calc elements such 
as cells, columns, rows, functions, charts 
etc.,

	 Format – menu contains the 
commands of various text and cell 
formatting features.

	 Tools – menu contains various tools 
and functions such as spell check, protect 
document, insert pictures, macros, etc.,

	 Data – menu contains the 
commands to manipulate data in a 
spreadsheet such as sort, filter, subtotal, 
validity etc.,

	 Window – menu shows display 
options such as New Window, Close 
Windows, Split and Freeze.

	 Help – menu lists in-built help 
features available with OpenOffice.

7.3.1.4 Tools Bar

	 Under the menu bar, there are three 
toolbars available by default. They are: 	
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	 (1) Standard Toolbar 	 (2) Formatting Toolbar	 (3) Formula bar

Standard Toolbar 

Formatting Toolbar Formula bar 

Fig. 7.3 OpenOffice Calc Toolsbar

	 Standard Toolbar – contains 
frequently used File, Edit and Data menu 
commands as icons such as New Open 
Save, Send, print, print preview, Cut, 
Copy, Paste, Sorting, inserting chart etc.,

	 Formatting Toolbar – contains 
frequently used text and cell formatting 
commands as such as changing font style, 
font size, font colour, alignments, cell 
formatting etc.,

	 Formula bar – This is a very 
important element in a spreadsheet. It 
contains Name box, Function Wizard, 
Sum button, Function button and Input 
line (Refer Figure 7.4).

	 Name box : It display the current 
cell address 

	 Function Wizard : It is used to 
insert function 

	 Sum button : It is used to quickly 
insert sum function.

	 Input Line : This is used to show 
the contents of the current cell. It always 
shows actually what you typed in a cell. It 
is also used to edit the contents. 

	
Name box / Address Box Input Line

Sum button
Function 
Wizard

Function 
button

Fig. 7.4  Calc Formula bar

7.3.1.5 Scroll bar

	 Spreadsheet window also has two 
sets of scrolling bars (1) Vertical Scrollbar 
and (2) Horizontal Scrollbar  (Refer Figure 
7.5)

Vertical Scroll bar : It is used to move the 
screen up and down.

Horizontal Scroll bar : It is used move 
the screen left and right.

Scroll buttons : used to move the screen 
to the relative distance.

Chapter 7.indd   106 12/11/2021   1:40:58 AM



107

Upward 
Scroll arrow

Scroll button

Downward
Scroll arrow

Right Scroll 
arrow

Scroll button
Left Scroll

arrow

Scroll button

Fig. 7.5  Calc Scrolling bar

7.3.1.6 Row, Column, Cell and Cell 
Pointer

	 Below the formula bar contains the 
worksheet of work area which consit of 
grid cells  The worksheet has number of 
rows and columns, where each column is 
labelled as A, B, C, D ….. AA, AB, AC ….. 
and the rows are numbered from 1, 2, 3 
…. (Figure 7.6).   

	 OpenOffice Calc version 4.1.5 
contains 1024 columns and 10,48,576 
rows. Column heading starts from A and 
end with AMJ. In the case of Microsoft 
Excel 2016, there are 16,384 columns (A 
to XFD) and 10,48,576 rows available. 

Cell

	 Intersection of each row and 
column makes a box which is called as 
“Cell”. Each cell has its unique address. 

Cell address is the combination of 
column heading and row number.  For 
example, the intersection of column B 
and row 4 makes a cell B4. (Figure 7.7). 
Every cell is thus identified by its unique 
cell address.

	 Cell pointer is a rectangle box which 
can be moved around the worksheet. The 
cell in which the cell pointer is currently 
located is known as “Active cell”. When 
you type anycontent, it will appear in the 
active cell. The address of the active cell 
is displayed in the Name box / Address 
box. Active cell’s column name and row 
number will be highlighted. Using this 
visual clue, one can easily identify an 
active cell. Moreover, the contents of an 
active cell will be displayed in the formula 
bar.
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Column Heading

Cell Pointer

Grid of Cells

Fig. 7.6  Calc Rows, Columns, Cells 

Current Cell Address Highlighted Column Heading

 Highlighted lighted Row
Number

Active all

Fig. 7.7  Cells, Rows and Columns

7.3.1.7 Worksheet tabs:

Active Sheet

Sheet Count
Sheet Navigation buttons

Fig. 7.8  Calc Sheet Tab
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	 At the bottom of the grid of cells 
are the sheet tabs. By default there are 3 
sheets “Sheet1”, “Sheet2” and “Sheet3”, 
(Figure 7.8). When you open a new 
worksheet, sheet1 is the default active 
sheet. Active sheet tab will appear in white 
colour. If you click on another sheet, it 
will become active and its colour will turn 
white. Multiple sheets can also be selected 
by clicking the sheet and press the Ctrl 
button (Ctrl + Click). Selected sheets will 
turn to white colour. 

	 On the left of the sheet tab, four 
navigation buttons are used to move 
between worksheets (Figure 7.9). 

1 3

2 4

(1) Move to the First sheet

(2) Move to the previous sheet

(3) Move to Next sheet

(4) Move to the Last sheet 

Fig. 7.9  Calc Sheet tab and Navigation 
buttons

	 Left corner of status bar shows the 
total count of sheets and the present active 
sheet number. For example, if the status 
bar shows sheet 3/12; 3 refers to the serial 
number of the current sheet and 12 refers 
to the total number of sheets available.

	 Every sheet name can be renamed. 
To rename a sheet, just double-click on 
the sheet, which will show a small box as 
shown in Figure 7.10.

Figure. 7.10  Rename Sheet dialog box

	 It shows the current name; delete 
or overwrite the existing name and type 
a new name; click OK button. New name 
will be displayed on the sheet.

7.3.1.8 Status bar

	 Below the sheet tabs and horizontal 
scrolling bar is the “Status Bar”. It shows 
the current status of the worksheet (Refer 
Figure 7.11). 

	 Sheets count:  Displays current 
serial number of the sheet / total number 
of sheets available.

	 Page Style: Displays the page style 
of the current sheet. To make changes, just 
double-click on “Default” and  it will show 
you the “Page Style” dialog box, which is 
used to change the margin, orientation, 
paper size, inserting header, footer, border 
style etc.,

	 Selection Mode: Displays the 
selection mode of the current sheet. There 
are three modes available to select the cells 
of a worksheet. They are, Standard (STD), 
Extend (EXT) and Add (ADD). 

Unsaved Changes: An asterisk ( * ) 
symbol indicates the changes made in the 
worksheet but not yet saved. If you have 
saved your changes, it will disappear. 
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Sheets count

Page Style Unsaved Changes cell information

Selection Mode Zoom

Fig. 7.11 Calc Status bar 

7.4 Working with Data

	 When you open a new spreadsheet, 
the cell pointer is located in cell A1. So, 
the Cell A1 is known as “Home Cell”. Cell 
pointer can be moved anywhere in the 
spreadsheet using the direction keys. 

	 “Tab key” is used to move the cell 
pointer towards the right side or forward 
direction. “Shift+Tab” is used to move 
backward i.e. from right to left in a row. 
“Enter” key is also used to move the cell 
pointer. Enter moves the cell pointer to a 
cell below the current cell i.e. downwards. 
Four “direction keys” are used to move the 
cell pointer anywhere in the worksheet.

7.4.1 Entering Data:

Any data can be typed directly in any cell 
of the worksheet. But, the cell in which 
you type data should be an active cell. 
So, move the cell pointer to a particular 
cell to make it active cell; or click any 
cell to make it active cell. Then, start 
typing any data. When you type data, 
spreadsheet recognises the type of data 
entered in cells.

Data types: 

	 Data are in different types. Data 
are made up of alphabets, numbers, Date 
and time is another data type even though 

it has numbers and symbols. In general, 
data types are classified as:

	 Alphabetic data type – consists 
of alphabets only Numeric data type – 
consists only of numbers (whole number 
or fractional numbers) Alphanumeric 
data types – consists of a combination of 
alphabets and numerals Date data type 
– consists only of date Time data type – 
consists only time

7.4.1.1 Entering Numbers:

	 Any numeric data can be entered 
in a spreadsheet. Entered numbers are 
aligned to the right side within the cell 
by default. Negative numbers may be 
entered with a minus sign or within 
brackets (Refer Figure 7.12). If you enter 
any number within the bracket, it will be 
changed as negative number i.e., number 
prefixed with minus. If any number starts 
with 0 (zero); Calc will drop the leading 
zero.

Figure 7.12 Entering data
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7.4.1.2 Entering Text:

	 Unlike numbers, any character can 
be entered as data in Calc. Entered text will 
be aligned to the left side within the cell 
by default. When you enter any numeric 
value, if it has aligned left, it is understood 
that the entered content is not a number. 
If there is any number that starts with a 
single quote, calc converts that number to 
text (Refer Figure 7.13). 

Figure 7.13 Entering Text

7.4.1.3 Entering Date and Time:

	 Before entering date, ensure the 
format of your system date. Calc accepts 
date as per the system date format. If your 
system has American date format i.e. 
month-date-year; you should enter dates 
in Calc spreadsheet as mm/dd/yy. If your 
system follows the Indian date format, 
date should be entered as dd/mm/yy form 
in Calc. Only the correct form of date is 
accepted by Calc as a date.v 

	 For example: If your system has 
American Date format, 18th December 
2017 should be entered as 12/18/17. As 
soon as the date is typed in the correct 
form, the entered date will be aligned on the 
right side within the cell, and if you place 
the cell pointer in that cell, the formula 
bar shows your date as “12/18/2017” 

(Figure 7.14). This is a visual clue to know 
whether the date is accepted or not. 

	 A Date format can be changed to any 
other valid form using “Cell Formatting” 
dialog box, and it will be discussed later.

Fig. 7.14 Entering Date

	 Like dates, for entering time, calc 
follows the general format HH:MM:SS. 
where HH, MM and SS represent hours, 
minutes and seconds respectively.

Different Date Formats

Order styles Countries

DD/MM/YYYY

Asia (Central, SE, 
West), Australia, New 
Zealand, parts of Europe, 
Latin America, North 
Africa, India, Indonesia, 
Bangladesh and Russia 

YYYY/MM/DD

Bhutan, Canada, China, 
Koreas, Taiwan, Hungary, 
Iran, Japan, Lithuania, 
Mongolia.

MM/DD/YYYY
United States, Federated 
States of Micronesia, 
Marshall Islands

DD/MM/YYYY 
and

MM/DD/YYYY

Malaysia, Nigeria, 
Philippines, Saudi Arabia, 
Somalia

DD/MM/YYYY
and

YYYY/MM/DD

Afghanistan, Albania, 
Austria, Czech Republic, 
Germany, Kenya, Macau, 
Maldives, Montenegro, 
Namibia, Nepal, 
Singapore, South Africa, 
Sri Lanka, Sweden.

Chapter 7.indd   111 12/11/2021   1:40:59 AM



112

7.5 Creating Formulae

	 After entering the data 
in worksheet, you can perform 
calculations on the data in the 
worksheet. In order to create 
formulae, you first need to 
know the syntax that describes 
the format for specifying a 
formula. 

	 In Calc, you can enter 
formulas in two methods, either 
directly into the cell or at the 
input line.  Formula in Calc may 
start with equal (=) or plus(+) 
or minus(–) sign followed 
by a combination of values, 
operators and cell references. 
But, as a general practice, all 
formulas should start with an 
equal sign. If any formula starts 
with a + or –, the values will 
be considered as positive or 
negative respectively.

7.5.1 Operators

	 Operators are symbols 
for doing some mathematical, 
statistical and logical 
calculations. Combination 
of values, operators and 
cell references is called as 
“Expression”. Calc supports a 
variety of operators which are 
categorized as: 

(1)	 Arithmetic Opertors

2)	 Relational Operators

(3)	 Reference Operators    
(4)	 Text Operator

7.5.1.1 Arithmetic Operators

	 Arithmetic operators are symbols for 
performing  simple arithmetic operations such as 
addition, subtraction, multiplication, division etc., 
These operators return a numerical result. 
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+ Addition 98 25 = B3 + C3 123
- Subtraction 125 25 = B3 – C3 100
* Multiplication 25 5 = B3 * C3 125
/ Division 90 10 = B3 / C3 9
^ Exponent 25 2 = B3 ^ C3 625
% Percent 600 = B3 * 35% 72

Percentage (%) operator shows percentage of the content.

Table 7.1  List of Arithmetic Operators

	 Formula bar shows the formula what the user 
had entered. But, the cell shows the resulted value 
(Figure 7.15).

Formula Entered

Figure 7.15 Percentage Operator

7.5.1.2 Relational Operators

	 Relational operators are symbols used for 
comparing two values such as greater than, less than, 
equal to etc. The relational operators are also called 
as "Comparative operators". These operators return 
either a True or a False. 
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Greater 

than
98 100 =B3>C3 FALSE

>=

Greater 
than 

or equal 
to

85 72 =B3>=C3 TRUE

< Less than 54 24 =B3<C3 FALSE

<=
Less than 
or equal 

to
55 55 =B3<=C3 TRUE

= Equal to 12 12 =B3=C3 TRUE

<>
Not equal 

to
54 45 =B3<>C3 TRUE

Table 7.2  List of Relational Operators of 
cells. 

7.5.1.3 Reference Operator

	 Reference operators are used to 
refer cell ranges. A continuous group 
of cells is called as “Range”. There are 
three types of reference operators that 
are used to refer cells in calc; they are 
(1) Range Reference Operator, (2) Range 
Concatenation (3) Intersection Operator.

Range Reference Operator

	 Colon (:) is the range reference 
operator. It is used to group a range of 
cells. An expression using a range operator 
has the following syntax:

reference left : reference right

where reference left is the starting cell 
address of a linear group of cells or upper 
left corner address of a rectangular group 

Reference right is the  last cell address of a 
linear group or lower right corner address 
of a rectangular group of cell.

Figure 7.16 Entering Relational Operator
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Example: 

(i)	 Linear group of cells A1, A2,A3,A4,A5 is referred as A1:A5

(ii)	 Rectangular group of cells A2, A3, A4, ….. B2, B3, B4,….D5, D6 is referred as 
A2:D6 (Refer Figure 7.17)

Range of Cells Highlighted Columns (Selected)

H
ig

hl
ig

ht
ed

 R
ow

 (S
el

ec
te

d)

Figure 7.17 Range of selected cells

	 Name box shows the reference A2:D6 corresponding to the cells included in the 
drag operation with the mouse to highlight the range.

Reference concatenation operator:

	 Concatenation means joining together. Tilde (~) symbol is used as a concatenation 
operator in calc. An expression using a concatenation operator has the following syntax:

reference left ~ reference right

Example:

	 If you want to find the sum of the values from A1 to A6 and C3 to F3. The formula 
is =SUM(A1:A6 ~ C3:F3)

	 SUM is a function to find the sum of a group of values.
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Intersection Operator:

	 Intersection operator is used to join two set of groups. It is very similar to Range 
concatenation operator. The intersection operator is represented by an exclamation

reference left ! reference right

Example: (A2:D3 ! B2:E4)

A

1

2

3

4

B C D E F

Range - 1 A2 : D3

A1 B1 C1 D1 E1 F1

A2 B2 C2 D2 E2 F2

A3 B3 C3 D3 E3 F3

A4 B4 C4 D4 E4 F4

B2:D3
Intersection of
Range 1 and 
Range 2

B2:E4Range 2

Figure 7.19  Intersection operator

	 The result of (A2:D3 ! B2:E4) is referred by the range B2:D3, because these cells are 
both inside A2:D3 and B2:E4 (Refer Figure 7.19 and 7.20).

Figure 7.20  Worksheet with Intersection operator
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7.5.1.4 Text Operator:

In Calc, “&” is a text operator which is used to combine two or more text. Joining two 
different texts is also known as “Text Concatenation” (Refer Figure 7.23). An expression 
using the text operator has the following syntax:

text reference1 & text reference2

Figure 7.21  Text operator

	 When arithmetic operators are used in a formula, Calc calculates the results using 
the rule of precedence followed in Mathematics. The order is:

I.	 Exponentiation ( ^ )			   II.	 Negation ( - )	

III.	 Multiplication and Division ( *, /)	 IV.	 Addition and Subtraction (+, -)

Here is an example to illustrate how to create a formula:

Illustration 1:

Create a Marks worksheet with the following data:

Reg. No Name Tam Eng CS Com Acc
12001 Jayashree J 147 136 105 163 162
12002 Kowsalya T 156 148 149 147 179
12003 Muskan S 149 165 123 168 179
12004 Ashia Stephy R 168 144 146 192 167
12005 Vennila T P 199 198 150 200 200
12006 Deepika M 187 141 98 130 178
12007 Tharani J 165 102 100 192 192
12008 Thulasi A 143 169 88 176 173
12009 Ayisha B 120 138 109 182 167
12010 Jenifer A 145 135 95 180 185

After completing the data entry, your worksheet will look as shown in Figure 7.22.
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Small red triangle indicates the column width  
is not enough to display the entire text

Figure 7.22  Worksheet Illustration

7.5.2 Construction of formula

To construct a formula, follow the steps below:

•	 Cell pointer should be in the cell in which you want to display the result.

•	 Formula should begin with an = sign.

•	 In a formula, use only cell reference (cell addresses) instead of the actual values within 
the cells. 

•	 While constructing a formula, BODMAS rule should be kept in mind.

•	 General Syntax of constructing a formula is: = cell reference1 <operator> cell 
reference2 <operator> ……………….

•	 Cell references are of two types (i) Relative cell reference (ii) Absolute Cell reference.

•	 If you refer  cell addresses directly while constructing formulae, it  is called as “Relative 
Cell reference”. 

•	 Examples of Relative Cell references: 

Adding values of A1, B1, C1, D1 =A1+B1+C1+D1

Subtract E4 from H3 = H3 – E4

Multiply  A5 and B5 = A5 * B5

Average of G1, G2, G3, G4 =(G1+G2+G3+G4)/4
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•	 In the above table, all cell references are “Relative cell references”.

•	 While writing a formula, if you use the $ symbol in front of a column name and row 

number, it will become an “Absolute Cell reference”. 

•	 Examples of Absolute cell references: 

Adding values of A1, B1, C1, D1 =$A$1+$B$1+$C$1+$D$1

Subtract E4 from H3 = $H$3 – $E$4

Multiply A5 and B5 = $A$5 * B5

Average of G1, G2, G3, G4 =($G$1+G2+$G$3+G4)/4

•	 In an expression, all cells need not necessarily be relative or absolute. You can mix 

both type of references.

•	 The following section explains the use of relative cell reference. About “Absolute cell 

reference”, you will be learn later in this chapter.

Finding Total to the above Illustration:

•	 Move the cell pointer to H2 (Total column)

•	 Type the following formula; after entering the formula, press “Enter” key

	 = C2+D2+E2+F2+G2 (Refere Figure 7.25)

•	 Now, you will get the sum of all the values of C2, D2, E2, F2 and G2

•	 The above-mentioned formula clearly stated that, how worksheets are working with 

cells.

•	 While referring to the cell addresses in a formula, the spreadsheet reads the value 

inside the cell that you refer. This is a good practice of constructing a formula. Because, 

if you change any value, the spreadsheet recalculates with that new value.

	 After entering a formula the result is display as in Figure 7.23
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Figure 7.23 Constructing formula in Worksheet

7.6 Save, Close and Open the Worksheet:

7.6.1 Saving Worksheet

	 The process of saving a worksheet is very similar to saving a document. Steps to 
save a worksheet are as follows:

Step 1:	 File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.

Step 2:	 If the spreadsheet has not been saved previously, the Save As dialog box will 
appear.

Step 3:	 Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored 
with extension .ods by default.

Step 4:	 Click “Save” button.

After clicking the save button, the given file name is displayed in the title bar as shown in Figure 7.24

File Extension:

	 A file extension or file name extension helps to identify the type of file. 
Following table gives the file extension of commonly used files. 
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Familiar File Type Extension

Text Files .txt

Microsoft Word Documents .doc / .docx 

OpenOffice Documents .odt

Microsoft Excel .xls / .xlsx

OpenOffice Calc .ods

Microsoft PowerPoint .ppt / .pptx

OpenOffice Impress .odp

Executable Files / Applications  .exe

Web Pages .htm / .html

Portable Document Format .pdf

Photos .jpg / .jpeg (Joint Photographic Experts Group)

Animated Images .gif (Graphical Image Format)

Audio .mp3

Audio / Video .mp4

	

File Name Application Name

Figure 7.24  Saved Spreadsheet
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Note: The saved file is stored in the 
"Document folder" by default. 

 What is save?

Technically saving is a process of 
transferring or shifting contents 

from primary memory (RAM) to 
Secondary storage medium such as 
Hard disk, Pen drive, memory chip 
etc.

7.6.2 Auto Save:

	 The OpenOffice saves a file at 
regular intervals. This is called as “Auto 
Save” feature. The default time interval 
is 15 minutes. It can be reduced even to 
one minute. If any unexpected shutdown 
occurs, this feature will recover your 
file. 

7.6.3 Closing a Worksheet

	 After saving the worksheet; it 
remains open. So, you can continue to 
work with the spreadsheet. When the work 
is finished, you should save using File → 
Save (or) Click “Save” icon (or) Ctrl + S 
and then to close the worksheet using File 
→ Close command (or) Press Ctrl + W.

7.6.4 Opening an existing worksheet

7.6.4.1 Using Open dialog box

	 To reopen an existing worksheet, 
the File → Open command (or) “Open” 
icon (or) Ctrl + O can be used. An Open 
dialog box appears as shown in Figure 7.25 
that is similar to “Save As” dialog box.

	 The name of the file to be opened 
can be chosen from the list or folder in 
which worksheet has been saved.

Default location

Available Files 
and Folders

Read only 
Option

Figure 7.25 Open Dialog box
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7.6.4.2 Using Recent documents

	 OpenOffice keeps a list of recently 
opened files. File → Recent Documents 
option can be used to open an existing 
worksheet from the list as shown in  
Figure 7.26

List of recently used files

Figure 7.26 List of Recent Documents

7.7 Copy, Cut and Paste

7.7.1 Copy and Paste Data

•	 Select the cell or cells you want to 
copy

•	 Select Edit → Copy or Click “Copy” 
icon from the standard toolbar or 
Press Ctrl + C

•	 Move the cell pointer to the cell in 
which you want to paste.

•	 Select Edit → Paste or Click “Paste” 
icon or Press Ctrl + V

7.7.2 Cut and Paste Data

•	 Select the cell or cells you want to cut

•	 Select Edit → Cut or Click “Cut” 
icon from the standard toolbar or 
Press Ctrl + X

•	 Move the cell pointer to the cell in 
which you want to paste.

•	 Select Edit → Paste or Click “Paste” 
icon or Press Ctrl + V

7.7.3 Copy and Paste Formula

•	 The process of Copy and Paste data is 
used for copying formula.

•	 When you copy a formula from one 
cell to another cell, the address of the 
pasted formula will change according 
to its row. This is called “Relative Cell 
Reference” (Refer Figure 7.27). 

•	 Example: 

While pasted it becomes = B3* C3

Originally typed formula = B2*C2

Row number

Figure 7.27 Copy and Paste formula to multiple cells
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7.7.4 Copy a formula from one cell and paste it in multiple cells:

(For illustration 1 - Refer 7.23)

Step 1:	 Copy the formula from H2 using Ctrl + C or Edit → Copy (or) click “Copy” icon.

Figure 7.28 Copy and Paste forumla to Multiple cells

Step 2:	 Select all cells (i.e. H3 to H11) in which you want to paste this addition formula.

Step 3:	 Paste the copied formula using Ctrl + V or Edit → Paste (or) Click “Paste” icon.

1.	 Open the spreadsheet which was created in Illustration 1.

2.	 Add one more column heading “Average” in I1

3.	 Create a formula to find the average of all marks in I2.

4.	 Apply the formula to the remaining cells.

5.	 Save the changes and close the file

Self Practice:

7.8 Auto Fill Feature:
 

	 You have learnt how to copy and paste a formula from one cell to other cells in the 
previous section. The process of Copy and paste can be replaced by a click and drag and it is 
called as “Auto Fill”. This is an alternate way to copy and paste. 

	 Auto Fill feature fills the contents from one cell to all the dragged cells. The content may 
be a data or formula. If you fill a relative formula, all the addresses of filled formulae will be 
changed.
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Drag Fill Handle

Figure 7.29 Drag fill handle

	 Cell pointer’s “Drag fill handle” is 
used to auto fill. Just click and drag this 
handle to fill the contents. It can be dragged 
towards right or down. Same can be achieved 
by Edit →Fill → Down (or) Edit → Fill → 
Right.

7.8.1 Auto Fill Series:

	 Auto Fill is also used to generate a 
series of values. For example, if you want to 
generate 1,2,3……. up to some length; it can 
be done by a simple click and dragging over.

	 Generating whole number series: 
(Refer Figure 7.30)

Step 1:	In cell A1, type as 1 (one) and press 
enter

Step 2:	click A1 to place the cell pointer

Step 3:	Click “Drag Fill Handle” of cell 
pointer; now the mouse pointer becomes a 
small +

Step 4:	Drag over the cells; while dragging,  
the generated values will be displayed.

Step 5:	Release the mouse pointer. Selected 
cells will be filled with series of values.

Drag
fill handle 

Drag Cells

Generated series

Figure 7.30  AutoFill series

7.8.2 Generating series using command  

	 Edit → Fill → Series Command is used 
to generate different set of series. Before 
using this feature, a set of cells should be 
selected. Using Fill Series feature, you can fill 
series of values at any direction. (Remember 
that, auto fill only fills either right or down). 
Refer Figure 7.31

Direction : Down / Right / Up / Left  
(Selected cell direction will be default)

Series type : 

Linear	 : To generate a sequence of series 
(Example 2,4,6,8,10…….)

Growth : To generate multiplication series 
(Example 2,4,8,16,32,64……)

Date	 : To generate date series (when you 
select date as series type; time unit section 
gets enabled)

AutoFill : To generate a continuous  series 
of values (1,2,3,…….). When you select 
“AutoFill”, Time unit section, End value and 
Increment text boxes become disabled.
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Time Unit: (Enabled only when you select the series type as “Date”

Day	 :	 To generate date series day-wise

Weekday	 :	 To generate date series weekday-wise

Month	 :	 To generate date series month-wise

Year	 :	 To generate date series year-wise

Start Value: 

•	 Initial value of the series should be typed

End Value:

•	 End value of the series should be typed

•	 If you fail to specify the end value, series will be generated upto the selected cells.

Figure 7.31  Fill series dialog box

•	 If your selection is less than the specified end value, series will be generated only upto the 
selected cells.

Increment:

•	 It is a middle value between the first and second value of your series. So, the next value 
(Third value) of the series will be generated based on this value.

•	 If you want to generate a decreasing order series, negative value should be specified as an 
increment value. 
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(i)	 Generate Even number series from 2 to 20

(ii)	 Generate a series of 5, 10, 15, 20 ……. upto selected cells.

(iii)	Generate a series of 2,4,8,16,……… 2048

(iv)	Generate a series of 33, 30, 27 …… upto 3

(v)	 Assume, today is Friday and generate next 25 Fridays (Date series).

Self Practice:

7.8.3 Date Arithmetic:

	 Manual date calculations can be tricky because you have to keep track of the number 
of days in a month. In spreadsheets, date calculations become very simple. Here you can	
 add a number to a date and arrive at a new date, find the difference between two dates 
and use a wide variety of function and formats to get what you want.

	 For example, enter a date 02/26/2018 in a cell, say A2. Suppose you want to calculate 
the date 80 days after this date. To do so, enter the formula, = A2 + 80, in another cell, say 
A4.

	 The date 05/17/18 appears in the cell.  

•	 Type today’s date in first cell.
•	 Type your birth date in second cell.
•	 Type the following formula in third cell = first_cell_reference – second_cell_

refernce

Find out how many days you were born?
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Part – II Editing and Formatting Worksheet

7.9 Inserting Columns, Rows and Cells

	 In Calc, Columns, rows and cells can be inserted individually or in groups.

7.9.1 Inserting a Column:

	 When you insert a new column, it is inserted to the left of the current column. The 
location of the cell pointer present, is the Current column. In Calc, you can insert a new 
column anywhere in the worksheet.

Step 1: 	Select the column where a new column should be inserted.

Step 2:	 Right-click on the selected column name that you selected. A pop-up menu  
appears.

Step 3:	 click the “Insert Columns” option from the menu.

Now, a new column will be inserted to the left of the current column.

Right Click here

To insert column click

Pop - up Menue appears

Figure 7.32  Insert Column pop-up menu

A new column can also be inserted using Insert → Columns command.  
(Refer Figure 7.32)
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Click "Insert" menu

Select "columns" option

Figure 7.33  Insert Column menu bar

1.	 Open the spreadsheet which was created in Illustration 1.
2.	 Insert a new column between column E and F
3.	 Give the heading as “Eco” and Enter the Economics marks for all the students
4.	 Insert one more column between the columns, Name and Tamil marks. 
5.	 Give the heading as “Date of Birth” and Enter the date of birth for all the students.
6.	 Save the changes and close the file.

Practical Practice:

7.9.2 Inserting Rows

	 When you insert a new row, it is inserted above the current row. The location of the 
cell pointer present is the current row. In Calc, you can insert a new row anywhere in the 
worksheet.

Step 1: 	Select the row where a new row to be inserted.

Step 2:	 Right-click on the row number, a pop-up menu appears

Step 3:	 click “Insert Rows” option from the menu.

Now, a new row will be inserted to above the current row.
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Right Click here to select the row as well as get popup menu

Select "Insert Rows"
Figure 7.34 Insert Rows popup menu

Insert → Rows command is used to insert a new row.  Refer Figure 7.35

Click "Insert" menu

A new "Row" 
inserted 

above the 
selected row

Select "Rows" option

Figure 7.35  Insert Rows menu bar
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1.	 Open the spreadsheet which was created in Illustration 1.

2.	 Insert 8 rows one by one, then insert the following student details

3.	 Save the changes and close the file.

Reg. No Name Date of Birth Tam Eng CS Eco Com Acc
12101 Sarika S 26/05/2001 145 135 145 125 180 196
12102 Jewees Celcya J 11/04/2001 102 165 134 95 180 134
12103 Yuvarani T 27/06/1999 172 130 107 155 162 130
12104 Meharunisha I 30/05/2001 132 146 112 185 192 176
12105 Priya W 07/03/2000 130 172 100 92 162 155
12106 Vijaya Vasavi K 03/06/2001 198 175 149 148 158 135
12107 Deepika B 14/03/2001 120 182 103 144 107 186
12108 Viji V 19/04/2001 137 173 128 148 125 177

Self Practice:

 
7.9.3 Inserting Cells

•	 To insert a new cell between two existing cells, just right-click on any existing cell

•	 From the pop-up menu, select “Insert” option Figure 7.36 Insert cells

•	 The “Insert Cells” dialog box appear with four options

	 i) Shift cells down	 ii) Shift cells right	 iii) Entire row	 iv) Entire Column

•	 Any one of the four options is selected. 

•	 Selecting “Shift cells down”, inserts a new cell in the present location and the existing 
cells are shifted downwards. 

•	 Selecting “Shift cells right”, inserts a new cell in the present location and the existing 
cells are shifted towards right.

•	 Selecting the “Entire Row” or “Entire Column” option, inserts a new row or a new 
column.v 

Figure 7.36 Insert cells
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7.9.4 Inserting multiple columns or rows

Multiple columns or rows can be inserted 

at once rather than inserting one at a time.

•	 Select multiple rows or columns for 

insertion.

•	 Follow steps as in 7.9.1 and 7.9.2 

7.9.5 Inserting Columns, Rows and Cells 

using “Insert Cells” Toolbar

•	 Insert Cells floating toolbar is also 

used to insert cells, rows and columns

•	 Click View → Toolbars → Insert Cell

•	 A tiny floating toolbar appears on the 

screen with four icons. Using these 

icons, you can insert cells, rows and 

columns. Refer Figure 7.37

Insert Rows

Insert 
Columns

Insert cell right
Insert cell down

Figure 7.37  Insert cell tool bar

7.10 Deleting columns and rows

	 A single or multiple columns or 

rows can be deleted.

	 All spreadsheets have some 
specific number of rows and columns, 
then how can you insert an additional 
row or column. Is this possible?

Technically this is NOT POSSIBLE.

	 Additional column, row or 
even cell cannot be inserted in any 
spreadsheet. When you insert a 
column or row, the contents within 
the column or row will be shifted to 
the next column or row. But visually 
it is felt that a new column or row has 
been inserted.

Inserting a new Column or 
row is really possible in a 
Spreadsheet?

7.10.1 Delete single column or row

	 A single column or row can be 
deleted by using the mouse:

•	 Select the column or row to be deleted.

•	 Choose Edit →Delete Cells from the 
menu bar.

(Or)

•	 Right-click on the column or row 
header.

•	 Choose Delete Columns or Delete 
Rows from the pop-up menu.

7.10.2 Delete multiple columns or rows

	 Multiple columns or rows can be 
deleted at a time. Refer Figure 7.38
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•	 Select the required columns or rows 
for deletion.

•	 Right-click on the selected columns 
or row.

•	 Choose Delete Columns or Delete 
Rows from the pop-up menu or Edit 
→ Delete Cells.

1.	 Open the spreadsheet which was 
created in Illustration 1.

2.	 Delete the details of any 3 
students. Save the changes and 
close the file.

Practical Practice:

	 Same as inserting column or 
row, Deleting a column or row is 
also not possible. No one can delete 
any column or row in a spreadsheet. 
When you delete a column or row, all 
the contents will be removed from 
the column or row. Actually, this is 
also another kind of deleting contents 
from a column or row.

Deleting Column or Row is 
not Possible

7.11 Formatting Worksheet

	 Formatting Data in a cell gives 
additional effect to the text. Additional 
effect includes changing the font style, 
font size, automatic wrapping, bold, 
underline, italic etc. The data in Calc 
can be formatted in several ways. Using 
formatting icons can be used.

Selected columns

To Delete Selected 
columns; click 

here

Figure 7.38  Delete multiple columns
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7.11.1 Text Formatting

	 Making  the cell contents as bold, italics, underlined, changing font style, size, 
colour etc., comes under text formatting. All text formatting options are available as icons 
in Formatting toolbar learnt in OpenOffice Writer. Figure 7.39(a)  Text Formatting Toolbar

Moving handle
Bold Italic

Underline

Merge 
Cells

Align 
Center

Justify 
Align

Styles Font Styles Fond Size

Figure 7.39(a)  Text Formatting Toolbar

Formatting 
Option

Keyboard 
Shortcut

Description

Font style Used to change 
Font style

Font size Used to change 
Font size

Bold Ctrl + B
Used to make 
the data as 
Bold

Italic Ctrl + I Used to 
italicize  data 

Underline Ctrl + U
Used to 
underline the 
data

Left Align Ctrl + L Left Align data 
within a cell 

Right Align Ctrl + R
Right Align 
data t within a 
cell

Center Align Ctrl + E
Center the 
data within a 
cell

Justify Ctrl + J

Align the data 
evenly both on 
left and right 
side of a cell

Merge cell
Makes selected 
cells as a single 
cell

7.11.2 Number formatting

	 Number formatting options are 
used to visually change the format of 
a numeric content. These formatting 
changes are only for visual as, it does not 
change its original value. For example, To 
display a number as currency form use 
Number format: Currency.  

Number format: Currency will be used as 
shown Figure 7.39(b).

Currency

Percentage
Delete 

Decimal

Add 
Decimal

Standard
Figure 7.39(b) Formatting toolbar

Number 
Format

Keyboard
Shortcuts

Currency Symbol Ctrl+Shift+4
Percent Ctrl+Shift+5
Standard Ctrl+Shift+6
Add Decimal Place
Delete Decimal Place
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1.	 Open the spreadsheet which was created in Illustration 1.

2.	 Align all headings as center and make them bold.  

3.	 Align all Register numbers and marks in center 

4.	 Apply different font styles to the entire worksheet.

5.	 Save the changes and close the file

Practical Practice:

Part – III Working with Functions and Chart

7.12 Functions

	 OpenOffice Calc has more than 350 
functions under 11 categories. Functions 
are predefined formulae already available 
with Calc. They are used to perform 
several frequently done calculations. 
Every function has a unique name and 
a prototype. Functions are categorized 
according to their functionality. For 
example, the functions such as Sum, 
Average, Sin, Cos etc., are categorized as 
“Mathematical Functions”.

7.12.1 Inserting Functions into 
Worksheet:

	 A function can be inserted by 
(i) Direct Insert Method or (ii) Using 
Function Wizard method. 

7.12.1.1 Direct Insert method:

	 If you know the function name and 
its syntax, it can be directly typed in any 
cell of the worksheet.

	 For example, SUM is the most 
frequently used function to add a set of 
values. The syntax of the SUM ( ) is 

= SUM (range 1; range 2; range 3…… 
range n) 

	 If you want to know the sum of the 
values in A1, A2, A3, A4 and in A5, Place 
your cell pointer in A5 and directly type 
the formulae as follows.

= SUM (A1:A4)

	 While inserting a function the 
following points should be kept in mind.

1.	 A function should begin with an equal 
sign.

2.	 Use proper name for the function to 
be used.

3.	 Arguments should be given within 
the brackets as per the syntax. Each 
function has a unique argument list.

4.	 Press “Enter” key after typing the 
function.

= Sum (A1 : A4)

Funciton name
Funciton arguments

Equal
Sign

First 
Cell

Last
Cell

Figure 7.40 Function Syntax
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1.	 Open the spreadsheet which was created in Illustration 1.

2.	 Delete all the formula in Total column.

3.	 Use SUM function to add all the marks of each student.

4.	 Save the changes and close the file

Self Practice:

7.12.1.2 Using Function Wizard method

	 A function can inserted using Function Wizard in Calc. Function Wizard is a dialog 
box provides the step-by-step procedure to insert a function. Function wizard can be 
invoked by clicking the Function Wizard icon on the Formula bar (or) Insert → Function 
(or) Ctrl + F2. Refer Figure 7.41

Function category drop down list box:

	 Function Wizard has two tabs viz. Functions and Shortcuts. In Functions Tab, the 
list of categories is available in Category drop down list box. In Calc, the functions are 
categorized into 11 types. They are,

1. Database 2. Date and Time 3. Financial 4. Information
5. Logical 6. Mathematical 7. Array 8. Statistical
9. Spreadsheet 10. Text 11. Add-in

List of Functions

Function Name 
with arguments

Short description 
about the Function 

Function Category List box

Figure 7.41 Function wizard
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If you select any particular category, the 
Functions list box shows the functions 
which  belongs to the selected category. If 
“All” is selected under category all functions 
in calc is displayed in alphabetical order. 
Refer Figure 7.42

Selected Category

List of Functions

Figure 7.42 Function wizard – Function 
Category list box

Function Description

	 When you select a function, the 
function wizard shows the function name, 
syntax and a small description about the 
function on the right side of the dialog 
box. Refer Figure 7.43

Inserting a function using Function 
Wizard: (with Cell Reference)

 The following steps explains to insert 
POWER( ) function in a cell.

About POWER ( ) function:

	 POWER ( ) is a function which is 
used to calculate power of an exponent 
value of a number. This function is 
categorized as a Mathematical function. 
There are two inputs needed to find the 
power value of a number. They are, Base 
value and exponent value. For example, 
to find the value of 25 to the power of 2 
(252) where 25 is the base value, 2 is the 
exponent value.

The syntax of POWER( ) is = POWER 
(Base ; Exponent)

	 Both Base and Exponent are 
arguments. In Calc, arguments are 
separated by a semicolon. 

Inserting POWER( ) in a worksheet:

Step 1:	 In cell A2 type the base value 25

Step 2:	 In cell B2 type the exponent value 
2

Step 3:	 Move the cell pointer to C2; in 
which you want display result.

Step 4:	 Click fx icon from Formula bar 
(or) choose Insert → Functions 
(or) Press Ctrl + F2.

Step 5:	 Pull down category list box, Choose 
“Mathematical”

	 All function under Mathematical 
category is displayed in the 
“Functions” list box
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Step 6:	 Scroll the “Functions” list box and select “POWER( )”. The function wizard shows the 
description about the selected function on the right corner of the dialog box

Step 7:	 Click “Next” command button.  Now, Function wizard appears as shown in the Figure 
7.44. 

Selected Category

Selected 
Function

Description about 
Function

Function
Syntax

Function
Name

.

Figure 7.43 Function wizard dialog box

Step 8:	 Click on the cell which is contains the base value (A2).

Now, the minimized wizard shows the cell address you have selected (A2). Refer Figure 7.45

Function button 
(Nesting of Functions

Select Cell 
button

Select Function

Figure 7.44 Function wizard
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Function name in input box

Shrinked Function wizard 
with Function nameSelected Cell

Maximize

Figure 7.45 Function wizard

Step 9:	 Click “Maximize” button to display full wizard. Now, Function wizard appears as 
shown in Figure 7.46

Cell address with 
contains Base

Formula for finding 
Power

Figure 7.46 Function wizard

Base box shows the cell address which contain base value.

Step 10:	 Directly type the cell address which contains exponent, in Exponent box; or 
repeat steps 7, 8 and 9.
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After entering Base and Exponent cell references, the function wizard appears as shown 
in Figure 7.47

Result  to the 
Function

Base value cell 
address

Exponent value cell 
address

Formula
Result to the 

formula

Figure 7.47 Function wizard

	 The formula box displays the syntax of the function with input values and Result box  
displays the result value.

Step 11:	 If the result is correct, click “OK” button else click “Back” button to display the 
previous page of this wizard. 

Inserting a function using Function Wizard: (with direct values)

	 In the previous example, Cell addresses are used for Base and Exponent values. In Calc, 
direct values can be used instead of using cell reference (i.e. cell address) to find the same 
result. 

	 In this case, type base and exponent value instead of cell address. Function wizard 
displays the result in the current cell. Refer Figure 7.48 shown below.
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Result of the function

Vaues typed

No more steps

Function Formula bar 
with values

Figure 7.48 Function Wizard (with Direct values)

1.	 Open a new worksheet.

2.	 In cell A1 type as “Value”

3.	 In cell A2 type as “Square root”

4.	 In cell B1 type any value

5.	 In cell B2 insert the function to find the square root of the value in B1

6.	 After getting square root, change the value in B1, observe changes in result. 

7.	 Use the same function in another sheet directly i.e. without using function wizard.

Self Practice:

7.13 Working with Chart

7.13 Working with Chart

	 One of the most important features of spreadsheet is the ability to create charts 
based on numeric data. The charts are used to present data in an easy manner. Creating 
charts is the key factor for the of success of spreadsheet. OpenOffice Calc provides a 
“chart wizard” to create and manipulate charts.
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7.13.1 Chart Wizard

	 Chart wizard is used to insert charts in Calc. Chart wizard can be invoked by 
clicking “chart” icon from standard toolbar or choosing Insert → Chart command. A 
"Chart wizard" appear as shown in Figure 7.49

	 Chart wizard dialog box has 4 steps viz. (1) Chart type (2) Data Range (3) Data 
Series and (4) Chart Elements. The “Next” button is used to move from one step to another 
step.

Step 1: Chart type

	 The first step of “Chart wizard” is used to select Chart type. All available chart 
types are listed under the “Choose a chart type” list box. On the right side of the list box 
shows style of the selected chart; each chart type has different styles. 

Figure 7.49 Chart Wizard – Step 1: Chart type

	 For example, Column chart has three styles viz. Normal, Stacked and Percent 
Stacked. Refer Figure 7.49

	 "3D Look" check box helps to display the selected chart type in an attractive form. 
3D Look is applied only for Column, Bar, Pie and Area chart type.  Refer Figure 7.50 

Click, “Next” button to move to the second step.
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Column Chart 3D Cylinder shape

Chart styles

List of 3D 
shapes3D look 

Checkbox

Figure 7.50 Chart Wizard – Step 1: Chart type with 3D Look

Step 2: Data Range

	 In this step, specify the range of data for which the chart should be created in “Data 
range” text box or click “Select data range” button which is at the end of the textbox to minimize 
the wizard.

	 If the user had selected the data before invoking "chart wizard", the selected range will 
appear automatically in the textbox as shown in Figure 7.51. 

	 There are two checkboxes used to set the first row or first column or both, as X and Y 
axis labels to the chart. 

	 Click "Next" button to move to the third step.

Figure 7.51 Chart Wizard – Step 2: Data Range
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Step 3: Data Series

	 In this step, the user can fine tune the data to be included in the chart. If you don’t 
want to include any column, click the column names listed in “Data Series” box and click 
on “Remove” button or if you want to add some more columns click “Add” button.  Refer 
Figure 7.52. This is useful only if you have very specific requirements for data in your 
chart. Otherwise simply click “Next” button to move the last step.

Step 4: Chart Element

	 This step is used to insert or change titles and legend. In “Title” box, type the title 
for the chart, to add a subtitle type it in the “Subtitle” box. Refer Figure 7.53. For example, 
A chart for showing the highest mark holder in you class, you may enter as “Highest Mark 
holder” as title and “Class XII F” as subtitle.

Figure 7.52 Chart Wizard – Step 3: Data Series

Figure 7.53 Chart Wizard – Step 3:  Chart Elements
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	 User can add or modify the labels of X and Y axis. 

	 To create a chart click “Finish” button.

7.13.2 Demo for creating a chart

	 Type the following data in a new worksheet as in Figure 7.54. The following steps 
is followed to create a chart for the given data. 

Step 1 – Select Data:	

•	 Select the data from A1 to F11.

Step 2 – To  open the chart wizard:

•	 Click “Chart” icon from Standard toolbar (or) choose Insert → Chart. 

Step 3 – Selecting Chart type and shape:  (Refer Figure 7.55)

Figure 7.54 Rainfall (in mm) data of ten districts in 2010

Figure 7.55 Chart Wizard – Step 1 Chart Type
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•	 Select “Chart type” as Column and style as Normal 

•	 Check “3D Look” and click “Cylinder shape”

•	 Click “Next” button.

•	 If the user wants change any other type or shape, click on the style image. Preview of 
the chart displayed on the backgroup of the chart wizard. So, you can view the chart 
at every stage of design. 

Step 4 – Defining Data range: (Refer Figure 7.56)

•	 In this case, the data has been selected earlier. So, the selected data range is displayed 
in the “Data range” box.

•	 Other settings are by default. Click “Next” to move to  step 5.

Figure 7.56 Chart Wizard – Step 2 Data Range

Step 5 – Adding or Removing Data series: (Refer Figure 7.57)

•	 “Data Series” list box shows all the columns to be included in the chart.

•	 Click on the “Total” in the data series box and click “Remove” button to remove the  
column. 

•	 If you don’t want to add or remove anyother column click “Next” button to move to 
the last step.
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Figure 7.57 Chart Wizard – Step 3 Data Series

Step 6 – Adding Title, Subtitle, Name of X and Y axis: (Refer Figure 7.58)

•	 Type the title and subtitle of the chart in “Title” and “Subtitle” box

•	 Type the name of the X and Y-axis in the respective boxes.

•	 The Display legent text box is selected to the right which is the default.

•	 Click “Finish” button.

	 Now the chart will be displayed as in Figure 7.59.

7.13.3 Editing Chart elements:

	 After inserting a chart any element of the chart can be modified. To modify the 
element 

	 (i) Double click on the element 

	 (ii) Right click on the selected element

	 (iii) Select Format from the popup menu.

	 For example, To change the display pattern of the X-axis, double-click on the X-axis 
and then right-click on it. A pop-up menu appears as shown in the Figure 7.60.

•	 In this popup menu, click “Format Axis…” option.
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Figure 7.58 Chart Wizard – Step 4 Chart Elements

Now the chart will be displayed as given below
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Figure 7.59 Chart
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Figure 7.60 Chart element formatting pop-up menu

•	 Now, a Format Axis dialog box appears as shown in Figure 7.61

Figure 7.61 Chart Element Properties dialog box
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Figure 7.62 Completed Chart

Select “Label” tab. 

•	 In Text Orientation spinbox, type as 90 degree or click and drag the Text direction animated 
handle.

•	 Click “OK” button.

•	 Now, the chart will be as in Figure 7.62 

1.	 Open the spreadsheet which was created in Illustration 1.

2.	 Create a column chart with 3D “cone” shape showing the total marks of all students.

Self Practice:
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Part – IV Sorting Filtering and Page setup

7.14 Advanced data analysis tools

	 A spreadsheet is a “Flat file database”. Thus, database operations such as sorting, 
filtering can be done on spreadsheet. The “Data” menu of OpenOffice calc provides maximum 
data analysis tools such as sorting, filtering, validity etc., In this part, the sorting and filtering 
feature is to be learnt. 

7.14.1 Database

	 A database is a repository of collections of related data or facts. It arranges them in a 
specific structure. The table given below contains details of students in a class. 

Sl.
No Class Group 

Code Student Name Gender
Comm 
Date of 
Birth

Date of 
Birth Religion

1 XII - F1 302 GANDHIMATHI N F SC 02/10/2000 H

2 XII - H2 402 SANDHIYA D F SC 19/08/2000 H

3 XII - H2 402 SUMATHI P F BC 06/09/1999 H

4 XII - F1 302 JAYASREE J F BC 09/06/2001 H

5 XII - H1 402 JOTHIKA A F SC 07/04/2001 H

6 XII - H2 402 RAMYA T F MBC 23/11/2000 H

7 XII - F1 302 KOWSALYA T F SC 14/12/2000 H

8 XII - F1 302 ASHA A P F SCA 14/09/2000 H

9 XII - A 102 VENNILA T P F BC 14/02/2000 H

10 XII - F2 302 SANGEETHA G F MBC 14/01/2000 H

Table 7.14.1 Student Database

	 The entire collection or related data in one table is referred to as a File or a Table. 
Each row in a table represents a Record, which is a set of data for each database entry. 
Each table column represents a Field, which groups each piece or item of data among the 
records into specific categories. (Refer Figure 7.63)

7.14.2 Sorting:

	 Sorting is the process of arranging data in ascending or descending order. There are 
two types of sorting in OpenOffice Calc. They are, 
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(1)	 Simple Sorting

(2)	 Multi Sorting

(3)	 Sort by selection

(1) Simple Sorting

	 Arranging data using single column is known as simple sorting. For sorting the 
data, calc provide two icons on the standard tool bar viz. (1) Sort Ascending (2) Sort 
Descending.

•	 Sort Ascending – Arrange data in alphabetical order (A to Z / Small to Large)

•	 Sort Descending – Arrange data in reverse order (Z to A / Large to Small)

Field

Record

Figure 7.63 Spreadsheet Data Table

Sorting data

Step 1: Place cell pointer in the field (column) to be sorted

Step 2: Click Sort Ascending or Sort Descending icon
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	 OpenOffice Calc, sort the data of selected column and its corresponding values 
present in other columns are also arranged simultaneously. Refer Figure 7.65

Sort Ascending Sort Descending

Figure 7.64 Standard Tool Bar with Sort Ascending / Descending

Click "Sort Ascending" icon to arrange ascending order

Place the Cell pointer 
anywhere in name column

				    	 Firgure 7.65 Sort Ascending

(2) Multi Sorting

	 Sorting data based on more than one field (column) is known as multi sorting. For 
example, the worksheet containing data of 20 students belongs to different groups and 
classes. To rearrange this data alphabetically by name and group code, multi sorting is 
used. Refer Figure 7.66.
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Multi-sorting data 

Step 1:  	 Select Data → Sort 

Name are arranged in Ascending order According to names, other data also 
rearranged

Step 2:  	 Sort dialog box appears. (Refer Figure 7.67)

Step 3: 	 Select the field name (Student name) in which you want to sort from the “sort 
by” dropdown list box and then choose order of sorting i.e. Ascending or 
Descending. Ascending is the default selection.

Step 4: 	 Select another field name (Group Code) from the “Then by” dropdown list box 
and choose the order of sorting to this column.

Step 5: 	 Click “OK” button.

	 In OpenOffice Calc, multi sort can be done only for three fields.
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Select First column in which 
the data arranged first

The selected the second and third column in which the 
data to be arrange based on the first column

Select order of 
arrangement

Fainally Click 
"Ok"

Figure 7.67  Multi-sorting dialog box

(3) Sort by selection

	 In Calc sorting can be done on selected range. But this kind of sorting is generally not 
recommended, because the other relevant data are also not sorted. Therefore, OpenOffice 
Calc displays a warnning message for this type of sorting. Refer Figure 7.68.

Sorting data by selection:

Step 1: 	 Select any particular field in which you want sort.

Step 2: 	 Click required Sort icon from standard tool bar or Data → Sort command.

	 Calc, display a “Sort Range” warning message as shown in the Figure 7.68

	 “Sort Range” message box has two options, viz. (1) Extend selection (2) Current 
selection.

Step 3: 	 “Extend Selection” – Sort all the data based on the selection. 

	 “Current Selection” – Sort only the selected range of data, remaining data are not 
sorted.
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7.14.3 Filtering

Filter is a way of limiting the information that appears on screen. Filters 

Figure 7.68 Sort by selection

are a feature for displaying and browsing a selected list or subset of data from a worksheet. 
The visible records satisfy the condition that the user sets. Those that do not satisfy the 
condition are only hidden, but not removed.

	 OpenOffice Calc allows three types of filters. They are AutoFilter, Standard Filter 
and Advanced Filter.

(1) Auto Filter:

	 Auto Filter applies a drop-down list box to each field (columns) filled with similar 
data available in that field. Using the list box item, you can filter the data that matches the 
criteria of the data concerned. 
Using Auto Filter:

•	 Click Auto Filter icon	 available on the “Standard tools bar” (or)  
click Data → Filter → Auto Filter
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•	 The list box contains similar data in the fields. Refer Figure 7.69 and 7.70

•	 Each list box item will be considered as filter criteria. 
Drop down list box

Figure 7.69 Spreadsheet table with Auto Filter

Figure 7.70 Auto Filter dropdown list box

•	 Select the data item from the list box. Now, Calc shows only the records which are 
satisfy the selected criteria.

Example:

	 If you want to apply an auto filter to the contents of the table 7.14.1, follow the 
following two steps

Step 1: Place cell pointer anywhere in the table

Step 2:  Click Auto Filter icon 	   available on the “Standard tools bar” (or) Click Data → 
Filter → Auto Filter

In the above table, if you want to view only the students belongs to the Group code 402;

•	 Click the dropdown list box’s drop arrow (a tiny triangle) to get the filter criteria. 
(Refer Figure 7.70)
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•	 Select group code 402 from the list

•	 The spreadsheet displays only the student’s details those who are studing in group 
code 402 (Refer Figure 7.71) and the remaining details are only hidden. 

Figure 7.71 Filtered details

Figure 7.72 Standard Filter dialog box

Removing Auto Filter:

•	 To remove auto filter, click “Auto filter” icon once again .

•	 The original table is displayed without filter.

(2) Standard Filter: Auto filter is used only for single criteria on a data, whereas the 
Standard filter is used for multiple critieria to filter.

Step 1: 

•	 Select Data → Filter → Standard Filter.
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•	 Now, the entire data is selected and 
"Standard Filter" dialog box dispalys 
as shown in Figure 7.73.

Step 2: 

•	 Select the column heading from the 
“Filed name” list box for first criteria.

•	 Select conditional opeator such as >, 
<, = etc., from “Condition” list box.

•	 Type or select the value of critera in 
the “Value” box.

Step 3:

•	 Select the one of the logical operator 
(And / Or) from “Operator” list box 
to fix second criteria.

•	 Follow the step 2, for the next criteria.

Step 4:

•	 Click “OK” to finish.

Example for Standard filter:

If you want to filter the records of “BC” 
students of group code 402 from the table 

7.14.1

Step 1: Select Data →Filter → Standard 
Filter

•	 Now, “Standard Filter” dialog box 
appears as in Figure 7.73

Step 2: In “Standard Filter” dialog box, 
select the first criteria;

•	 Select Field name as Group code

•	 Select Condition as =

•	 Type or select Value as 402

Step 3: To select the second criteria;

•	 Select Operator as “AND”

•	 Select Field name as Class

•	 Select Condition as = 

• 	 Type or select Value as XII- H2

Figure 7.73 Standard Filter
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Step 4: Click “OK”

•	 Now, the table displays only the recods which are match for the given two criteria. 
Refer Figure 7.74.

Remove Standard Filter:

•	 Select Data → Filter → Remove Filter

Figure 7.74 Class XII student of group 402

Figure 11.75 Page Style dialogue box

•	 “Header” tab is used to create header
•	 “Footer” tab is used to create footer
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7.15 Setting the page size, Orientation and Margins

•	 To set page size, select Format → Page  

•	 Page style dialoge box will appears as shown in figure 7.75.

•	 “Page” tab is used to change page size, orientation and margin

•	 “Header” tab is used to create header

•	 “Footer” tab is used to create footer

Workshop 1 

1. Create a worksheet with following data

Emp. 
No

Name of Emp. Basic DA HRA CCA MA GPF IT HF

1001 Manivannan M 25500

25
 %

 o
f B

as
ic

%
15

 o
f B

as
ic

 a
nd

 D
A

600 300

12
 %

 o
f B

as
ic

%
10

 o
f G

ro
ss

250

1002 Kannan K 20200 600 300 250

1003 Gowrishankar N V 24300 600 300 250

1004 Lenin K 23400 600 300 250

1005 Suryanarayanan T 24100 600 300 250

1006 Ramesh K 18500 600 300 250
1007 Govindasami A 13200 600 300 250
1008 Kannan S 20250 600 300 250
1009 Penchil Rao K 28300 600 300 250

1010 Logeswaran M 30200 600 300 250

1011 Arumugam E 12000 600 300 250

1012 Vasu G N 25000 600 300 250

Based on the above data, 

(1)	 Calculate the Gross Salary, Total Deductions and Net Salary

(2)	 Insert “IT Cess” column and calcualte 3% of cess to all employees
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7.15 Setting the page size, Orientation and Margins

•	 To set page size, select Format → Page  

•	 Page style dialoge box will appears as shown in figure 7.75.

•	 “Page” tab is used to change page size, orientation and margin

•	 “Header” tab is used to create header

•	 “Footer” tab is used to create footer

Workshop 1 

1. Create a worksheet with following data

Emp. 
No

Name of Emp. Basic DA HRA CCA MA GPF IT HF

1001 Manivannan M 25500

25
 %

 o
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as
ic

%
15

 o
f B
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 a
nd
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600 300
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 o
f B
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1002 Kannan K 20200 600 300 250

1003 Gowrishankar N V 24300 600 300 250

1004 Lenin K 23400 600 300 250

1005 Suryanarayanan T 24100 600 300 250

1006 Ramesh K 18500 600 300 250
1007 Govindasami A 13200 600 300 250
1008 Kannan S 20250 600 300 250
1009 Penchil Rao K 28300 600 300 250

1010 Logeswaran M 30200 600 300 250

1011 Arumugam E 12000 600 300 250

1012 Vasu G N 25000 600 300 250

Based on the above data, 

(1)	 Calculate the Gross Salary, Total Deductions and Net Salary

(2)	 Insert “IT Cess” column and calcualte 3% of cess to all employees

(3)	 Delete the records of “Govindasami” and “Arumugam”.

(4)	 Insert four new rows and enter the following employee details.

(5)	 Calculate the Total amount of GPF, IT and Cess

Emp. No Name of Emp. Basic DA HRA CCA MA GPF IT HF
2001 Murali G 24750
2002 Munirathnam A 23550
2003 Ramakrishnan V G 25500
2004 Srinivasan R 27500

Workshop: 2 

1. Create a new worksheet in OpenOffice Calc.

2. Enter the following stock and sales details of “Chennai whole sale Marketing Pvt. 
Ltd.” during the month of Jan-2018.
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100 Marie Gold 120 345 15 147 5%
101 Milk Bikis 85 106 10 63 5%
102 Dark Fantasy 75 147 25 43 3%
103 Nutri Choice 250 98 50 12 10%
104 Lays potato chips 52 172 15 152 4%
105 Oreo 120 112 25 85 6%

3. Calculate the following using formula or function

(i) Amount of Discount, Selling price and Amount of sales for each product 

(ii) Total amount of discount and Sales of the month

(iii) Closing stock of each product

4. Draw a Pie chart to show the highest selling product.
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Workshop: 3 

1. Create a worksheet in OpenOffice Calc.

2. Enter the following details of loan sanctioned during the month of January 2018 of 
“Tamil Finance Corporation”.

A
C

 N
o 

Em
p.

 N
o

N
am

e

A
m

ou
nt

 o
f L

oa
n

Lo
an

 S
an

ct
io

n 
da

te

D
ur

at
io

n 
of

 L
oa

n

R
at

e 
of

 In
te

re
st

In
te

re
st

 (R
s)

To
ta

l A
m

ou
nt

D
ue

 d
at

e

2001 Senthil 250000 02/01/2018 120 days 9.5%

2002 Kumar 175000 15/01/2018 150 days 9.5%

2003 Ibrahim 550000 16/01/2018 140 days 10.5%

2004 Valli 375000 21/01/2018 210 days 10%

2005 Charles 450000 28/01/2018 130 days 10.5%

3. Create the formula to calculate

(i) Interest, Total amount and due date.

(ii) Grass total of amount of loan, interest and total amount.

4. Insert 5 new rows between Kumar and Ibrahim and include the following details
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3001 Pari 250000 03/02/2018 125 days 9.5% 5%
3002 Arul 375000 07/02/2018 155 days 9.5% 5%
3003 Raman 350000 10/02/2018 130 days 10.5% 3%
3004 Givind 450000 10/02/2018 100 days 10% 10%
3005 Zeenath 800000 26/02/2018 90 days 10% 4%
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Wo

Points to Remember:

•	 Spreadsheet is a very useful office automation tool for organization, analysis 
and storage of data in a tabular form.

•	 Daniel Bricklin and Bob Frankston developed the first spreadsheet software 
called “VisiCalc” in 1979 for Apple II.

•	 OpenOffice Calc is popular open source spreadsheet application software 
presently maintained by Apache Foundation.

•	 A worksheet is a grid of cells with a programmable calculator attached to each 
cell.

•	 OpenOffice Calc version 4.1.5 contains a total of 1024 columns and 10,48,576 
rows.

•	 Intersection of every row and column makes a box which is called as “Cell”.

•	 Cell pointer is a rectangle element which can be moved around the worksheet. 

•	 The cell in which the cell pointer is currently located is known as “Active cell”.

•	 All formula should start with an equal sign. 

•	 There are four types operators supported by calc.

•	 The charts are used to present numerical data in an easy manner.

Activity

Student Activity 

1. 	 Based on the concept of calculation using formula / functions, make the students to 
create various worksheet data.

2. 	 Make the students prepare Charts and manipulate data using sorting and filtering 
features.

Teacher Activity

1. 	 To show the demo of working with spread sheets using simple example in class room.
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Evaluation

Part – I 

Choose the correct answer
1.	 Which is the first electronic spreadsheet?

	 (A)Excel		  (B) Lotus 1-2-3

	 (C) Visicalc		  (D) OpenOffice Calc

2.	 Which of the following applications was the parent to OpenOffice Calc?

	 (A)Visicalc		  (B) LibreCalc	

	 (C) Lotus 123		  (D) StarOffice Calc

3.	 Grid of cells with a programmable calculator:

	 (A)Spreadsheet		  (B) Database		

	 (C) Word processor		  (D) Linux

4.	 A column heading in Calc is represented using 

	 (A)Number		  (B) Symbol 	

	 (C) Date		  (D) Alphabet

5.	 Which key is used to move the cell pointer in the forward direction within the worksheet?

	 (A)Enter		  (B) Tab	

	 (C) Shift + Tab		 (D) Delete

6.	 A formula in calc may begin with

	 (A) =			   (B) +		

	 (C) -			   (D) All the above

7.	 What will be the result from the following formula (Assume A1=5, B2=2)? + A1^B2

	 (A) 7			   (B) 25	

	 (C) 10			   (D) 52
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8.	 What will be the result from the following expression (Assume H1=12, H2=12)? = 
H1<>H2

	 (A) True		  (B) False	

	 (C) 24			   (D) 1212

9.	 Which of the following symbol is used to make a cell address as an absolute reference?

	 (A) +			   (B) %		

	 (C) &			   (D) $

10.	  Which of the following key combinations is used to increase the width of the current 
column?

	 (A)Alt + Right arrow				    (B) Ctrl + Right arrow

	 (B)Alt + Left arrow	  			   (D) Ctrl + Left arrow

Part – II
Very Short Answers
1.	 What are the types of toolbars available in OpenOffice calc?

2.	 What is a Cell pointer? 

3.	 Write about the text operator in OpenOffice Calc.

4.	 Write the general syntax of constructing a formula in Calc.

5.	 What are the keyboard shortcuts to cut, copy and paste?

6.	 Can you edit the contents of a cell? If yes, explain any one of the method of editing the 
cell content.

7.	 What are the options available in “Insert Cells” dialog box?

8.	 Match the following

A B
(a) Cut, Copy and Paste (1) Absolute Cell
(b) Cell pointer (2) Status bar
(c) Selection Mode (3) Standard Toolbar
(d) $A5$ (4) Active cell

9.	 Define the following (i) Text Operator  (ii) Rows and Columns of spreadsheet
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10.	  Differentiate between Copy -Paste and Cut-Paste

Part-III
Short Answers
1.	 Write a short note on OpenOffice Calc.

2.	 Write about inserting columns and rows in Calc.

3.	 Differentiate Deleting data using Backspace and Delete

4.	 Write any three formatting options.

5.	 In cell A1=34 A2=65 A3=89 write the forumla to find the average.

Part-IV
Explain in Detail
1.	 Explain about changing the column width in Calc.

2.	 Write the steps to generate the following series. 5, 10, 20 ….. 2560

3.	 Read the following table

A B C D E
1 Year Chennai Madurai Tiruchi Coimbatore
2 2012 1500 1250 1000 500
3 2013 1600 1000 950 350
4 2014 1900 1320 750 300
5 2015 1850 1415 820 200
6 2016 1950 1240 920 250

	 Above table shows the sales figures for “Air Cooler” sold in four major cities of Tamilnadu 
from the year 2012 to 2016. Based on this data, write the formula to calculate the following.

(1)	 Total sales in the year 2015.

(2)	 Total sales in Coimbatore from 2012 to 2016.

(3)	 Total sales in Madurai and Tiruchi during 2015 and 2016.

(4)	 Average sales in Chennai from 2012 to 2016

(5)	� In 2016, how many “Air Coolers” are sold in Chennai  
compared to  Coimbatore? 
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Spreadsheet Sheet of paper that shows accounting or other data  
in rows and columns

What-if analysis It is a process of changing the values in a cell to see  
how those changes will affect output.

VisiCalc The first electronic spreadsheet application

GUI Graphical User Interface

Excel Familiar spreadsheet application developed by Microsoft 
Corporation. 

Cell Intersection of rows and column

Cell Pointer A rectangular box, highlighting the cell in a spreadsheet.

Active cell A cell in which the cell pointer is presently locating

Formula A formula is an expression telling the computer what 
mathematical operation to perform upon a specific value.

Operator A symbol that usually represents an action or process

Range Group / Collection of cells

BODMAS Rule Order of mathematical calculation:
Brackets - Orders (powers or square roots) -  Division – 
Multiplication – Addition - Subtraction.

Drag fill handle A small black box at the bottom right corner of the cell pointer.

Function Predefined formula / A group of instructions to return a single 
result or a set of results.

Chart Graphical representation of data.

Database A large quantity of indexed digital information.

Flat file database Single table, non relative database
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Annexure 2

Sl. 
No

Function Description Syntax

1 Averageif Averages the arguments that meet the 
condition

Average (range; criteria; 
average_range)

2 Celling Rounds a number up to the nearest 
multiple of significance

Celling (number; significance; 
[mode])

3 Countif Count the argument which meet the 
set conditions

Countif (range; criteria)

4 Fact Calculates the factorial of a number. Fact (number)

5 Floor Rounds number down to the nearest 
multiple of significance

Floor (number1; number2)

6 Product Multiples the arguments Product (number1; number2)

7 Quotient Returns the integers portion of a 
division 

Quotient (numerator; 
denominator)

8 Round Rounds a number to a predefined 
accuracy

Round (number; count)

9 SQRT Returns the square root of a number SQRT (number)

10 Sum Returns the sum of all arguments Sum (number1; number2;….)

11 Sumif Totals the arguments that meet the 
condition

Sumif (range; criteria; sum-
range)

12 Sumsq Returns the sum of the squares of the 
arguments

Sumsq (number1; 
number2;…)

13 DB Returns the real depreciation of an 
asset for a specified period using the 
fixed-declining balance method

Db (cost; salvage; life; 
period;[month])

14 N Converts a value to a number N (value)

15 Date Provides an internal for the date 
given

Date (year; month; day)

Chapter 7.indd   168 12/11/2021   1:41:04 AM



169

16 Days Calculates the number of days 
between two dates

Days (date2; date1)

17 Days360 Calculate the number of days 
between two dates based on a 360 
days year

Days360 (date1; date;[type])

18 Average Returns the average of a sample Average (number1; 
number2;…)

19 Count Counts how many numbers are in the 
list of arguments

Count (value1; value2;…)

20 Concatenate Combines several text items into one Concatenate (text1; text2;..)

21 Len Calculates length of a text string Len (text)

22 Lower Converts text to lower case Lower (text)

23 Mid Returns a partial text strings of a text Mid (text; start; number)

24 Proper Capitalizes the first letters in all 
words

Proper (text)

25 Upper Converts text to upper case Upper (text)
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