
PB 207

Learning Objective

•	 To Learn various data processing tools in spreadsheet. 

•	 To Learn about page formatting and printing in the spreadsheet.

                                11.1  Data tools

	 Data Tools are used to manipulate the information in spreadsheet. The data tools in  
spreadsheet are used for automated manipulation. For the new users, these tools may be like 
advanced options. But, a user who is experienced in these tools can do complex manipulation 
in a simple way. 

11.2  Applying conditional format

	 An important aspect of the data tools lies in the visualization of those data for easy 
understanding of the user. Conditional formatting gives different font size, font colour and 
background colour for different data, based on the user requirement. 

	 Cell formats help to change the font size, font colour, background colour depending on 
conditions that we specify. For example, in a table of numbers, all the values above average can 
be displayed in green and  below  average in red by specifying condition.

	 For example, if the marks of the students are entered in the spreadsheet. The marks 
should be shown in different colours for different mark ranges. 

Illustration 11.1: Apply the conditional formatting for Table 11.1 as for the condition given 
below.

	 1. Mark less than or equal to 50 in Lightgreen

	 2.  Mark greater than 50 in blue

Table 11.1 Data with conditional Formatting

Name Marks
Kumar 32
Arun 67
Gayathri 50
Chandru 98
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Procedure to apply conditional formatting:
1.	 Select the cells which contain marks
2.	 Choose Format → Conditional Formatting from the menu bar

Figure 11.1 Format → Conditional Formatting

3.	 Conditional formatting dialog box appears as shown in Figure 11.2

Figure 11.2 Conditional Formatting Dialog Box

4.	 Select Condition 1, choose cell value is “greater than” and type 50 in the value box. 
5.	� Then click New Style button. The New Style button has various options such as Font 

Style, Font Size, Font colour, Font alignment, Border Colour, and Background colour. 
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�	 Now, the cell style dialog box appears as shown in Figure 11.3a will appear. Click 
Background Tab and choose light green and click Ok button.

Figure 11.3a Conditional Formatting → New Style → Background

6.	� Similarly, Select Condition 2, choose cell value is “less than” and type 50 in the value 
box. In the background tab, choose blue colour and click Ok button.

Finally OpenOffice calc shows the result as given below:

Figure 11.3b Background Colour

11.3  Sorting

	 Sorting is the process of re-arranging data in ascending or descending order. There 
are three types of sorting in OpenOffice Calc. They are, 

(1)  Simple Sorting
(2)  Multi Sorting
(3)  Sort by selection
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11.3.1 Simple Sorting
	 Arranging data using a single column is known as simple sorting. To sort the 
data, calc provides two icons on the standard tool bar viz. (1) Sort Ascending (2) Sort 
Descending.

•	 Sort Ascending – Arranging data in alphabetical order (A to Z / Small to Large)

•	 Sort Descending – Arranging data in reverse order (Z to A / Large to Small)
Field

Record

Figure 11.4 Spreadsheet Data Table

Sorting data

Step 1: Place the cell pointer in the field (column) to be sorted

Step 2: Click Sort Ascending or Sort Descending icon

	 OpenOffice Calc, sorts the data based on selected column and its corresponding 
values present in other columns are also arranged simultaneously. Refer Figure 11.6.
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Sort Ascending Sort Descending

Figure 11.5 Standard Tool Bar with Sort Ascending / Descending

Click "Sort Ascending" icon to arrange ascending order

Place the Cell pointer 
anywhere in name column

Figure 11.6 Sort Ascending

11.3.2  Multi Sorting

	 Sorting data based on more than one field (column) is known as multi sorting. 
For example, consider a worksheet containing data of 20 students belonging to different 
groups and classes. To rearrange this data alphabetically by name and group code, multi 
sorting is used. Refer Figure 11.6.
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Multi-sorting data

Step 1:  	 Select Data → Sort 

Select First column in which 
the data arranged first

Select order of 
arrangement

Fainally Click 
"Ok"

Figure 11.7 Multi-sorting dialog box 

Step 2:  	 Sort dialog box appears. (Refer Figure 11.7).

Step 3: 	 Select the field name (Student name) in which you want to sort from the “sort 
by” dropdown list box and then choose order of sorting i.e. Ascending or 
Descending. Ascending is the default selection.

Step 4: 	 Select another field name (Group Code) from the “Then by” dropdown list box 
and choose the order of sorting to this column.

Step 5: 	 Click “OK” button.

	 In OpenOffice Calc, multi sort can be done only for three fields.
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Figure 11.8 Sorted Table

Note: Names are arranged in Ascending order according to names, while the other data 
are also rearranged simultaneously.

11.3.3   Sort by selection

	 In Calc sorting can be done on selected range. But this kind of sorting is generally not 
recommended, because the other relevant data are also not sorted. Therefore, OpenOffice 
Calc displays a warning message for this type of sorting. Refer Figure 11.9.

Sorting data by selection:

Step 1: 	 Select any particular field in which you want sort.

Step 2: 	 Click required Sort icon from standard tool bar or Data → Sort command.Calc 
displays a “Sort Range” warning message as shown in the Figure 11.9 “Sort 
Range” message box has two options, viz. (1) Extend selection (2) Current selection.

Step 3: 	 “Extend Selection” – Sorts the data beyond on the selection. “Current Selection” – 
Sort only the selected range of data, remaining data are not sorted.
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Figure 11.9 Sort by selection

11.4   Filtering

Filter is a way of limiting the information that appears on screen. Filters are a feature for 
displaying and browsing a selected list or subset of data from a worksheet. The visible 
records satisfy the condition set by the user. Those that do not satisfy the condition are 
only hidden, but not removed.

	 OpenOffice Calc allows three types of filters. They are AutoFilter, Standard Filter 
and Advanced Filter.

11.4.1   Auto Filter:

	 Auto Filter applies a drop-down list box to each field (columns) filled with similar 
data available in that field. Using the list box item, you can filter the data that matches the 
criteria of the data concerned. 

Using Auto Filter:

•	 Click Auto Filter icon	  available on the “Standard tool bar” (or) Click Data → Filter 
→ Auto Filter
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•	 The list box contains similar data in the fields. Refer Figure 11.10 and 11.11

•	 Each list box item will be considered as filter criteria. 
Drop down list box

Figure 11.10 Spreadsheet table with Auto Filter

Figure 11.11 Auto Filter dropdown list box

•	 Select the data item from the list box. Now, Calc shows only the records which are 
satisfy the selected criteria.

Example:

	 If you want to apply an auto filter to the contents of the Figure 11.4, follow the 
following two steps

Step 1: Place cell pointer anywhere in the table

Step 2:  Click Auto Filter icon available on the “Standard tool bar” (or) Click Data → 
Filter → Auto Filter

In the above table, if you want to view only the students belonging to the Group Code 402

•	 Click the dropdown list box’s drop arrow (a tiny triangle) to get the filter criteria. 
(Refer Figure 11.11)
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•	 Select group code 402 from the list

•	 The worksheet displays only the student’s details who are studying in group code 402 
(Refer Figure 11.12) and the remaining records are hidden. 

Figure 11.12 Filtered details

Figure 11.13 Standard Filter dialog box

Removing Auto Filter:

•	 To remove auto filter, click “Auto filter” icon once again .

•	 The original table is displayed without filter.

11.4.2   Standard Filter:

	 Auto filter is used only for a single criteria on data, whereas Standard filter is used 
for multiple critieria.
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Step 1: 

•	 Select Data → Filter → Standard Filter.

•	 Now, the entire data is selected and "Standard Filter" dialog box dispalys as shown in 
Figure 11.14.

Step 2: 

•	 Select the column heading from the “Field name” list box for the first criteria.

•	 Select conditional opeator such as >, <, = etc., from “Condition” list box.

•	 Type or select the value of critera in the “Value” box.

Step 3:

•	 Select the one of the logical operator (AND / OR) from “Operator” list box to fix 
second criteria.

•	 Follow the step 2, for the next criteria.

Step 4:

•	 Click “Ok” to finish.

Example for Standard filter:

If you want to filter the records of “XII-H2” students of group code 402 from the Figure 
11.4.

Step 1: Select Data →Filter → Standard Filter

•	 Now, “Standard Filter” dialog box appears as in Figure 11.14.

Step 2: In “Standard Filter” dialog box, select the first criteria:

•	 Select Field name as "Group code".

•	 Select Condition as "=".

•	 Type or select Value as "402".

Step 3: To select the second criteria:

•	 Select Operator as “AND”.

•	 Select Field name as "Class".

•	 Select Condition as "= ".

• 	 Type or select Value as "XII- H2".
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Figure 11.14 Standard Filter
Step 4: Click “OK”

•	 Now, the table displays only the records which match the given two criteria. Refer 
Figure 11.15.

To Remove Standard Filter:

•	 Select Data → Filter → Remove Filter

Figure 11.15 XII-H2 students of Group 402

11.5  Applying Validation

	 Validation will limit the data to be entered in the selected row/column/cell. For example, 
in the student database, the maximum roll no is 50. Hence, if the user enters a roll no above 50, 
it should give an error message.

Step 1: Enter Roll No in a cell A1 and select the entire column (column A)

Step 2: select Data → Validity, the validity dialogue box appears. Select Criteria tab, Select 
whole numbers in the Allow field. It means only integer values are allowed. Fractional values 
are not allowed. In the Data field, select less than and in the Maximum field type 50. Refer 
Figure 11.16. 
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Figure 11.16 Screen shot of validity dialogue box (Criteria Tab)

	 Then select Error Alert Tab,  select "Show error message when invalid values are 
entered" check box. Then select Warning in the Action dropdown list box, Enter title of the 
error message (such as invalid) in the Title text box. Then type the error message in the Error 
message multi line text box. Refer Figure 11.17. 

Figure 11.17 Screen shot of validity dialogue box (Error Alert Tab)

	 Now, in the Roll No column, if the user types values above 50, the error message will 
appear as shown in Figure 11.18.
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Figure 11.18 Screen shot of validity error

11.6 Creating and using Input Help List

Input Help is used to provide various options such as choosing the gender of a person  
(Male or Female), Month (Jan,Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec).

The following steps will guide to generate the List for Gender.

Step 1: In any one cell (ex: A1) type Gender

Step 2: Select the next cell (may be in A2 or B1)

Step 3: Go to Data → Validity then the dialogue box will appear (refer Figure 11.19)
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Figure 11.19 Screen shot of Input Help list

Step 4: Select Input Help Tab, type Title as Gender. then type, Male and Female in the Input 
Help Field. Then press “Ok”.

Step 5: Goto the selected cell no, the input help message will appear (refer Figure 11.20).

Figure 11.20 Screen shot of spread-sheet after applying Input Help list

11.8 Printing Spreadsheet

11.8.1	Setting the page size, Orientation and Margins

Step 1: To format the page size, go to Format → Page in the menu bar. The dialoge box will 
appear as shown in Figure 11.21.
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Figure 11.21 Page Style dialoge box

Step 2:	  Choose Page Tab (refer Figure 11.22)

Figure 11.22 Screen shot of page formatting

Step 3: Choose the Page size, Orientation and Page Margin
	 Before printing the worksheet, it is necessary to verify the Print Preview, in order to 
check the required format.

For print preview, go to File -> Page Preview
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If the worksheet appears in the required format, press close preview, otherwise choose Format 
→Page Tab in the top of the screen.

11.8.2  Inserting Header and Footer

	 Header and Footer are some titles (such as Document Title, Author Name) or references 
(such as page no, number of pages, date) or remarks to be printed in the top (called as Header) 
and bottom of the page (called as Footer). The header and footer dialoge boxes are shown in 
Figure 11.23 and 11.24.

Figure 11.23 Header Dialogue Box
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Figure 11.24 Footer Dialogue Box

11.8.3  Repeating Rows / Columns in all pages 

	 If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat 
on each printed page.

For example, if the top two rows of the sheet as well as column A need to be printed on all 
pages, do the following steps:

Step 1:	 Choose Format → Print Ranges → Edit. 

Figure 11.25 Printing Repeatative Rows/Columns
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Step 2: On the Edit Print Ranges dialog box, type the rows in the text entry box under Rows 
to repeat. For example, to repeat rows 1 and 2, type $1:$2. This automatically changes Rows to 
repeat from “- none –“ to “- user defined –“.

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Points to Remember:

•	 Data Tools are used to manipulate the information in the spread-sheet
•	 Conditional format gives different font size, font colour and background colour 

for different data based on the user requirements. 
•	 Sorting is used to re-arrange the items in ascending or descending order based 

on alphabets or based on values. 
•	 Filters are used to show only the selected portion of data from a large size 

database
•	 Input Help is used to provide various options like week, month etc
•	 Header and Footer are some titles (such as Document Title, Author Name) or 

references (such as page no, number of pages, date) or remarks to be printed in 
the top (called as Header) and bottom of the page (called as Footer).

•	 If a sheet is printed on multiple pages, we can set up certain rows or columns 
to repeat on each printed page.

Evaluation

Part I
Choose the correct answer 
1.	 There are 10000 rows in a worksheet. The user needs to view only particular rows of the 

database. Which of the following tool is used?
	 A.  Sorting		  B.  Merging	 C.  Filtering		  D.  Formatting

 2.	 The customer is required to design the item number between 101 to 200. If the user types 
above 200 or below 100, the system should give an error message. Which of the following 
tool is used?

	 A.  Listing		  B.  Filtering	 C.  Formatting	 D.  Validating

3.	 In a form, the teacher needs “True or False” as a drop down menu. Which of the following 
tool is used?

	 A.  Form		  B.  Data	 C.  List		  D.  Format

4.	 The size of an A4 paper is 21 cm x 29 cm. If the user chooses Landscape orientation, then 
the size of the paper is…..?

	 A.  21 x 29		  B.  29 x 21	 C.  None of the above	 D.   All of the above
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 Part II
Answer the following questions (2 Marks)
5.	 What is sorting?
6.	 What are the type of the filters?
7.	 What is header and footer?
8.	 Write the steps to format the margin of the paper as 1” in all sides.

Part III
Answer the following questions (3 Marks)
9.	 The user needs page number at the bottom of all pages. Which tool is used? Write the 

steps to design the needs.
10.	 Write the steps for sorting the database based on the customer name in ascending order
11.	 Write the steps to print the title row on every page of the spread-sheet

Part IV
Answer the following questions (5 Marks)
12.	 Create a student database with register number, student name, Mark1, Mark2, and Mark3. 

Calculate the total and average of the students. Show the marks which are below 50 in red 
colour and marks above 50 in green colour.

13.	 Explain the applications of Header and Footer with example

Practicals
	 Type the registration number and name of the student, mark 1 if the student is present and 
mark 0 if the student is absent on the date. Apply conditional formatting such as if the student is 
present that should represent in green colour and the absentees should represent in red colour. Then 
calculate number of present days, number of absent days and attendance percentage of the student. 
Also calculate number of student present per day and number of student absent per day.

Register No 	 Name 29-Nov 08-Dec 13-Dec 20-Dec
160172 SHIVA. M 0 0 0 0
170001 MONICA. A 1 1 1 1
170002 SUGANYA. D 1 1 1 1
170004 POOJA. P 1 1 0 1
170005 MANJU. M 1 1 1 1
170006 MOTHILAL. T 1 1 1 1
170007 DIYA N 1 1 1 0
170008 PRAJAKTA S 1 1 1 1
170009 SIRISHA S 1 1 1 1
170010 SUSMITA S 1 1 1 1
170011 DIVYA K 1 1 1 1
170012 THOMAS S 1 1 1 1
170013 SUPRAJA A 1 1 1 1
170014 RAVIRAJ R 1 1 1 1
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