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Learning Objectives

Students will be able

•	 	 To know how to work with multiple sheets.

•	 	 To learn to rename, delete worksheet.

•	 	 To know to copy, move and change the order the sheets.

•	 	 To understand how to select cells, columns and rows.

•	 	 To learn how to format tool bar.

•	 	 To understand the types of cell referncing

•	 	 To know how to use functions in Open Office calc.

•	 	 To learn to create charts in Open Office Calc.

10.1 – Managing Worksheets

10.1.1 – Selecting Worksheets

	 One or multiple sheets can be selected using a mouse. This feature is useful when same 
changes are to be made at the time in multiple sheets.

10.1.2 Selecting single sheet

	 Click on the sheet tab for the sheet you want to select. The active sheet becomes white 
and any action that you perform will now affect the selected cells in the sheet.

Sheet Navigation

Serial number / Total no. of sheets

Selected Sheet

Figure 10.1  Selecting Single Sheet
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If you want unselect the selection, click on any unselected sheet.

10.1.3. Selecting multiple continous sheets

The following steps should be followed to select multiple continuous sheets.

•	 Click on the sheet tab for the first desired sheet. 

•	 Hold down the Shift key and click on the last sheet tab.

	 All the tabs between these two sheets will be selected and will turn white. Any actions 
that you perform will now affect all highlighted sheets. For example, if you want to select from 
sheet1 to sheet5. Do the following,

	 Step 1: Click on Sheet1 to select first sheet

	 Step 2: Press and hold down “Shift” key and Click on the Sheet 5 i.e., last sheet

	 All the sheets between Sheet1 and Sheet5 will be selected and their sheet colour turns to 
white as given in the Figure 10.2 and any actions that you perform will now affect all highlighted 
sheets. 

Selected sheets Unselected sheets

Figure 10.2   Multiple continous sheets

If you want to unselect the selection, click on any unselected sheet.

10.1.4 Selecting multiple non-continous sheets.

	 If you want to select multiple non-continuous sheets the following steps will be followed. 

•	 Click on any sheet,

•	 Hold down the Ctrl key,

•	 Click another sheet. 

	 Ctrl + Click on any sheet is used to select multiple sheets. Selected sheets tab colour 
turns into “White”.
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For example, if you want to select Sheet1, Sheet3 and Sheet 7;

	 Step 1: Click on Sheet1 and then

	 Step 2: Hold down the Ctrl key

	 Step 3: Click on Sheet4, Sheet6 and Sheet8.

	 Selected Sheets colour becomes “White” and any actions that you perform will now 
affect all Selected sheets. 

Multiple non-continuous Sheet1, Sheet4, Sheet6 and Sheet8

Figure 10.3  Selecting Multiple non-continous sheets

10.2 Selecting all sheets

	 To select all sheets, Right-click any one of the sheet tabs and choose Select All Sheets 
option from the pop-up menu.
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Figure 10.4 (a)  - Selecting all sheets

Total Sheets 
Selected 

Selected Sheets

Figure 10.4(b)  - Selecting all sheets
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Deselect sheets

	 Deselecting a selected sheet is a 
very simple process. The following table 
shows you the deselect methods for 
various selections.

SN
Selection 

Type
Deselect process

1 Single Sheet
Click on any 
unselected sheet

2
Multiple 
continous 
sheets

Click on any 
unselected sheet

3
Multiple non-
continous 
sheets

Click on any 
unselected sheet

4 All sheets Click on any sheet

	 To deselect the already selected 
sheets, Right-click → Deselect All Sheets 
option from the pop-up menu is selected.

10.3 – Renaming Worksheets

	 The default name of a new sheet is 
Sheet-n, where n is a number. There are two 
methods to give a more meaningful name to 
a sheet.

Method 1:

•	 Double-click on a Sheet in which you 
want rename

•	 A small “Rename Sheet” box is appears 
as shown in Figure 10.5

Figure. 10.5   Rename Sheet dialog box

•	 Type a new name and click “OK” button.

Method 2:

•	 Right-click  on a sheet tab and choose 
Rename Sheet option from the pop-up 
menu now. 

•	 Now Rename Sheet dialog box appears 
and type a new name and then click on 
ok button.

Sheet names must start with 
either a letter or a number or 
some special characters like 

&,!,@ etc. Attempting to rename a sheet 
with an invalid name will produce an 
error message.
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Type a New Name here

Figure 10.6   Renaming a sheet

10.3.1 – Inserting and Deleting Worksheets

	 When you create a new worksheet, 
three sheets are there by default. If needed, 
one or more new worksheets can be added 
or deleted.
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10.3.1 – Inserting Worksheets

	 There are different ways to insert a new sheet.

Step 1:

•	 Right-click on a sheet tab and choose Insert Sheet option from the pop-up menu now.

			   (or)

•	 Choose Insert → Sheet option from the menu bar.

			   (or)

•	 Click the Enter Key between last sheet and horizontal scroll bar.

Choose Insert → Sheet

Click Insert Sheet

Right Click

or

Figure 10.7   Inserting more sheets

Step 2:

•	 “Insert Sheet” dialog box appears (Refer Figure 10.8).
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Click "OK"

Set position
Where the new sheet 

will be inserted

New Sheet

Existing sheet from 
another file

Figure 10.8  Insert Sheet dialog box

In this dialog box,

•	 Set position by clicking “Before current sheet” or “After current sheet”. If you select 
“Before” the new sheet(s) will inserted left side of the active sheet ie., selected sheet. If you 
select “After”, the new sheet(s) will inserted right side of the active sheet. 

•	 Type or spin the number of sheets you need to insert. If you type or spin one sheet, Name 
box will be activated, and you can enter new name of the sheet to be inserted. If you set 
more sheets, Name box will be disabled. 

•	 The minimum number of sheet must be one and maximum will be 253 (OpenOffice 
Calc 4.1.5). 

•	 Finally, click OK button.

10.3.2 – Deleting Worksheets

	 In a worksheet sheets can be deleted individually or in groups. 

To delete single sheet:

1.	 Right-click on the tab of the sheet which is to deleted and choose. Delete Sheet from the 
pop-up menu, or 
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2.	 Choose Edit  → Sheet → Delete from the Menu bar (Refer Figure 10.9).

Selected Sheet
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Figure 10.9  Delete Sheet

3.	 Either way, an alert will ask if you want to delete the sheet permanently. Click Yes. 

To delete multiple sheets:

	 To delete multiple sheets, select them as mentioned earlier and either right-click over 
one of the tabs and choose Delete Sheet from the pop-up menu, or choose Edit → Sheet → 
Delete from the menu bar. Rest of the procedure are similar to deleting a single sheet what you 
learnt earlier.

10.4 – Copy, Move and change the order of sheets

	 Click and drag the sheet tab is the simple way to move the sheets.

	 Menu also can be used to move sheets.

1.	 Right-click the sheet you want to move and select Move/Copy Sheet from the pop-up 
menu, or select Edit → Sheet → Move/Copy from the main menu (Refer Figure 10.10).
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Figure 10.10 Move / Copy Sheets

2.	 Specify the new position of the sheet in the Move/Copy Sheet dialog box. You can even 
move the sheet to a different document that is opened in Calc.

3.	 Copy Checkbox to be selected to copy sheet.

4.	 Click OK.

10.5 – Selecting Cells, Columns and Rows

10.5.1 Selecting a single cell: 

•	 Move the mouse pointer to a cell and click to select a cell (or) 

•	 Specify required cell address in the address bar to select a cell.

Click any cell to 
select 

Type cell address and 
press Enter

Figure 10.11 Selecting a Cell
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10.5.2 Selecting Multiple Cells:

	 Continuous cells can be selected using the keyboard or the mouse. 

10.5.2.1 Selecting Multiple cells using mouse:

•	 Click in a cell. 

•	 Press and hold down the left mouse button.

•	 Move the mouse till the desired location is selected. 

•	 Once the desired block of cells is selected, release the left mouse button.
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Figure 10.12 Selecting Multiple Sheets

10.5.2.2 Selecting multiple cells using keyboard:

•	 Move to the starting cell.

•	 Holding down the Shift key, use the cursor movement arrow keys to select the rest of the 
range.

10.5.3 Selecting single column or single row:

•	 To select a single column, click on the column identifier letter

•	 To select a single row, click on the row identifier number.
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Selected 
Columns

Click Row number to select entire 
row

Click Column heading to 
select entire Column

Figure 10.13 Selecting Single column or single row

10.5.4 Selecting Continuous multiple columns or rows 

•	 Click on the first column or row in the group.

•	 Hold down the Shift key.

Click the last column or row in the group. 
(1) Click on the Column heading

(3) Click last Column

Entire Columns will be selected

(2) Hold down Shift key

Shift

Figure 10.14 Selecting Continuous multiple columns or rows

10.5.5 Selecting multiple columns or rows that are not continuous: 

•	 Click on the first column or row in the group.
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•	 Hold down the Ctrl key. 

•	 Click on all of the subsequent columns 
or rows while holding down the Ctrl 
key. 

To select range of non-continuous cells

•	 Select the cell or range of cells using 
one of the methods above. 

•	 Move the mouse pointer to the start of 
the next range or single cell. 

•	 Hold down the Ctrl key and Click or 
Click-and-drag to select another range 
of cells with already selected range. 

•	 Repeat if necessary.

10.6 – Hide/Show Rows and Columns

	 When elements are hidden, they 
are neither visible nor printed, but can 
still be selected for copying if you select 
the elements around them. For example, if 
column B is hidden, it is copied when you 
select columns A and C. When you need a 
hidden element again, you can reverse the 
process, and show the element.

•	 To hide or show rows and columns, 
use the option in the Format menu or 
the right-click and choose from pop-
up menu. 

•	 To hide a row/column, first select 
the row/column, and then use menu 
options, 

•	 Format → Row → Hide or Format 
→ Column → Hide to hide row and 
column respectively.

•	 The same can be achieved by choosing 
“Hide” option from the pop-up menu 
when you right-click the selected  
row/column.

•	 To show the hidden row / column, 
choose Format→ Row → Show or 
Format →Column → Show (or)

•	 Right-click and choose Show from 
pop-up menu. 

10.7 - Freezing and Unfreezing rows and 
columns

	 Freezing locks number of rows at the 
top of a spreadsheet or number of columns 
on the left of a spreadsheet or both. Frozen 
columns and rows remain in view during 
scrolling, whereas other rows and columns 
gets scrolled.

Figure 10.15 Freezing and Unfreezing rows 
and columns

Freezing single rows or columns:
1.	 Click on the Header for the row below 

where to the freeze or for the column to 
the right of where to freeze. 

2.	 Choose the Window -> Freeze. A dark 
line appears, indicating where the freeze 
is done.

Freezing a row and a column:
1.	 Click the Cell that is immediately below 

the row to be frozen and immediately to 
the right of the column to be frozen. 
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2.	 Choose Window  -> Freeze. 

3.	 Two lines appear on the screen, a horizontal line above this cell and a vertical line to the left 
of this cell. Now as you scroll around the screen, everything above and to the left of these 
lines will remain in view. 

Unfreeze: 
	 To unfreeze rows or columns, choose Window -> Freeze. The check mark in Freeze 
will vanish.

10.8 - Merge Cells

To merge a group of cells into one cell:

Select the cells to merge.

1.	 Click on Merge Cell  icon or select Format -> Merge Cells option from menu bar.

Figure 10.16 Merge cells

10.9 – Formatting Cells and Protecting Worksheets, locking and hiding cells

	 Formatting Data in a cell gives additional effect to the text. Additional effect includes 
changing the Font type, Style, Font size, automatic wrapping, bold, underline, italic etc. The 
data in Calc can be formatted in several ways using the icons of the Formatting Tool bar (Refer 
Figure 10.17)

Figure 10.17 Formatting Tool bar

10.9.1 - Icons available in the Formatting Tool Bar:

1.	 Font Name list box:  Various fonts are available in the list from 
which the required font can be selected.

2.	 Font Size list box: Font size can be selected from this list box.
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3.	 Bold Icon: This icon is used to 
apply bold for selected cell. Key board 
shortcut Ctrl + B can also be used.

4.	 Italic Icon: Italic icon is used to 
apply italic style to selected cell. Ctrl + 
I can also be used to apply italic.

5.	 Under line Icon: To apply underline 
for selected cell this icon can be used. 
Ctrl + U can also be used for this.

6.	  Four alignment Icons: 
Using this icon content of a cell can be 
aligned Left, Center, Right and Justify. 
The key board short cuts are Ctrl + 
L, Ctrl + E, Ctrl + R and Ctrl + J can 
also be used respectively to align cell 
content.

7.	  Number Format 
Icon: Currency symbol (Ctrl + Shift + 
4), Percent (Ctrl + Shift + 5), Standard 
(Ctrl + Shift + 6), Add Decimal Place, 

Delete Decimal Place can be applied 
using this icons.

8.	  Increase Indent and Decrease 
Indent Icons can be used to indent the 
cell content.

9	  Borders Icon, 
Background Colour Icon and Font 
Colour Icons can be used to apply 
border, to change cell background 
colour and to change font colour.

10.9.2 - Formatting using Format Cells 
Dialog Box:

	 The above formatting options can 
be applied individually one by one.  The 
Format Cells dialog box is used to apply 
formatting and see the preview. Select a cell 
and Right-click and select Format cells or 
click Format → Cells or press Ctrl+1, now 
Format Cells dialog box appears with seven 
tabs as follows.

Figure 10.18 Format Cells
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Numbers Tab :

	 Several number formats like Category, Format, Language, Decimal places, leading 
zeros and Thousands separator. User-defined Format code is also applied. The main advantage  
here is that preview is available.

Cell Protection Tab :

	 In Open Office Calc, cells are protected against any accidental changes. Protection can 
be provided by means of a password. Authorization is given by entering the correct password. 
It is clear that the Cell Protection with a Protected attribute is only effective when the whole 
sheet is in protected mode.

Figure 10.19 Format Cell - Cell Protection

1.	 Select the cells that you want to apply the cell protection feature..

2.	 Choose Format → Cells and click the Cell Protection tab.

3.	 In the Protection group, the Protected check box is enabled, click Ok button. This 
becomes effective only when password and confirm are entered through Tools → Protectd 
Document → Sheet(Refer Figure 10.20).
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Figure 10.20 Protecting the Sheet

	 In the Format Cells  dialog box - for cell protection under the Protection group:.

4.	 Enable Protected to prevent changes to the contents and the format of a cell. 

5.	 Enable Hide formula to hide and to protect formulae from changes.

6.	 Enable Hide when printing to hide protected cells in the printed document. (The cells are 
not hidden on screen).

7.	 Click OK.

8.	 Apply the protection options.

	 8.1  To protect the cells from being changed / viewed / printed according to your settings 
in the Format→ Cells Dialog box, choose Tools → Protect Document → Sheet.

	 8.2  Enter a password with of atleast 5 or more characters.

10.10 –Cell Referencing

10.10.1 Relative Addressing

	 The cell from A1 to A3 is addressed as A1:A3. Assume A4  has the formula =SUM(A1:A3). 
When the same formulae is copied to column B4 Relative Addressing automatically changes 
the formulae in B4 as =SUM(B1:B3). Relative here means that the reference to this area will 
be changed automatically when you copy the formulae.
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10.10.2 Absolute Addressing

	 Absolute Addressing is opposite to Relative Addressing. A dollar sign is placed 
before each column name  and row number in an Absolute Addressing, for example, assume  
A5 has the formula =SUM($A$1:$A$3), when it is copied to B5 the  reference will not 
automatically change and formulae in B5=SUM($A$1:$A$3) that is same as A5.

 

Figure: 10.21 Relative Cells Addressing

Figure: 10.22 Absolute Cell Addressing

10.11– Functions in OpenOffice Calc

10.11.1 – Introduction

	 A function is a predefined calculation entered in a cell to help to analyze or manipulate 
data in a spreadsheet. These functions simplify help to create the formulas needed to get the 
expected results. Formulae are equations using numbers and variables to get a result. In a 
spreadsheet, the variables are cell locations that hold the data needed for the equation to be 
completed. Open Office Calc includes over 350 functions to analyze and reference data. Many 
of these functions are used for working on numbers, dates, times, and text.
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10.11.2 – Familiarization with the categories of functions

	 The most commonly used functions are the built-in functions, which is available in 
.the Function Wizard. To open the Function Wizard choose Insert→ Function or press the 
shortcut key Ctrl+F2.  

1.	 Once the Function Wizard is open, Select a Category from the Category dropdown box 
and select the function from the Function list box. 

2.	 When you select a function its description appears on the right-hand side of the dialog 
box. Double-click on the required function. 

3.	 The Wizard now displays a textbox where you can enter data manually in the text box and 
the result will be displayed in the Result text box

Figure: 10.23 Function Wizard Dialoge Box

10.11.3 – Working with the functions in Mathematical and Statistical Category 

10.11.3.1 - Mathematical functions under Mathematical Category: 

	 Various Mathematical functions are readily available under Mathematical category for 
mathematical calculations.
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Figure: 10.24 Mathematical functions

Few mathematical functions are listed 
below.

ABS (Number/Cell Address)

	 Number/ Cell Address is the value 
whose absolute value is to be calculated. 
The absolute value of a number is its value 
without   +/- sign.

Example

=ABS (-76) returns 76, =ABS (74) returns 
74, =ABS (0) returns 0.

ACOS (Number/Cell Address) 

	 This function returns the inverse 
trigonometric cosine of Number which is in 
radians. The angle returned is in the range 
0.0 to +PI. To return the angle in degrees, 
use the DEGREES function. 

Example

=ACOS (-1) returns 3.14159265358979 (PI 
radians)

=DEGREES (ACOS(0.5)) returns 60. The 
cosine of 60 degrees is 0.5.

ACOSH (Number/Cell Address)

	 This function returns the inverse 
hyperbolic cosine of a Number. The Number 
must be greater than or equal to +1.0.

Example

=ACOSH(1) returns 0, =ACOSH(COSH(4)) 
returns 4.

ACOT(Number/Cell Address)

	 This function returns the inverse 
trigonometric cotangent of a Number.  
Where the angle is in radians is Number. 
The angle returned is in the range 0.0 to 
+PI. To return the angle in degrees, use the 
DEGREES function.

Example

=ACOT(1) returns 0.785398163397448 
(PI/4 radians).

=DEGREES(ACOT(1)) returns 45. The 
tangent of 45 degrees is 1. 

ASIN (Number/Cell Address)

	 This function returns the inverse 
trigonometric sine of Number where the  
angle is in radians. The angle returned is in 
the range -PI/2 to +PI/2. To return the angle 
in degrees, use the DEGREES function.
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Example

=ASIN (0) returns 0. =ASIN (1) returns 
1.5707963267949 (PI/2 radians). 

=DEGREES (ASIN (0.5)) returns 30. The 
sine of 30 degrees is 0.5.

ATAN (Number/Cell Address)

	 This function returns the inverse 
trigonometric tangent of Number where the 
angle is in radians. The angle returned is in 
the range -PI/2 to +PI/2. To return the angle 
in degrees, use the DEGREES function.

Example

=ATAN (1) returns 0.785398163397448 
(PI/4 radians).

=DEGREES (ATAN (1)) returns 45. The 
tangent of 45 degrees is 1.

CEILING (Number; Significance; Mode)

	 This function rounds a number 
up to the nearest multiple of Significance. 
Number is the number that is to be rounded 
up. Significance is the value that the number 
is to be rounded up to a multiple of. Mode 
is an optional value. If the Mode parameter 
is supplied and is not equal to zero and if 
Number and Significance are negative, 
rounding up is carried out based on the 
absolute value of Number. This parameter 
is omitted when exporting to Microsoft 
Excel since Excel does not support a third 
parameter for this function

Example:

=CEILING (15.5;2;2) returns 16, 
=CEILING(-11;-2) returns -10

=CEILING (-11;-2;0) returns -10, 
=CEILING(-11;-2;1) returns -12

COMBIN (Count1; Count2)

	 Returns the number of combinations 
for a given number of objects (without 
repetition). Count1 is the number of items 
in the set. Count2 is the number of items to 
choose from the set. COMBIN returns the 
number of ordered ways to choose these 
items. For example if there are 3 items A, 
B and C in a set, you can choose 2 items 
in 3 different ways, namely AB, AC and 
BC. COMBIN implements the formula: 
Count1!/(Count2!*(Count1-Count2)!)

Example:

=COMBIN (3;2) returns 3, =COMBIN(5;3) 
returns 10.

COMBINA (Count1; Count2)

	 Returns the number of combinations 
of a subset of items including repetitions. 
Count1 is the number of items in the 
set. Count2 is the number of items to 
choose from the set. COMBINA returns 
the number of unique ways to choose 
these items, where the order of choosing 
is irrelevant, and repetition of items is 
allowed. For example if there are 3 items 
A, B and C in a set, you can choose 2 items 
in 6 different ways, namely AB, BA, AC, 
CA, BC and CB. COMBINA implements 
the formula: (Count1+Count2-1)! / 
(Count2!(Count1-1)!)
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Example

=COMBINA(3;2) returns 6, 
=COMBINA(4;3) returns 20

COS (Number)

	 Returns the (trigonometric) cosine 
of Number, whose angle is in radians. To 
return the cosine of an angle in degrees, use 
the RADIANS function.

Examples:

=COS(PI()/2) returns 0, the cosine of PI/2  
in radians.

=COS(RADIANS(60)) returns 0.5, the 
cosine of 60 degrees.

COUNTBLANK (Range)

	 Returns the number of empty cells in 
the cell range.  

Example:

	 =COUNTBLANK (A1:B2) returns 4 
if cells A1, A2, B1 and B2 are all empty.

COUNTIF (Range; Criteria)

	 Range is the range where the criteria 
is  to be applied.

Example:

	 The Criteria determines which cells 
are counted and is in the form of a number, 
an expression or a text string. The search text 
may also be given in the form of a regular 
expression. The command   "b.*" is given for all 
words that begin with b. If search is for literal 
text, enclose the text in double quotes.

A1:A10 is a cell range containing the 
numbers 2000 to 2009. Cell B1 contains 
the number 2006. In cell B2, you enter a 
formula:

=COUNTIF (A1:A10;2006) - this returns 1

=COUNTIF (A1:A10;B1) - this returns 1

=COUNTIF (A1:A10;">=2006") - this 
returns 4

=COUNTIF (A1:A10;"<"&B1) - when B1 
contains 2006, this returns 6

=COUNTIF (A1:A10;C2) where cell C2 
contains the text >2006 counts the number 
of cells in the range A1:A10 which are > 
2006. 

To count only negative numbers: 
=COUNTIF (A1:A10;"<0")

10.11.3.2 - Statistical functions 

Figure: 10.25 Statistical functions

COUNT(Value1; Value2; ... Value30)

	 Counts how many numbers are in the 
list of arguments. Text entries are normally 
ignored. Value1; Value2; ... Value30 are 1 to 
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30 values or ranges representing the values 
to be counted.

Example

The entries 2, 4, 6 and eight in the Value 1 ... 
4 fields are to be counted.

=COUNT (2;4;6;"eight") = 3. The count of 
numbers is therefore 3. Text is ignored.

COUNTA(Value1; Value2; ... Value30) 

	 Counts how many values are in the 
list. Text entries are also counted, even 
when they contain an empty string of length 
0. Value1; Value2; ... Value30 are 1 to 30 
arguments representing the values to be 
counted.

Example

The entries 2, 4, 6 and eight in the Value 1 ... 
4 fields are to be counted.

=COUNTA(2;4;6;"eight") = 4. The count of 
values is therefore 4.

CORREL(Data1; Data2)

	 Returns the correlation coefficient 
between two data sets.Data1 is the first data 
set. Data2 is the second data set.

Example

	 =CORREL(A1:A20;B1:B20) 
calculates the correlation coefficient as a 
measure of the linear correlation of the two 
data sets.

LARGE(Data; Rank_C)

	 Returns the Rank_c-th largest value 
in a data set. Data is the cell range of data. 
Rank_C is the ranking of the value.

Example

	 =LARGE(A1:C50;2) gives the second 
largest value in the range A1:C50.

SMALL(Data; Rank_C)

	 Returns the Rank_c-th smallest value 
in a data set. Data is the cell range of data. 
Rank_C is the rank of the value.

Example

	 =SMALL(A1:C50;3) gives the third 
smallest value in the range A1:C50.

AVERAGE(Number1; Number2; ... 
Nu m b e r 2 0 )

	 Returns the average of the arguments. 
Number1; Number2; ... Number20.

Example

	 =AVERAGE(A1:A20) returns the 
average of set of values in the cell range 
A 1 : A 2 0

10.11.4 – Working with the functions in 
Logical Category.

IF (Test; TrueValue; FalseValue)

	 Specifies a logical test to be 
performed. Test is any value or expression 
that can be TRUE or FALSE. TrueValue 
(optional) is the value that is returned if the 
logical test is TRUE. FalseValue (optional) is 
the value that is returned if the logical test is 
FALSE.
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Example

	 =IF(A1>5;”True”;"too small") If the value in A1 is higher than 5 then the text “True” is 
returned in the current cell  otherwise the text “too small” (without quotes) will be returned.

10.11.5 – Working with the functions in Date and Time Category 

	 OpenOffice Calc internally handles a date/time value as a numeric value.  To change 
the number format to date or time, Select the cell containing the date or time, Click Format→  
Cell, select Numbers tab of the Format Cells Dialog Box, select the desired format.

Figure: 10.26 Number format

10.11.6 – Working with the functions in Text Category 

CONCATENATE("Text1"; "Text2";"Text3"; ...)

	 Combines several text strings into one string. Text1; Text2; Text3; ... are 1 to 30 text 
passages which are to be concatenated together into one string.

Example

	 =CONCATENATE("Good ";"Morning ";"Mr. ";"Ramki") returns Good Morning  
Mr. Ramki
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DECIMAL("Text"; Radix)

	 Converts a text string with characters 
from a number system to a positive integer 
in the base radix given. Text is the text 
string to be converted. To differentiate 
between a hexadecimal number, such as 
A1 and a cell address A1, you must place 
the text in quotation marks, for example, 
"A1" or "FACE". Radix indicates the base of 
the number system. It may be any positive 
integer in the range 2 to 36.

Example

=DECIMAL("17";10) returns 17. 
=DECIMAL("FACE";16) returns 64206.

	 =DECIMAL("0101";2) returns 5.

10.12 – Charts in OpenOffice Calc

10.12.1 – Introduction

	 Charts and graphs are powerful ways 
to convey information to the reader through 
a pictorial representation. OpenOffice Calc 
offers a variety of different charts and graph 
formats for data representation.  Calc helps 
to customize charts and graphs to enhance 
the Presentation in a best manner.

10.12.2 – Familiarization with the types of 
charts 

	 There are various types of charts 
and graphs for representing data through 
relevant pictorial representation. The 
creation and presentation of charts are 
discussed in the following sections. 

	 The following are the types of charts 
that Calc provides.

1.	 Column chart

2.	 Bar chart

3.	 Pie chart

4.	 Area chart

5.	 Line chart

6.	 Scatter or XY chart

7.	 Bubble chart

8.	 Net chart

9.	 Stock chart

10.	 Column and line chart

Column Chart

	 This is a bar chart or bar graph with 
vertical bars. The height of each bar is 
proportional to its value. The x-axis shows 
categories. The y-axis shows the value for 
each category.

	 Normal type is a sub-type which 
shows all data values belonging to a category 
next to each other. Main focus is on the 
individual absolute values, compared to 
every other value.

	 Stacked type is a sub-type which 
shows the data values of each category 
on top of each other. Main focus is the 
overall category value and the individual 
contribution of each value within its 
category.

	 Percent is a sub-type which shows 
the relative percentage of each data value 
with regard to the total of its category. The 
main focus is the relative contribution of 
each value to its total category.
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Figure: 10.27  Percentage

Bar Chart
	 This type shows a bar chart or bar 
graph with horizontal bars. The length of 
each bar is proportional to its value. The 
y-axis shows categories. The x-axis shows 
the value for each category.

Figure: 10.28  Horizontal Bar

Pie Chart
	 A pie chart shows values as circular 
sectors of the total circle. The length of the 
arc, or the area of each sector, is proportional 
to its value. 

	 Normal Pie is a sub-type which shows 
sectors as colored areas of the total pie, for one 
data column only. In the created chart, you can 
click and drag any sector to separate that sector 
from the remaining pie or to join it back.

	 Exploded pie is a sub-type which 
shows the sectors already separated from 
each other. In the created chart, you can 
click and drag any sector to move it along a 
radial from the pie's center.

	 Doughnut is a sub-type that shows 
multiple data columns. Each data column is 
shown as one doughnut shape with a hole 
inside, where the next data column can be 
shown. In the chart created, you can click 
and drag an outer sector to move it along a 

radial from the doughnut's center.

	 Exploded doughnut is a sub-
type that shows the outer sectors already 
separated from the remaining doughnut. In 
the created chart, you can click and drag an 
outer sector to move it along a radial from 
the doughnut's center.

Figure: 10.29  Pie Chart

Area chart
	 An area chart shows values as points 
on the y-axis. The x-axis shows categories. 
The y-values of each data series are connected 
by a line. The area between each two lines is 
filled with a colour. The area chart's focus is 
to emphasise the changes from one category 
to the next.

	 Normal - this sub-type plots all 
values as absolute y-values. It first plots the 
area of the last column in the data range, 
then the next to last, and so on, and finally 
the first column of data is drawn. Thus, if 
the values in the first column are higher 
than the other values, the last drawn area 
will hide the other areas.

	 Stacked - this sub-type plots values 
cumulatively stacked on each other. It 
ensures that all values are visible, and no 
data set is hidden by others. However, the 
y-values no longer represent absolute values, 
except for the last column which is drawn at 
the bottom of the stacked areas.

	 Percent - this sub-type plots values 
cumulatively stacked on each other and 
scaled as percentage of the category total.



200 201

Figure: 10.30  Area Chart Percentage

Line chart

	 A line chart shows values as points 
on the y-axis. The x-axis shows categories. 
The y-values of each data series can be 
connected by a line.

	 Points only - this sub-type plots only 
points.

	 Points and lines - this sub-type plots 
points and connects points of the same data 
series by a line.

	 Lines only - this sub-type plots only 
l ines.

	 3-D lines - this sub-type connects 
points of the same data series by a 3-D line.

Figure: 10.31  Line Chart - Points Only

Scatter or XY chart

	 An X-Y chart in its basic form is 
based on one data series consisting of a 
name, a list of x values, and a list of y values. 
Each value pair (x|y) is shown as a point in 
a coordinate system. The name of the data 
series is associated with the y values and 
shown in the legend.

	 All the charts are created with default 
settings. After the chart is finished, you can 
edit its properties to change the appearance. 
Line styles and icons can be changed on the 

Line tab page of the data series properties 
dialogue box.

	 Double-click on any data point to 
open the Data Series dialogue box. In 
this dialogue box, you can change many 
properties of the data series.

	 For 2-D charts, you can choose 
Insert - y-Error Bars to enable the display 
of error bars.

	 You can enable the display of mean 
value lines and trend lines using commands 
on the Insert menu.

Points only

	 Each data point is shown by an icon. 
OpenOffice uses default icons with different 
forms and colours for each data series. 
The default colours are set using Tools → 
Options → Charts → Default Colours. 

Lines Only

	 This variant draws straight lines from 
one data point to the next. The data points 
are not shown by icons. 

	 The drawing order is the same as 
the order in the data series. Mark Sort by 
x-values to draw the lines in the order of 
the x-values. This sorting applies only to the 
chart, not to the data in the table.

Points and Lines

	 This variant shows points and lines at 
the same time.

3-D Lines
	 The lines are shown like tapes. The 
data points are not shown by icons. In 
the finished chart choose 3-D View to set 
properties like illumination and angle of 
view.
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Figure: 10.32  3D Points Only

Bubble chart
	 A bubble chart shows the relation of three variables. Two variables are used for the position 
on the x-axis and y-axis, while the third variable is shown as the relative size of each bubble.

	 The Data Series dialog box for a bubble chart has an entry to define the data range for 
the Bubble Size.

Net chart
	 A Net chart displays data values as points connected by some lines, in a grid net that 
resembles a spider net or a radar tube display.

	 For each row of chart data, a radial is shown on which the data is plotted. All data 
values are shown with the same scale, so all data values should have the same magnitude.

Figure: 10.33  Bubble Chart Points Only

Column and line chart

				    Figure: 10.34  Column and Line Charts	

A Column and Line chart is a combination of a Column chart with a Line chart.

Select one of the variants

•	 Columns and Lines. The rectangles of the column data series are drawn side by side so that 
you can easily compare their values.

•	 Stacked Columns and Lines. The rectangles of the column data series are drawn stacked 
above each other, so that the height of a column visualises the sum of the data values.

•	 You can insert a second y-axis with Insert - Axis after you finish the wizard.
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10.12.3 – Creating and formatting charts

1.  Select the cells that contain the data that you want to present in your chart.

2.  Click the Insert->Chart option or click Insert Chart icon  on the Standard toolbar.

Figure: 10.35a  Insert Chart

3.  The Chart Wizard has three main parts: 

•	 List of steps involved in setting up the chart, 

•	 List of chart types, and 

•	 The options for each chart type. 

At any time you can go back to a previous step and change selections.

Figure: 10.35b  Chart Type
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4.  Choose a Chart type and its option type. Then click Next	  button.

Figure: 10.35c  Data Range

5.	 In Step 2, Data Range, helps to manually correct any mistakes  made in selecting the 
data. Click one of the options for Data series in rows or in columns. Check whether the 
data range has labels in the first row or in the first column or both. Then click the Finish 
button, or click Next to change some more details of the chart.

Figure: 10.35d  Data Series

6.	 The Data Series list box contains a list of all data series in the current chart.
•	 To organize the data series, select an entry in the list.
•	 Click Add to add another data series below the selected entry. The new data series has the 

same type as the selected entry.
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•	 Click Remove to remove the selected entry from the Data Series list.
•	 Use the Up and Down arrow buttons to move the selected entry in the list up or down. This 

does not change the order in the data source table, but changes only the arrangement in 
the chart.

•	 Then click Next button

Figure: 10.35e  Chart Elements

7.	 In the Chart Elements page, chart a title and, if desired, a subtitle. Give a  suitable title 
that draws the viewers’ attention to the chart: For example: Figure 10.35f has the chart 
Title as Mark Statement. Then click Finish to create chart..

Figure: 10.35f  Final Chart

Case Study: Create a spreadsheet file to store sales data of a particular product and present it 
in the form of Chart.
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Evaluation

Part - A 

Choose the best answer:
1. The active sheet colour will be of which colour?
	 A) Grey	 B) Green	 C) White	 D) Yellow

2. To select multiple continuous sheet which key is used?
	 A) Ctrl	 B) Shift	 C) Alt	 D) tab

3. To delete a single sheet which command is to be selected?
	 A) File → Sheet → Delete
	 B) Delete →Sheet→Delete
	 C) Sheet → Delete
	 D) Edit → Sheet → Delete

4. Which command is used to show the hidden row in OpenOffice Calc?

	 A) Format → Row → Show	

	 B) Format → Show → Row

	 C)Format→Display→Row	

	 D) Format → Row → Display

5. To protect cell in Open Office Calc Format → Cells and click which tab?

	 A) Protect Cell

	 B) Protection Cell

	 C) Cell Protection

	 D) Cell Protect

6. To make which cell address absolute we use sign?

	 A) Absolute	 B) Relative	 C) Comparative	 D) Reference

7. Which function sounds a number upto the nearest multiple of significance?

	 A) COMBINA	 B) CEILING	 C) Floor	 D) ABS
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8.	 If cell A5 contains value 18, then if 26; “true”, “False”) will return

	 A)True	 B)False	 C)Blasse	 D) Error

9. Which can be a powerful way to convey information to the reader through a pictorial 
representation?

	 A) Charts and images		  B) graphs and images

	 C) Charts and graphs		  D) Images and Pictures

10. What will be value returned by = decimal ("16";1101)

	 A) 12		  b) 13		  c) d		  d) e

Part-II

Answer the following questions (2 Marks)

1. How to select continuous and non-continuous sheets in OpenOffice Calc?
2. Write the method to rename sheet.
3. What is the use of freezing a sheet?
4. What are the types of Cell addressing?
5. What is a Chart?

Part-III

Answer the following questions (3 Marks)

1. Differentiate Relative cell addressing from Absolute cell addressing
2. What are functions in OpenOffice Calc?
3. How to hide/show rows and columns in sheet?
4. Write briefly about ASIN function in Open Office Calc.
5. What is a range? Give example.

Part-IV

Answer the following questions (5 Marks)

1.	� Create a Worksheet which consist of student database with the following fields.
	 Rollno., Name, English, Tamil, Maths, Science, Social, Total, average.
2.	 Explain how to format a worksheet
3.	 Discuss in detail the steps to create chart in OpenOffice calc.
4.	 How to use function in Open Office Calc? Explain with suitable example.
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