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Chapter 2

Advanced GIMP

Learning Objectives 
After learning this chapter learner will be able to:-
•	State the purpose of using Gimp software.
•	List the features of Gimp.
•	Use advance tools of Gimp for editing the images.
•	Align different objects placed in a Layer.
•	Create image by merging two or three images using Layers.
•	View the images in different dimensions using Perspective tool.
•	Apply different effects on image using Masking option.

Introduction
GIMP is called multi-platform photo manipulation tool. Since, GIMP is free software, 
it is covered by the General Public License [GPL]. The GPL provides the users with the 
freedom to access and alter the source code. In this chapter, you will learn advance tools 
of Gimp used to give different projections to the image to get the desired result.

1. Review of GIMP Covered in Class IX
GIMP is a GNU Image Manipulation Program. It is a powerful open source image editing 
tool that provides retouching, authoring and composition of photos. It consists of the 
features similar to the ones provided by the other available Photo Editing software. It is 
freely downloadable software, which can be downloaded from www.gimp.org site.

GNU/Linux distributions include GIMP as a standard application. The GIMP is also 
available for other operating systems such as Microsoft Windows™ or Apple’s Mac OS X™ 
(Darwin).

1.1 Features of GIMP are:
	 ❖	 It can be used as a simple paint program
	 ❖	 It can be used as an expert quality photo retouching program.
	 ❖	 It can be used as an online batch processing system.
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	 ❖	 It can be used as a mass production image producer to develop different models.
	 ❖	 The advanced scripting interface allows everything from the simplest task to the 

most complex image manipulation procedures to be easily scripted.
	 ❖	 It can convert and save files to many file formats such as gif, jpeg, tiff.etc
	 ❖	 It can load and save animations in a convenient frame as layer format.
	 ❖	 Virtually unlimited images can be opened at one time.
	 ❖	 GIMP works with numerous operating systems including Linux, Mac OS and 

Microsoft Windows.

2. Tool box
The Basic tools were learnt in Class IX. Here we would learn some advanced tools. 

2.1 Move Tool [M] 
The Move Tool is used to move 
layers, selections, paths or  
guides of both the objects and  
the text.

2.2 Align Tool [Q] 
The Align tool is useful to align  
the image layers with various image 
objects. 

2.3 Scale Tool [Shift + T] 
The Scale Tool is used to scale layers, 
selections or paths (the Object).

2.4 Shear Tool [Shift + S] 
Shear tool is used to shift one selected 
part of an image, a layer, a selection 
or a path to a direction and the other 
part to the opposite direction. For 
instance, a horizontal shearing will 
shift the upper part to the right and 
the lower part to the left. 

Rectangle Select tool Oval select tool

Foreground select tool Paths tool

Alignment too Crop tool

Flip tool Cage transform

Paintbrush tool Eraser tool

Perspective tool Blur/sharpen tool

Lasso too Fuzzy select tool tool

Color picker tool Zoom tool

Rotate tool Scale tool

Text tool Bucket fill tool

Airbrush tool Ink tool

Smudge tool Dodge/Burn tool

Select by color Scissors tool

Measure too Move tool

Shear tool Rectangle Select tool

Blend tool Pencil tool

Clone tool Heal tool

Foreground color Background color
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2.5 Perspective Tool 
The Perspective Tool is used to view the images in different dimensions, of the active 
layer content. 

2.6 Flip an Image 
In a photo, if the face of a person is in the left side direction, this tools changes the direction 
of the face to the right side.  It creates the mirror image of the photo. 

2.7 Rotate an Image 
This tool is used to rotate an image in different directions i.e. from horizontal to vertical 
and vice versa.

2.8 Blend Tool [L]  
This tool is used to fill the selected area with a gradient blend of the foreground and 
background colours by default. These colours can be modified to change the colour of 
the gradient.

2.9 Blur/Sharpen Tool [Shift +U] 
This tool is used to blur or sharpen the image using the current brush. Note that in 
“Sharpen” mode, the tool increases the contrast where the brush is applied.

2.10 Smudge Tool [S] 
The Smudge tool uses the current brush to smudge colours on the active layer or the 
selection. It takes the colour and uses it to mix it with the next colour it meets.

2.11 Dodge/Burn Tool [Shift + D] 
The Dodge tool uses the current brush to lighten the colors in your image.

The Burn tool uses the current brush to darken the colors in your image. 

The mode will determine which types of pixels are affected.

2.12 Eraser Tool [Shift + E] 
Eraser Tool works similar to a classic eraser. Simply select the tool and drag on the canvas 
to erase things.
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2.13 Pencil tool [N] 
The Pencil Tool is used as the same way that you would use a real pencil to draw. Simply 
select the tool and drag on the canvas to draw with the Pencil Tool.

2.14 Paintbrush tool [P] 
The Paint Brush tool draws brush like strokes, as if you were painting. It lets you create 
special effects. Unlike the Pencil Tool, the brush tool draws both a fill and outline. 

3. �Steps to use the Tools stated above used in GIMP 
are as follows

3.1 Move Tool [M] 
The Move Tool is used to move layers, selections, paths or guides. It works also on 
texts.

You can access the Move Tool in different ways:

From the image menu bar Tools → Transform Tools → Move

By clicking the tool icon: 

By using the keyboard shortcut M.

The Move tool is automatically activated when you create a guide.

To use this tool simply click on the canvas and drag the selection to a desired location.

Note: Holding down the space bar changes the active tool to Move temporarily.

3.2 Move Tool Options
Normally, tool options are displayed in a window attached 
under the Toolbox as soon as you activate a tool. If they 
are not, you can access them from the image menu bar 
through 

Windows → Dock able Windows → Tool Options which 
opens the option window of the selected tool.

Move

Move:

Tool Toggle (Shift)
Pick a layer or guide

Move the active layer

Selection
Layer

Path
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If Move is on “Layer” – 
Only the current Layer 
will be moved.

If Move is on “Selection” – 
The selection’s outline will 
be moved.

If Move is on “Path” - The 
mouse pointer turns to a 
small hand when it goes 
over a visible path. Then you can move this path by click-and-dragging it (it will be the 
active path while moving.

3.3 Align Tool 
The Align tool is useful to align the image layers with various image objects. When this 
tool is selected, the mouse pointer turns to a small hand. By clicking on an element of 
a layer in the image, you choose the layer which will be moved (with Shift + click, you 
can choose several layers to be aligned), this focalised layer has small squares in corners. 
Various buttons in the dialog allow you to select how the layer will be moved. And you 
can select the image object (other layer, selection, path...) the selected layer will be aligned 
on. This object is called target.

You can activate the Align tool in several ways:
From the image-menu, through: Tools → Transform Tools → 
Align, By clicking on the tool icon: in the toolbox, By using 
the Q keyboard shortcut.

3.4 Align Tool Options           
The options of Align Tool become active when a layer 

is selected. When you click on one of these buttons, you align 
the selected layer with left edge, horizontal middle, right edge, 
top edge, vertical middle, or bottom of the target. 

          

These options seem to differ from the  “Related to  ” options only by the possibility to 
set an offset. This offset is the distance which will separate the selected layer(s) from 

Align
Align

Relative to:
First item

Distribute

Offset:

Selected part of the Image is moved
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the target once the alignment is performed. 
Distribute add this offset to the left edges, 
horizontal centres, right edges, top edges, 
vertical centres, or bottoms of targets.

3.5 Scale Tool [Shift + T] 
The Scale Image command enlarges or reduces the physical size of the image by changing 
the number of pixels it contains. It changes the size of the contents of the image and resizes 
the canvas accordingly.

You can access this command from the image menubar through Image → Scale Image.

Step 1: Click on Image → Scale Image

Step 2: Set the width and height and click on scale

Scale Layer

Scale Layer
Earthi.jpg-20 ([Earth] (imported))

Layer Size

Width:

H ight:e

Quality

I terpolation:n

1940

1941

1940 × 1940 pixels
300 ppi

px

Cubic

Help Reset Scale Cancel

Image after scaling

Images using different alignments

Image Layer Colors Tools Filte sr Windows Help

Duplicate

Mode

Transform

Can as Size...v

Fit Canvas to L yersa

Fit Canvas to Selection

Print Size...

Scale Image...

Crop to Selection

Autocrop Image

Zealous Crop

Merge Visible Layers...

Flatten Image

Aligh Visi le Layers...b

Guides

Configure G id...r

Image Pr pertieso Atl+Return

Ctrl+M

Ctrl+D
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3.6 Shear Tool [Shift + S] 
Shear tool is used to shift one part of an image, a layer, a selection or a path to a direction 
and the other part to the opposite direction. For instance, a horizontal shearing will shift 
the upper part to the right and the lower part to the left. 

You can use the shear tool in several ways:
In the image-menu through: Tools → Transform Tools → Shear,

By clicking the tool icon:     in Toolbox,

Also by using the Shift+S key combination.

Before using Shear Tool After using Shear Tool

3.7 Perspective Tool
The Perspective Tool is used to change the dimensions of the active layer content, of 
selection content or of a path. 

You can use the Perspective tool in different ways: 
By clicking the tool icon: in Toolbox, By using the Shift+P key combination.

horinajpg.115 (proeo) image

0.00000
1.00000
0.00000

0.00000
0.00000
1.00000

Transform Cancel

Perspective

Perspective

Transforamtion Matrix
1.00000
0.00000
0.00000

Help Reset

After using Perspective
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3.8 Flip an Image 
When you need the person in the photo looking in the other direction, or you need to top 
of the image to be the bottom like developing the Mirror image. Right click on the image 
and follow the menus Tools → Transform Tools → Flip, or use the button on the toolbox.

Image before flipping Image after flipping

Selection Tools
Paint Tools
Transform Tools
Color Tools
Pat sh

C lor Pickero

Zoom

Measure

Te tx

GEGL Operation...

Toolb xo
Default Colors
S ap Colorsw

Shift+M

T

Ctrl+B
D
X

B
O
Z

IMP

ors Tools Filte sr Windows Help

Align

Move

Crop

Rotate

Scale

S earh

Perspective

Flip

Cage Transform

Q

M

Shift+C

Shift+R

Shift+T

Shift+S

Shift+P

Shift+F

Shift+G

3.9 Rotate an image  
This tool helps you to revolves the layer, paths and 
selected portion in the image.

It helps to spin an image in different directions.

Steps to rotate an image are as follows:
Right click on the image, and follow the menus 
Image → Transforms → Rotate → 90 degrees (or 
270 depending on the orientation). 

Image before Rotating Image after Rotating

Image Layer Colors Tools Filte sr Windows Help

color, 1 layer) 640×400 - GMP

Duplicate

Mode

Transform

Can as Size...v

Fit Canvas to L yersa

F t Canvas to Selectioni

Print Size...

Scale Image...

Crop to Selection...

Autocrop Image

Zealous Crop

Merge Visible ayers...L

Flatten Image

Align Visi le Layers...b

Guides

Configure G id...r

Image Pr pertieso

Ctrl+D

Ctrl+M

Alt+Return

Flip orizontallyH

Flip erticallyV

Rotate 90° lockwisec

Rotate 90° counter-clock isew

Rotate 80°1

Guillotine
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3.10 Blend Tool [L] 
The Blend tool creates a new color by gradually mixing multiple colours. This tool fills the 
selected area with a gradient blend of the foreground and background colours. To make a 
blend, drag the cursor in the direction you want the gradient to go, and release the mouse 
button when you feel you have the right position and size of your blend. The softness of 
the blend depends on how far you drag the cursor. The shorter the drag distance, the 
sharper it will be.

There are different possibilities to activate the tool:
From the image-menu: Tools → Paint Tools → Blend.

By clicking the tool icon .

By clicking on the L keyboard shortcut.

Step 1: Select the foreground and 
background colour if you want to 
blend two colours otherwise it will 
take white & black colour as default. 

Step 2: Fill the colour using bucket 
tool

Step 3: Click on blend tool and select the area 
till where you want to have blend effect.
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3.11 Blur/Sharpen Tool [Shift +U] 
Blur mode causes each pixel affected by the brush to be blended with neighbouring pixels, 
thereby increasing the similarity of pixels inside the brushstroke area. 

Sharpen mode causes each pixel to become more different from its neighbours, it increases 
contrast inside the brushstroke area. 

There are different possibilities to activate the tool:
From the image-menu: Tools → Paint tools → Blur/Sharpen.
The Tool can also be selected by clicking the tool icon in the Toolbox.
By using the keyboard shortcut Shift+U.

Holding down the Ctrl key toggles between Blur and 
Sharpen modes; it reverses the setting shown in the 
Tool Options.

	 1.	 Set convolve type to switch between blur\
sharpen.

	 2.	 Set the rate

	 3.	 Click on the canvas area and keep on dragging 
the brush until the desired result is obtained.

Blurring can be useful if some element of your image stands out too much, and you would 
like to soften it. If you want to blur a whole layer, or a large part of one, you will probably 
be better off using one of the Blur Filters.

Before Blurring the image After Blurring the image

Tool Options

Tool Options

Blur/Sharpen
Mode: Normal

Opacity

Brush
2 Sinkel

Size 21.70

0.00

0.00

Aspect Ratio

Angle

Dynamics
Untiltled

Dynamics Options

Apply Jitter

Smooth Stroke

Hard edge

Convolve Type (Ctrl)
Blur

Sharpen

Rate 50.0
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In “Sharpen” mode, the tool works by increasing the contrast where the brush is applied. 
Over-application of the tool will produce noise.

Before Sharpening the image After Sharpening the image

3.12 Smudge Tool [S] 
The Smudge tool uses the current brush to smudge colours on the active layer or a selection. 
It takes color in passing and uses it to mix it to the next colours it meets, on a distance 
you can set.

You can find the Smudge tool in various ways:
Through Tools → Paint Tools → Smudge. in the image menu, by clicking on the tool icon: 
in Toolbox, Or by pressing the S key on keyboard.

Using Ctrl with Shift, you can constrain the angle between two successive lines to vary 
by steps of 15°.

  Before smudging the image After smudging the image

3.13 Dodge/Burn Tool [Shift + D] 
The Dodge tool uses the current brush to lighten the colours in your image. 
The Burn tool uses the current brush to darken the colours in your image.
The mode will determine which types of pixels are affected.
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There are different possibilities to activate the tool:
From the image-menu: Tools → Paint Tools → Dodge / Burn.

The Tool can also be called by clicking the tool icon or by using the Shift+D keyboard 
shortcut.

  Before using the Dodge Tool

Before using the Burn Tool

After using the Dodge Tool

After using the Burn Tool

4. Layers
In GIMP terminology, each individual transparency is called a layer.Layer provides a 
variety of effects that change the appearance of the image. It allows you to work with one 
element of an image without disturbing the others. Layers are the transparent sheets one 
on top of the other. You can see through transparent areas of a layer to the layers below.

A new image in Gimp has a single layer. You can add a number of additional layers to 
add different elements in an image.

4.1 Adding a new layer:
To create a new layer follow the steps:
Layer menu  select new layer.

Enter the information for a new layer; transparency is good for overlapping layers or 
necessary for deleting portions of an image. 
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Give the layer a name which will help you to identify it later, such as while changing the 
background. 

After all the information is set, click the OK button.

New Layer

Create a New Layer
Untitled-4659

Layer ame:n Layer

640

400

Width:

Height:

Layer Fill Type

Foreground color
Background color
White
Transparency

Help OK Cancel

px

Layers - Brushes

Mode: Normal

Opacity 100.0

Lock:

Layer

Background

4.2 Renaming a Layer
To rename a layer after it is created, highlight the layer, right click it and select edit layer 
attributes, then type in a new name.

Edit Layer Attributes...

New Layer...
New from isibleV
New Layer roup...G
D plicate Layeru

Anchor Layer

Merge Do nw

Delete Layer

Layer B undary Size...o

Layer to mage SizeI

Scale Layer...

Add La er Mask...y
Apply Layer askM
Delete Layer Mask

S ow Layer Maskh
Edit Layer Mask
Disable Layer Mask
Mask to Selection

Add Alpha C annelh
Remove Alpha Channel
Alpha to Selection

Merge isible Layers...V
latten ImageF

Layers

Mode: Normal

Opacity 100.0

Lock:

Layer

Layer Attributes

Edit Layer Attributes
Layer-3([Untitles])

Layer ame:n Layer

Help OK Cancel
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4.3 Deleting a Layer
To delete a layer, select the layer and press the bin like looking button at the bottom of 
layers tab.

4.4 Merging a Layer
To merge a layer, 

Step 1: Open both the images as layers.

[Untitled]-5.0 (RGB color, 1 layer) 640×400 - GIMP

File Edit Select View Image Layer Colors Tools Filte sr Windows Help

Toolbox

100% Background (2.6 MB)

*[Untitled]-5.0 (RGB color, 1 layer) 640×400 - GIMP

File Edit Select View Image Layer Colors Tools Filte sr Windows Help

Toolbox

Layers

Mode: Normal

Opacity 100.0

Lock:

earth.jpg

bridge.jpg

100% earth.jpg (4.2) MB

Step 2: Right-click the layer and select merge down or merge 
visible option available in the drop-down menu. The Merge down 
option merges the selected layer with the layer right below it, 
whereas the Merge visible option merges all the visible layers.

Edit Layer Attributes...

New Layer...
New from isibleV
New Layer roup...G
D plicate Layeru

Anchor Layer

Merge Do nw

Delete Layer

Layer B undary Size...o

Layer to mage SizeI

Scale Layer...

Add La er Mask...y
Apply Layer askM
Delete Layer Mask

S ow Layer Maskh
Edit Layer Mask
Disable Layer Mask
Mask to Selection

Add Alpha C annelh
Remove Alpha Channel
Alpha to Selection

Merge isible Layers...V
latten ImageF

Layers

Mode: Normal

Opacity 100.0

Lock:

Layer
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Step 3: Resultant image, after merging the two 
layers.

4.5 Scaling a layer
The Scale Layer command resizes the layer and its contents. The image loses some of its 
quality by being scaled. The command displays a dialog where you can set parameters 
concerning the size of the layer and the image quality.

You can access this command from the image menubar through Layer → Scale Layer.

Scale Layer

Scale Layer
Layer-3 ([Untitles])

Layer Size

Width:

H ight:e

Quality
I terpolation:n Cubic

640

400
640 × 400 pixels
72 ppi

px

Help Reset Scale Cancel

or, 1 layer) 640×400 - GIMP

Image Layer Colors Tools Filte sr Windows Help

Layer B undary Size...o

Layer to mage SizeI

cale Layer...S

rop to SelectionC

Autocrop Lay re

New Layer...
New from isibleV
New Layer roup...G
D plicate Layeru

Anchor Layer
Merge Do nw
Delete Layer

Stack
askM

Tr nsparencya
ransformT

Shift+Ctrl+D
Ctrl+H

Shift+Ctrl+N

4.6 Duplicating a Layer
The Duplicate Layer command adds a new layer to the image which is identical copy of 
the active layer. The name of the new layer is the same as the name of the original layer, 
but with “ copy” appended to it. 
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You can create a duplicate layer by clicking image menu→ Layer → Duplicate Layer, or 
from the local pop-up menu that you get by right-clicking on the Layer Dialog.

Layer Colors Tools Filte sr Windows Help
New Layer...
New from isibleV
New Layer roup...G
Duplicate Layer
Anchor Layer

Merge Do nw

Delete Laeyr

Stack
Mask
Tr nsparencya
Transform

Layer Boundary Size...

Layer to mage SizeI

Scale Layer...

Crop to Selection

Autocrop Lay re

Shift+Ctrl+D
Ctrl+H

Shift+Ctrl+N

Layers

Mode: Normal

Opacity 100.0

Lock:

feeldesain-ferrari-

feeldesain-ferrari-

A Copy of your previous layer will be automatically made in the Layers tab.

5. Masking
The Mask is GIMP’s way of showing the full structure of the selection. Mask also provides 
the ability to interact with the selection in new, and substantially ways.Masking layers 
(similar to the fusion mask in Photoshop)which allows you to work on layers with great 
ease. With this method it is easy to edit corners without touching the layer. 

Step 1. Click the small outlined button at the lower left of the image window to toggle 
Quickmask on and off. The button switches between Quickmask mode, and marching 
ant’s mode. 

You can also use Select → Toggle 
Quickmask, or Shift + Q, to toggle 
between Quickmask and marching 
ants mode. 

In Quickmask mode, the selection is 
shown as a translucent screen overlying-
the image, whose transparency at each 
pixel indicates the degree to which that 
pixel is selected. 

Layer Colors Tools Filte sr Windows HelpImageViewSelectEditFile

[nature] (imported)-3.0 (RGB color, 1 layer) 680×306 – GIMP

All

oneN

nvertI

loatF

y ColorB

Fr m Patho

Selection Editor

Fea her...t

Sharpen

S rink...h

Grow...

Bo der...r

Distort...

Rounded R ctangle...e

Toggle uick MaskQ Shift+Q

Save to hannelC

To athP
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By default the mask is shown in red, but you can change this if another mask colour is 
more convenient. 

5.1 Editing a mask
To edit a mask, go to the channels tab, select “quickmask” channel, right-click to open the 
drop-down menu and selectEdit channel attributes…and change the colour.

Step 1:  Channels

Edit Channel Attributes...

New Channel...
Raise Channel
Lower Channel
D plicate Channelu
Delete Channel

Channel to Sele tionc
dd to SelectionA
ubtract from SelectionS
ntersect with SelectionI

Quick Maks

Red

Green

Blue

	 Step 2:  

Set the settings and press OK

Channel Attributes

Edit Channel Attributes
Quick Mask-4 ([nature]) (imported))

Channel ame:n

Fill opacity:

Qmask

50.0

Help OK Cancel

Step 3:  
H
S
V

R
G
B

A

HTML optation:n

206

100

100

0

144

255

50

0090ff

Current:
Old:

Help Reset OK Cancel

Edit Channel Color    Step 4:  

Before Masking Before Masking
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Summary 
	 1.	 GIMP is a GNU Image Manipulation Program is free and powerful open source image editing 

tool that provides retouching of photos, authoring of photos and composition of photos.
	 2.	 The Align tool is useful to align the image layers with various image objects. 
	 3.	 The Scale Tool is used to scale layers, selections or paths (the Object).
	 4.	 The Shear tool is used to shift one part of an image, a layer, a selection or a path to a direction 

and the other part to the opposite direction. 
	 5.	 The Perspective Tool is used to change the “perspective” of the active layer content, of selection 

content or of a path. 
	 6.	 The Flip tool is used to rotate the image in the other direction to create the image.
	 7.	 The Rotate tool is used to rotate layers within an image.
	 8.	 The Blend Toolis used to fill the selected area with a gradient blend of the foreground and 

background colours.
	 9.	 The Sharpen tool is used to increase the contrast where the brush is applied.
	10.	 The Blur tool is used to blur or softened the areas of an image where the brush is applied.
	11.	 The Smudge tool uses the current brush to smudge colours on the active layer or a selection.
	12.	 The Dodge tool uses the current brush to lightenthe colours in your image.
	13.	 The Burn tool uses the current brush to darken the colours in your image. 
	14.	 The Eraser tool is used on the canvas to erase things.
	15.	 The Pencil Tool is used to draw images on the canvas. 
	16.	 The Paint Brush tool lets you draws brush like strokes.
	17.	 Layers are the transparent sheets one on top of the other.
	18.	 Masking effect allows you to create merge effects in an image.
	19.	 If some of your scanned photos do not look colourful enough, you can easily improve their 

tonal range with the “Auto” button in the Levels tool (Colours→Levels). If there are any color 
casts, you can correct them with the Curves tool (Colours→Curves).

	20.	 Not all effects can be applied to all kinds of images. This is indicated by a grayed-out menu-
entry. You may need to change the image mode to RGB Image→Mode→RGB), add an alpha-
channel (Layer→Transparency→Add Alpha Channel) or flatten it (Image→Flatten Image).

	21.	 Retouching tools are used for the arrangement of pixels. The following are the retouching 
tools available in Gimp:

	22.	 Brush & Pencil Tool 
	23.	 Eraser Tool 
	24.	 Blend Tool 
	25.	 Blur & Sharpen Tool 
	26.	 Smudge 
	27.	 Dodge & Burn Tool
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Exercise
A.	Multiple choice questions
	 1.	 _________ tool helps you to add a new layer to the image which is identical copy of the  

active layer.
	 (a)	Smudge Tool	 	 	 (b)	 Dodge Tool
	 (c)	 Perspective Tool	 	 	 (d)	 Duplicate Layer

	 2.	 By default the mask is shown in ______, but you can change this if another mask colour  
is more convenient. 

	 (a)	Red	 	 	 (b)	 Blue
	 (c)	 Green	 	 	 (d)	 No colour

	 3.	 In _________ mode, the selection is shown as a translucent screen overlying -the image,  
whose transparency at each pixel indicates the degree to which that pixel is selected. 

	 (a)	Default	 	 	 (b)	Quickmask
	 (c)	Marching ants	 	 	 (d)	 Normal

	 4.	 __________ are the transparent sheets one on top of the other.
	 (a)	Masking	 	 	 (b)	 Tools
	 (c)	 Layers	 	 	 (d)	 None of the above 

	 5.	 By default the extension of Gimp file is ______
	 (a)	 .XCf	 	 	 (b)	 .BMP
	 (c)	 .TIFF	 	 	 (d)	 .PNG 

	 6.	 GPL stands for 
	 (a)	General Private license	 (b)	 Great Pioneer License	
	 (c)	 General Public Limited 	 (d)	 General Public License

	 7.	 The image loses some of its quality by being _______
	 (a)	Scaled	 (b) Merging	 (c)	 Renaming	 (d)	Masking

	 8.	 _______ 
	 (a)	Adobe	 (b)	 Gimp	 (c)	 After Effects	 (d)	 Paint Shop Pro X5

	 9.	 In _______ mode, over-application of the tool will produce noise.
	 (a)	Sharpen	 (b)	 Blur	 (c)	 Dodge	 (d)	 Smudging

	 10.	 ________ takes colour in passing and uses it to mix it to the next colours it meets.
	 (a)	Sharpen	 (b)	 Blur	 (c)	 Dodge	 (d)	 Smudging

B.	Answer the following questions:
	 1.	 Name the application areas where Gimp can be used.

	 2.	 Mention all the features of Gimp.

	 3.	 What do you understand by General Public License (GPL)?
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	 4.	 �Which tool is used to align the objects placed on different layers? Explain all its  
options.

	 5.	 Name the properties needs to be changed while scaling the image.

	 6.	 Which tool is used to lighten the pixels in an image?

	 7.	 Which tool is used to darken the colour pixels in an image?

	 8.	 Differentiate between Shear and Perspective tool.

	 9.	 What is the default background and foreground colour of image window?

	 10.	 How is blur tool different from smudge tool?

	 11.	 Name any four tools used for changing the pixel arrangement in an image.

	 12.	 What is the difference between Blur tool and Sharpen tool?

	 13.	 How is flipping an image different from rotating an image?

	 14.	 Write the steps to apply blend effect on an image?

	 15.	 What are Layers? What is the purpose of using Layers?

	 16.	 What is the need of merging the Layers?

C.	 Identify the tools used for the following purpose:
	 1.	 To resize the layer/image	 __________________

	 2.	 To move layers	 __________________

	 3.	 To align the layers with various objects	 __________________

	 4.	 To create the mirror image 	 __________________

	 5.	 To draw free hand drawings	 __________________

	 6.	 To lighten the colour pixels of an image	 __________________

	 7.	 To give wet paint effect in an image	 __________________

	 8.	 To shift one part of an image/ a layer to a particular direction	 __________________

	 9.	 To apply different colours without effecting the original image	 __________________

	 10.	 To remove objects from the canvas	 __________________

D.	Application Oriented Questions
	 1.	 Shivank has collected pictures of his favourite superhero and wants to make a collage of 

the superhero in action. Suggest him the way to make collage.

	 2.	 Amishi wants to change the background of her class photograph with the school \  building. 
Help her to do the same.



38 Information and Computer Technology

	 3.	 Rudraksh has to send his photograph to the passport office for the processing of his 
Passport but his photograph clicked by the photographer is very dark due to insufficient   
light. Help him lighten the colour pixel of his photograph as per the requirement.

	 4.	 Geetanjali has got a project work in she has been given two images, where one image 
depicts a girl walking on the grass and other one depicts an ocean. Now she has to 
project as if the girl is walking on the water surface. Suggest her the way to accomplish 
the task.

	 5.	 Avni wants to change her coloured photograph into white/black photograph along with   
the borders and corners of the image without affecting the original image. Help her to 
do the same. 

	 6.	 Bhuvi is working on her social science project work. She wants to add the image of the  
Minister but the image is not in the required direction. She needs the mirror image of 
the photograph. Suggest her the tool to perform the task.

	 7.	 Mohit has got a hazy image. He wants to increase the contrast of the image. Suggest him  
the tool to complete the task. 

	 8.	 Vasu has inserted an image in a new file. He wants to duplicate the image on the same 
layer. Suggest him the tool which will fulfil his requirement.

E.	 Lab Session

	 1.	 Collect the photographs of your family members and make a 
collage of the same. Design a Birthday card for your friend.

	 (a)	Add image of a flower and text to the card 
	 (b)	Fill the background with the texture format 

	 2.	 Make abstract painting depicting 
Independence Day. Scan the image of 
any car and transform the image as 
shown below.

	 3.	 Make a collage depicting the different seasons such as Rainy, Summer, Autumn, Winter.  
Transform an image using perspective tool.


