
PB 343

18.1 Introduction

“ பிறநாட்டு நல்லறிஞர் சாத்திரங்கள் 

தமிழ்மொழியிற் பெயர்த்தல் வேண்டும்; 

இறவாத புகழுடைய புதுநூல்கள் 

தமிழ்மொழியில் இயற்றல் வேண்டும்; 

மறைவாக நமக்குள்ளே பழங்கதைகள் 

ச�ொல்வதில�ோர் மகிமை இல்லை;

திறமான புலமையெனில் வெளிநாட்டோர்; 

அதை வணக்கஞ் செய்தல் வேண்டும்.”

-  மகாகவி பாரதி

CHAPTER 18
Tamil Computing

Unit VI COMPUTER ETHICS AND 
CYBER SECURITY

	 Human civilization developed with 
the innovation of computer in the twentieth 
century. Computer development began as a 
early calculating tool and has now become 
a essential ingredient for gigantic growth 
for the existence of human life without 
computers. 

	 It is true that any language will be 
outdated when it does not have the ability 
to adapt itself to the changing technologies. 
Tamil is a living language for thousands of 
years. Development of modern technologies, 
does not affect the growth of classical 
Tamil as it is ready to adopt the growing 
technological changes. Tamil is not just a 
language, it is our identity, our life and our 
sense.

“எங்கள் வாழ்வும், எங்கள் வளமும் மங்காத 
தமிழென்று சங்கே முழங்கு” – புரட்சி கவி.

18.2 Tamil in Internet

	 We know that the internet today 
plays a vital role in every man's life. Internet 
is the best information technological device, 
through which we get know  information.
	 In 2017 a study conducted by KPMG 
a Singapore based organization along with 
google, reported that, Tamil topped the list, 
among the most widely used languages in 
India, where 42%  are using the Internet in 
Tamil 
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As per study, by 2021, 74% of people in India will access internet using Tamil and it will be in 
the top usage of Internet in India.

These statistical data will be useful to improve internet services in Tamil.

18.3 Search Engines in Tamil

	 The “Search Engines” are used to 
search any information from the cyber space. 
Although there are many search engines, but 
only a few of them are frequently in use. In 
the top ten search engines, Google, Bing and 
Yahoo take first three places respectively. 
Google and Bing provide searching facilities 
in Tamil, which means you can search 
everything through Tamil. The Google 
search engine gives you an inbuilt Tamil 
virtual keyboard. 

உள்ளீட்டுக் கருவிகள்

Figure 18.1(a) Google Search Engine 
(India)

உள்ளீட்டுக் கருவிகள்

Figure 18.1(b) Google Search Engine 
(Singapore)

Figure 18.2 Searching in Tamil
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18.4  e – Governance:

	 Getting Government services through 
internet is known as e-Governance. Govt. 
of Tamilnadu has been giving its services 
through Internet. One can communicate 
with Govt. of Tamilnadu from any corner 
of the World. One can get important 
announcements, government orders, and 
government welfare schemes from the web 
portal of Govt. of. Tamilnadu. Figure 18.3 Official Website of Govt. of 

Tamilnadu

E-Governance through Tamil Web Address
Official Website of Govt. of Tamilnadu http://www.tn.gov.in/ta
Department of Agricultural Engineering http://www.aed.tn.gov.in/ 
Department of Environment http://www.environment.tn.nic.in/ 
Directorate of Govt. Examinations http://www.dge.tn.nic.in/ 
Tamilnadu Health Department http://www.tnhealth.org/ 
Tamilnadu Micro, Small and Medium 
Enterprises Department

http://www.msmeonline.tn.gov.in/ 

Rural Development and Panchayat Raj 
Department

http://www.tnrd.gov.in/ 

Backward, Most Backward and Minorities 
Welfare Department

http://www.bcmbcmw.tn.gov.in/ 

Tamilnadu Forest Department https://www.forests.tn.gov.in/ 
Hindu Religious and Charitable 
Endowments Department.

http://www.tnhrce.org/ 

Tamil Nadu Public Service Commission 
(TNPSC)

http://www.tnpsc.gov.in/tamilversion/index.
html 

Official Website of Govt. of Srilanka https://www.gov.lk/index.php 

	 Outside India, Government of 
Srilanka provides all their services through 
the official website in Tamil.

18.5 e-Library

	 E-Libraries are portal or website 
of collection of e-books. Tamil e-Library 

services provide thousands of Tamil Books 
as ebooks mostly at free of cost. It is the most 
useful service to Tamil people who live far 
away from their home land.
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Tamil e-Library Website address
Tamilnadu School Education 
and Teacher Education Training 
Textbooks and Resource Books

http://www.textbooksonline.tn.nic.in/ 

Tamil Virtual Academy http://www.tamilvu.org/library/libindex.htm 

Connemara Public Library
http://connemarapubliclibrarychennai.com/
Veettukku_oru_noolagam/index.html 

Tamil Digital Library http://tamildigitallibrary.in/ 
Chennai Library http://www.chennailibrary.com/ 

Thamizhagam
http://www.thamizhagam.net/parithi/
parithi.html 

Project Madurai
http://www.projectmadurai.org/pmworks.
html 

Old Books and Manuscripts
http://www.tamilheritage.org/old/text/
ebook/ebook.html 

Noolaham http://www.noolaham.org/wiki/index.php/ 
Anna Centenary Libraray http://www.annacentenarylibrary.org/ 

18.6 Tamil Typing and Interface software
	 Tamil is mostly used to type 
documents in word processors and search 
information on the internet. Typing Tamil 
using Tamil interface software is a familiar 
one among the different methods of typing. 
This is the simplest method of typing Tamil 
in both Computer and Smart phones.
18.6.1 Familiar Tamil Keyboard Interface:
•	 NHM Writer, E-Kalappai and Lippikar 

– are familiar Tamil keyboard interfaces 
software that is used for Tamil typing 
which works on Tamil Unicode, using 
phonetics. 

•	 Sellinam and Ponmadal – are familiar 
Tamil keyboard layouts  that works on 
Android operating system in Smart 
phone using phonetics. 

Figure 18.4 eKalappai Opening screen

18.7 Tamil Office Automation 
Applications

	 Famous Office automation software 
like Microsoft Office, Open Office etc., 
provides complete Tamil interface facility. 
These softwares are downloadable and 
installed in your computer. After installation, 
your office automation software environment 
will completely change to Tamil. Menu bars, 
names of icons, dialog boxes will be shown 
in Tamil. Moreover, you can save files with 
Tamil names and create folders with Tamil 
names.
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Figure 18.5 Libra Office Writer 
Environments in Tamil

	 Apart from that Tamil Libra Office, 
Tamil Open Office, Azhagi Unicode Editor, 
Ponmozhi, Menthamiz, Kamban, Vani 
are office automation software working 
exclusively for Tamil. You can use these 
applications to work completely in Tamil.

18.8 Tamil Translation Applications
	 Thamizpori (தமிழ்பொறி) is a Tamil 
tranlation application having more than 
30000 Tamil words equalent to English 
words.  Using this application, we can 
translate small english sentences into Tamil. 
Google also gives an online translation 
facility.

18.9 Tamil Programming Language
	 Programming languages to develop 
software in computers and smart phones are 
available only in English. Based on Python 
programming language, the first Tamil 
programming language “Ezhil” (எழில்) is 
designed. 

18.10 Tamil Information Interchange 
Coding Systems

TSCII (Tamil Script Code for Information 
Interchange) 
	 Computers handle data and 
information as binary system. Computers 
use ASCII encoding system to handle data 
and information. The ASCII encoding 
system is applicable only for handling 
English language. Therefore, TSCII (Tamil 
Script Code for Information Interchange) 
is the first coding system to handle our 

Tamil language. This encoding scheme 
was registered in IANA (Internet Assigned 
Numbers Authority) a unit of ICANN. 
ISCII (Indian Script Code for Information 
Interchange) 
	 This is one of the encoding schemes 
specially designed for Indian languages 
including Tamil. It was unified with Unicode.
Unicode:
	 Unicode is an encoding system, 
designed to handle various world languages, 
including Tamil. Its first version 1.0.0 was 
introduced in October 1991. Unicode is the 
best suitable to handle Tamil.

18.11 Tamil Operating System

An operating system is needed to access 
electronic systems such as computer and 
smart phone. Microsoft Windows is very 
popular operating system for personal 
computers. Linux is another popular 
open source operating system. Operating 
systems are used to access a computer easily. 
An operating system should be easy to 
work and its environment should be in an 
understandable form.  Thus, all operating 
systems used in computers and smart phones 
are offered in Tamil environment.

	 Windows Tamil Environment 
interface should be downloaded and 
installed from  the internet. It displays all 
window elements such as Taskbar, desktop 
elements, names of icons, commands in 
Tamil. 

18.12 Organisation and projects to 
develop Tamil

Tamil Virtual Academy:

	 With the objectives of spreading 
Tamil to the entire world through internet, 
Tamil Virtual University was established 
on 17th February 2001 by the Govt. of 
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Tamilnadu. Now, this organisation functions 
with the name of “Tamil Virtual Academy”.  
It offers different courses in Tamil language, 
Culture, heritage etc., from kindergarten to 
under graduation level. 

Website:  http://www.tamilvu.org/index.php
Tamil Language Council, Singapore
	 With the objectives 
of promoting the awareness 
and greater use of Tamil 
among the Singaporeans, in 
2001 the council of Tamil 
Language was formed by the ministry of 
Information Communications and Arts, 
Govt. of Singapore. The council is called as 
“வளர்தமிழ் இயக்கம்”. 
Website:  http://tamil.org.sg/ta
Madurai Project
	 Project Madurai is an open and 
voluntary initiative to collect and publish 
free electronic editions of ancient tamil 

literary classics. This means either typing-in 
or scanning old books and archiving the text 
is one of the most readily accessible formats 
for use on all popular computer platforms. 
	 Since its launch in 1998, Project 
Madurai etexts released are in Tamil script 
form as per TSCII encoding. Since 2004 
we have started releasing etexts in Tamil 
unicode as well.
Web Site: http://www.projectmadurai.org/

Tamil Wikipedia:
	 Wikipedia is a open source 
encyclopedia where any person can write 
an article about any subject. There are more 
than One lakh articles in Tamil Wikipedia. 

Web Site: https://ta.wikipedia.org/
	 In order to make Tamil as a living 
language, it is the duty of every Tamilian to 
actively  use Tamil in the development of 
technology. 

•	 Tamil topped the list of the most widely used regional languages in India by the end of 
2016, among 42% are using the Internet.

•	 Google and Bing provide searching facilities in Tamil.
•	 Getting Government services through internet is known as e-Governance.
•	 Tamil e-Library services provide thousands of Tamil Books as ebooks mostly at free of 

cost.
•	 Thamizpori (தமிழ்பொறி) is a Tamil tranlation application having more than 30000 

Tamil words equalent to English words.
•	 The first Tamil programming language is “Ezhil” (எழில்)
•	 Unicode is an encoding system, designed to handle various world languages, including 

Tamil.
•	 Windows Tamil Environment interface should be downloading and install from 

internet.

Points to Remember:

Evaluation

Very Short Answers
1.	 List the search engines supported by Tamil language.
2.	 What are the keyboard layouts used in Android?
3.	 Write a short note about Tamil Programming Language.
4.	 What is TSCII?
5.	 Write a short note on Tamil Virtual Academy.
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Practical Programs – Hand Book

COMPUTER APPLICATION PRACTICAL 11

Instructions: 
1.	 One exercise from Writer, Calc and CSS, Three exercises from HTML, and Four 

exercises from JavaScript   are     to be practiced in the practical classes.
2.	 Ansewer to any one question from Practical Book with internal choice 
3.	 Distribution of Marks 

I. Internal Assessment:            5 Marks
Record Book 5 Marks
II. External Assessment:           15 Marks

(a) Writer or Calc                            –  Procedure 

      HTML or CSS or JavaScript     –  Coding
10 Marks

(b) Execution & Output 5 Marks

Total 20 Marks

INDEX

Sl. No. Question 
Number Program Name

1 CA1 Open Office Writer - Formatting Invoice  
2 CA2 Open Office Calc – Interest Calculation  
3 CA3 HTML – Form Design
4 CA4 HTML – Height and Weight Table
5 CA5 HTML – Nested List
6 CA6 CSS – Formatting Webpage 
7 CA7 JavaScript – Display  Text
8 CA8 JavaScript – Multiplication Table
9 CA9 JavaScript – Display Weekdays in Words

10 CA10 JavaScript – Login Form
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CA1 – FORMATTING INVOICE

CA-1
Type the following Invoice in OpenOffice Writer and apply the formatting 
features as given below:

Invoice
SAIRAM MEDICAL STORES

Mobile No      : 9002416000
Mail Address  : sairam@gmail.com

P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

23rd Nov 2017

No: 70/162

M/s.	  Eswari Medical Stores,
	 No: 72, N.S.C. Bose Road, 
	 Puduchery - 6210110

For Sriram Medical Stores

Sales Manager

Quantity (Nos) Particulars Rate Amount
20 Johnson Baby Powder 25 500

10 Nestle Milk Powder 100 1000

5 Wood Wards Gripe Water 70 350

Total
Add: GST @ 3%

Net Payable

•	 Use formula to calculate Total and Net Payable

Procedure

	 Step-1.	 OpenOffice Writer and choose Text document or File → New → Text Docu-
ment.

	 Step-2.	 Type the text and apply the format as per the given format.
Note: Select the required text before formatting.

Text Format Method

INVOICE Center and apply red Ctrl + E and choose Red color from 
font color pallete or any method.

SAIRAM MEDICAL 
STORES

Center and apply blue Ctrl + E and Blue color from font 
color pallete or any method.

Eswari Medical 
Stores

Bold Ctrl + B or any method.
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	 Step-3	 Create a table using any one of the method Ctrl + F12   or   Insert → Table or 
Table → Insert → Table or Insert Table icon from toolbar. with 4 columns and 7 rows

	 Step–4.	 Enter the data as per the given format.

	 Step-5.	 Select first three columns in 5th Row and Right Click  →  Cell →  Merge and 
type as "Total"

	 Step-6.	 Repeat Step-5 for 7th Row, and type as "Net payable"

	 Step-7.	 To find the Total, Enter the following formula at Total → Amount Column as  
=<D2>+<D3>+<D4> OR = Sum (<D2:D4>)

	 Step-8.	 To find the GST @ 3% Enter the formula as = <B5> *0.03

	 Step-9.	 To calculate Netpayable amount, Enter the formula as =<B5>+<D6>
Output

Invoice
SAIRAM MEDICAL STORES

Mobile No      : 9002416000
Mail Address  : sairam@gmail.com

P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

23rd Nov 2017

No: 70/162

M/s.	  Eswari Medical Stores,
	 No: 72, N.S.C. Bose Road, 
	 Puduchery - 6210110

For Sriram Medical Stores

Sales Manager

Quantity (Nos) Particulars Rate Amount
20 Johnson Baby Powder 25 500

10 Nestle Milk Powder 100 1000

5 Wood Wards Gripe Water 70 350

Total 1850
Add: GST @ 3% 55.5

Net Payable 1905.5

CA2 -  INTEREST CALCULATION

CA-2
Create statement of interest using OpenOffice Calc with the following partic-
ulars:

	 Sara Ltd., sells goods. Their policy is to charge interest @ 2% p.a., for the number of 
days. From the following data, find out the amount to be collected from each customer. 
Assume 365 days in the year.
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Customer Sales Date of Sale NO. of days Date of 
settlement

Tharani 25000 10/04/2017 60
Mahalakshmi 14000 28/05/2017 30
Kumar 28000 14/07/2017 45
Arulmozhi 54000 03/08/2017 90

Procedure

Step -1. Open OpenOffice Calc and choose Spreadsheet or File →  New → Spreadsheet.
Step -2. Type the Headings in cell A1 to E1 (Customer, Sales, Date of Sale, Number of days 

and Date of settlement) as per the given data.
Step -3. In cell F1 and G1 type (Interest Amt and Amount to be paid) respectively.
Step -4. In cell E2 enter the formula = C2 + D2 to arrive the date of settlement and to the 

remaining cells (E2 to E5). Use Edit → Fill → Down command
Step -5. In cell F2 enter the formula =ROUND((B2*2/100)*D2/365) to arrive the Interest 

amount to the remaining cells (F2 to F5). Use Edit → Fill → Down command
Step -6. In cell G2 enter the formula = B2 + F2 to arrive the Amount to be paid to the remaining 

cells (G2 to G5). Use Edit → Fill → Down command

Output

CA3 – FORM DESIGN

CA-3 Write an HTML code to design a form like the one shown below. 
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Coding

<html>
<head>
<title> User Registration </title>
</head>
<body>
<h1 align = center> Registration Form </h1>
<form id=reg_form  method = post  action = " ">
User Name: <input type = text  name=uname > <br><br>
Password: <input type = password name=pword1 > <br><br>
Re-type Password: <input type = password name=pword2 > <br><br>
Gender: 
<input type = radio  name=male value="M" > Male
<input type = radio  name=female  value="F" > Female
<h2 align=center> Additional Information </h2>
Optional Subject: 
<select name=subj>
	 <option value = CT> Computer Technology
	 <option value = Paint> Painting
	 <option value = SG> Sports and Games
</select>
<br><br>
<input type  = checkbox  name=mail >  Put me on mail list <br> <br> 
<input type = reset  value=Reset >
<input type = submit  value=Submit > 
</form>
</body>
</html>

Output
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CA4 - HEIGHT AND WEIGHT TABLE

CA-4 Write an HTML code to display the following.

Height and Weight

Name Class Height Weight
Mani XII - G 5'0" 45
Vasu XI - H 5'4" 49
Murali XI - B 5'1" 51
Pallavai XII - D 4'5" 50

Coding

<html>
<head>
<title> Height and Weight Table </title>
<head>
<body>
<table border=10>
<caption> Height and Weight </caption>
<tr> 
<th width=40%> Name </th>
<th width=20%> Class </th>
<th width=20%> Height </th>
<th width=20%> Weight </th>
</tr>
<tr> 
<td> Mani	 </td>
<td> XII – G </td>
<td> 5’0” </td>
<td> 45 </td>
</tr>
<tr> 
<td> Vasu </td>
<td> XI – H </td>
<td> 5’4” </td>
<td> 49 </td>
</tr>
<tr> 
<td> Murali </td>
<td> XI – B </td>
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<td> 5’1” </td>
<td> 51 </td>
</tr>
<tr> 
<td> Pallavai </td>
<td> XII - D </td>
<td> 4’5” </td>
<td> 50 </td>
</tr>
</table>  
</body>
</html>

Output

Height and Weight

Name Class Height Weight
Mani XII - G 5'0" 45
Vasu XI - H 5'4" 49
Murali XI - B 5'1" 51
Pallavai XII - D 4'5" 50

CA5 - NESTED LIST 

CA-5
Write an HTML code to create a webpage to display the following sets of 
lists:

1. Tamilnadu
a. Chennai
b. Madurai

• Languages
o	 Tamil
o	 Malayalam
o	 Telugu

2. Andhra Pradesh
a. Amaravathi
b. Vijayawada

• Science
o	  Physics
o	 Chemistry
o	 Zoology

3. Kerala
a. Thiruvananthapuram
b. Cochin

• Humanities
o	  History
o	 Commerce
o	 Economics
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Coding

<html>
<head>
<title> Sets of Lists </title>
</head>
<body>
<OL>
	 <LI> Tamilnadu
		  <OL type=a>
			   <LI> Chennai
			   <LI> Madurai
		  </OL>
	 <LI> Andhra Pradesh
		  <OL type=a>
			   <LI> Amaravathi
			   <LI> Vijayawada
		  </OL>
	 <LI> Kerala
		  <OL type=a>
			   <LI> Thiruvananthapuram
			   <LI> Cochin
		  </OL>

</OL>
<UL>
	 <LI> Languages
		  <UL type=circle>
			   <LI> Tamil
			   <LI> Malayalam
			   <LI> Telugu
		  </UL>
	 <LI> Science
		  <UL type=circle>
			   <LI> Physics
			   <LI> Chemistry
			   <LI> Zoology
		  </UL>
	 <LI> Humanities
		  <UL type=circle>
			   <LI> History
			   <LI> Commerce
			   <LI> Economics
		  </UL>
</UL>
</body>
</html>

Output

1. Tamilnadu
a. Chennai
b. Madurai

2. Andhra Pradesh
a. Amaravathi
b. Vijayawada

3. Kerala
a. Thiruvananthapuram
b. Cochin

• Languages
o	  Tamil
o	  Malayalam
o	  Telugu

• Science
o	   Physics
o	  Chemistry
o	  Zoology

• Humanities
o	   History
o	  Commerce
o	  Economics

Computer Application Practical.indd   356 3/20/2020   4:36:19 PM



357

CA6 -  FORMATTING WEBPAGE 

CA-6 Create a webpage as given description using CSS

Tamil

	 Tamil is a Dravidian language predominantly spoken by the Tamil people of India 
and Sri Lanka, and by the Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, and 
Chindians. Tamil is an official language of two countries: Sri Lanka and Singapore. 

	 It has official status in the Indian state of Tamil Nadu and the Indian Union Territory 
of Puducherry. It is used as one of the languages of education in Malaysia, along with 
English, Malay and Mandarin. 

	 Tamil is spoken by significant minorities in the four other South Indian states of 
Kerala, Karnataka, Andhra Pradesh and Telangana and the Union Territory of the Andaman 
and Nicobar Islands. It is one of the 22 scheduled languages of India.

Description:

Element Font Style Alignment Color

H1 Arial Black - Center Border 2px 
solid blue

P1 Century Bold - Red

P2 Boockman Old Style Italic - Blue

P3 Century Gothic - - Green

Note: Create two files. 1. Mystyle.css and 2. CA6.html

Coding -1

Mystyle.css
H1
{
  font-family: "Arial Black";
  text-align:center;
  border : 2px solid blue;
}
P1
{
 font-family: "Century";
 font-style : Bold;

 color : Red;
}
P2
{
 font-family: "Bookman Old Style";
 font-style : Italic;
 color : Blue;
}
P3
{
 font-family: "Century Gothic";
 color : Green;
}
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Coding -2
CA6.html
<html>
<head>
<title> Tamil </title>
<link rel="stylesheet" type="text/css" 

href="mystyle.css">
</head>
<body>
<H1> Tamil </H1>
<P1>
Tamil is a Dravidian language predominant-
ly spoken 
by the Tamil people of India and Sri Lanka, 
and by the 
Tamil diaspora, Sri Lankan Moors, Bur-
ghers, Douglas, 
and Chindians. Tamil is an official language 
of two countries: 
Sri Lanka and Singapore.
</P1> <br> <P2>

It has official status in the Indian state of 
Tamil Nadu 
and the Indian Union Territory of 
Puducherry. 
It is used as one of the languages of educa-
tion in Malaysia, 
along with English, Malay and Mandarin.
</P2> <br> <P3>
Tamil is spoken by significant minorities in 
the four other 
South Indian states of Kerala, Karnataka, 
Andhra Pradesh 
and Telangana and the Union Territory of 
the Andaman and 
Nicobar Islands. It is one of the 22 sched-
uled languages of 
India.
</P3>
</body>
</html>

Output

Tamil
	 Tamil is a Dravidian language predominantly sopken 
by the Tamil people of India and SriLankan Moors, Burghers, 
Douglas, and Chindians. Tamil is an official language of two 
countries: Sri Lanka and Singapore.

	 It has official status in the Indian state of Tamil Nadu 
and the Indian Union Territory of Puducherry. It is used as one 
of the languages of educatiooon in Malaysia, along with English, 
Malay and Mandarin.

	 Tamil is spoken by significant minorities in the four 
other south Indian states of Kerala, Karnataka, Andhra Pradesh 
and Telangana and the Union Territory of the andaman and 
Nicobar Islands. It is one of the 22 scheduled languages of India.
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CA7 - DISPLAY  TEXT

CA-7 Create a webpage using JavaScript to display the following text.

Welcome to JavaScript
State Council of Educational Research and Training (SCERT), 
Tamilnadu, Chennai.

Coding 

<html>
<head>
<title> Display text using JavaScript </title>
</head>
<body align=center>
<p> 
<script>
 document.write ("<h1 align=center>Welcome to JavaScript <br>");
 document.write ("State Council of Educational Research and Training (SCERT),<br>");
 document.write ("Tamilnadu, Chennai. </h1>");
</script>
</p>
</body>
</html>

Output

Welcome to JavaScript

State Council of Educational Research and Training (SCERT),

Tamilnadu, Chennai.

CA8 – MULTIPLICATION TABLE

CA-8 Create a webpage using JavaScript to display multiplication table by prompting 
number of rows and columns.

Coding 
<html>
<head>
  <title>Multiplication Table</title>
  <script type="text/javascript">
    var rows = prompt("How many rows for your multiplication table?");
    var cols = prompt("How many columns for your multiplication table?");
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    if(rows == "" || rows == null)
   		   rows = 10;
    if(cols== "" || cols== null)
   		   cols = 10;
    createTable(rows, cols);
    function createTable(rows, cols)
    {
      var j=1;
 var output ="<table border='1' width='500' 
cellspacing='0'cellpadding='5'>";
      for(i=1;i<=rows;i++)
      {
    	 output = output + "<tr>";
        while(j<=cols)
        {

CA9 - DISPLAY WEEKDAYS IN WORDS

CA-9 Create a webpage using JavaScript to display Weekday in words by getting 
input as a number using switch.

  	  output = output + "<td>" + i*j + "</
td>";
   		    j = j+1;
   		  }
   		   output = output + "</tr>";
   		   j = 1;
    }
    output = output + "</table>";
    document.write(output);
    }
  </script>
</head>
<body>
</body>
</html>

Output

 

1 2 3 4 5 6

2 4 6 8 10 12

3 6 9 12 15 18

4 8 12 16 20 24

5 10 15 20 25 30

6 12 18 24 30 36

7 14 21 28 35 46

8 16 24 32 40 48

9 18 27 36 45 54

10 20 30 40 50 60

11 22 33 44 55 66

12 24 36 48 60 72

Coding 
<html>
<head>
<title> Weekday </title>
<script type="text/javascript">
var n=prompt("Enter a number between 1 
and 7");
switch (n)

{
case (n="1"):
document.write("Sunday");
break;
case (n="2"):
document.write("Monday");
break;
case (n="3"):
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document.write("Tuesday");
break;
case (n="4"):
document.write("Wednesday");
break;
case (n="5"):
document.write("Thursday");
break;
case (n="6"):
document.write("Friday");
break;
case (n="7"):
document.write("Saturday");
break;
default:
document.write("Invalid Weekday");

break;
}
</script>
</head>
</html>

Output

Thursday

CA10 - LOGIN FORM

CA-10
Create a Form using JavaScript to get username, password and address, 
validate the inputs. 

Coding 
<html>
<head>
<script type="text/javascript">
function sub()
{
if(document.getElementById("t1"). 
value == "")
alert("Please enter your name");
else if(document.getElementById("t2").
value == "")
alert("Please enter a password");
else if(document.getElementById("t2").
value != document.getElementById("t3").
value)
alert("Please enter correct password");
else if(document.getElementById("t4").
value == "")
alert("Please enter your address");
else
alert("Form has been submitted");
}
</script>
</head>
<body>
<form>

<p align="center">
User Name:<input type="text" 
id="t1"><br><br>
Password:<input type="text" 
id="t2"><br><br>
Confirm Password:<input type="text" 
id="t3"><br><br>
Address:<textarea rows="2" cols="25" 
id="t4"></textarea><br><br>
<input type="button" value="Submit" on-
click="sub()">
<input type="reset" value="Clear All">
</p>
</form>
</body>
</html>

Output
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