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Learning Objectives

Students will be able
•	 �To know the features of 

OpenOffice Calc. 
•	 Use of different operators.
•	 �Generation of Series.
•	 �Edit Formula in 

Worksheet.
•	 �Manipulation of Rows/Columns in Worksheet.
•	 Understand various text format in options.
•	 �Use of Number format in Worksheet.

9.1 Introduction to spreadsheet
	 Spreadsheet is a very useful office 
automation tool to organise, analyse and 
store data in a tabular form. Spreadsheet was 
developed as computerized equivalent to 
paper-based accounting worksheets. 

	 Spreadsheet users can adjust any of 
the stored values and can observe the effects 
on the calculated values.  This is called "What 
if" analysis. Modern spreadsheet can have 
multiple interacting sheets and can display 
data either as text or numerals or in a graphical 
form.

9.1.1 Evolution of Spreadsheet
	 Daniel Bricklin and Bob Frankston 
developed the first spreadsheet called  
“VisiCalc” in 1979 for Apple II. In 1982, Lotus 
Corporation introduced “Lotus 1-2-3”; Lotus 
1-2-3 was the first to introduce cell names 
and macros. In 1987, Microsoft Corporation 
introduced Excel. Excel implemented a 
Graphical User Interface (GUI) and the ability 

to point and click using a mouse. There are lots 
of other spreadsheet applications; Microsoft 
Excel continues to be the most popular 
spreadsheet software.

Daniel Singer "Dan" 
Bricklin (born 16 July 
1951), often referred 
to as “The Father of 
the Spreadsheet”, is the 
American Co-Creator, 

with Bob Frankston, of VisiCalc 
spreadsheet. He also founded Software 
Garden, Inc., in which he is currently 
the President of Trellix Corporation, 
which is currently owned by Web.com.  
He currently also serves as the Chief 
Technology Officer of Alpha Software.

Daniel Singer "Dan" Bricklin
The Father of Spreadsheet

	 OpenOffice Calc is a popular open 
source spreadsheet application maintained 
by Apache Foundation. Star Office calc is the 
parent application of OpenOffice Calc which 
was developed by a German Company namely, 
Star Division in 1985.

9.2 Working with OpenOffice Calc

	 Calc is the spreadsheet component of 
OpenOffice. You can enter any kind of data in 
a spreadsheet and then manipulate this data 
to produce certain results. Alternatively, you 
can enter data and then use Calc in a ‘What 
If...’ manner by changing some of the data 
and observing the results without having to 
retype the entire spreadsheet.

CHAPTER 9Unit III Spreadsheet

Introduction to Spreadsheet
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VisiCalc ("Visible Calculator") was 
the first spreadsheet for personal 
computers, originally released for the 
Apple II by VisiCorp. It is considered  
that VisiCalc turned the microcomputer 
from a hobby for computer enthusiasts 
into a serious business tool, prompting 
IBM to introduce the IBM PC, two 
years later. It was sold over 700,000 
copies in six years, and as many as 1 
million copies over its history.

First Spreadsheet

9.2.1 Features of OpenOffice Calc:

•	 Connecting with Excel - Ability to 
open, edit, and save Microsoft Excel 
spreadsheets.

•	 AutoSum - helps you to add the 
contents of a cluster of adjacent cells.

•	 List AutoFill - automatically extends 
cell formatting when a new item is 
added to the end of a list.

•	 AutoFill - allows you to quickly fill cells 
with repetitive or sequential data such 
as chronological dates or numbers, and 
repeated text. AutoFill can also be used 
to copy functions. You can also alter 
text and numbers with this feature.

•	 Charts - helps you in presenting a 
graphical representation of your data 
in the form of Pie, Bar, Line charts and 
more.

•	 Functions - which can be used to 
create formula to perform complex 
calculations on data

•	 Database functions - to arrange, store, 
and filter data

9.3 Creating a new worksheet

	 A new worksheet can be created 
through various methods. From Windows, 
select 

Start → All Programs → OpenOffice → 
OpenOffice Calc (or)

From Star Center (Welcome Screen):

Double-click on “OpenOffice” icon the 
desktop

Now, a welcome screen appears as shown 
in Figure 9.1.  

	 This open screen is called as “Star 
Center”. Calc is one of the component of 
OpenOffice. So, it may be invoked from 
the “Star Center” by simply clicking on 
the “Spreadsheet” icon.   

(or)

	 A new spreadsheet can also be 
created by selecting File → New → 
Spreadsheet from any OpenOffice 
Application. After using any one of the 
above said methods, OpenOffice Calc 
window appears as shown in Figure 9.2. 
The outline of the window is very similar to 
other application windows of OpenOffice. 
The main area of the Calc window is called 
as “Work area” or “Worksheet”. 

	 A worksheet is a grid of cells with a 
programmable calculator attached to each 
cell.  When you open a new spreadsheet, 
there are three worksheets available by 
default(Sheet1, Sheet2, Sheet3). You can 
include more sheets and organize them. 
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Figure 9.1 Opening Screen (Star Center) of OpenOffice
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Figure 9.2 OpenOffice Calc Window
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9.3.1 Parts of the OpenOffice Calc 
Wi n d o w

	 Appearance of the Calc window is 
very similar to that of the Writer window. 
The workspace of Writer is a big blank 
area. But, in Calc, the grid of cells is the 
workspace. 

9.3.1.1 Title Bar

	 At the top of the window is the 
“Title Bar”. It is used to show the name of 
the file and its application. In OpenOffice 
Calc, the default name for the first unsaved 
worksheet is “Untitled1”.

9.3.1.2 Control Buttons:

	 In the right corner of title bar, (1) 
minimize, (2) maximize / restore and (3) 
close control buttons are available.

9.3.1.3 Menu Bar

	 Below the title bar is the menu bar. 
Most of the menus are very similar to what 
you have learnt in OpenOffice Writer. 

	 File - menu contains the commands 
of all file management tasks like, Create 
a new file, Open an existing file, Close 
the current file, Save a file, Save a file in 
another name, print file, Export file etc.

	 Edit - menu contains the editing 
commands like, cut, copy, paste, Undo, 
Redo, Fill etc., Most of the menu items are 
similar to Writer Edit menu. But, for Calc, 
some special editing options are available 

under this menu.

	 View - menu contains the 
commands which are used to modify the 
environment of Calc.

	 Insert – menu contains commands 
for inserting various Calc elements such 
as cells, columns, rows, functions, charts 
etc.,

	 Format – menu contains the 
commands of various text and cell 
formatting features.

	 Tools – menu contains various tools 
and functions such as spell check, protect 
document, insert pictures, macros, etc.,

	 Data – menu contains the 
commands to manipulate data in a 
worksheet such as sort, filter, subtotal, 
validity etc.,

	 Window – menu shows display 
options such as New Window, Close 
Window, Split and Freeze.

	 Help – menu lists in-built help 
features available with OpenOffice.

9.3.1.4 Tools Bar

	 Under the menu bar, there are three 
toolbars available by default. They are:

(1) Standard Toolbar 
(2) Formatting Toolbar 
(3) Formula bar
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Standard Toolbar 

Formatting Toolbar Formula bar 

Figure 9.3 OpenOffice Calc Tool bar

	 Standard Toolbar – contains 
frequently used menu such as File, Edit,  
Data etc., commands as icons such as New 
Open Save, Send, Print, Print Preview, 
Cut, Copy, Paste, Sorting, Inserting chart 
etc.,

	 Formatting Toolbar – contains 
frequently used text and cell formatting 
commands as such as changing font style, 
font size, font colour, alignments, cell 
formatting etc.,

	 Formula bar – This is a very 
important element in a spreadsheet. It 
contains Name box, Function Wizard, 
Sum button, Function button and Input 
line (Refer Figure 9.4).

	 Name box : It display the current 
cell address 

	 Function Wizard : It is used to 
insert function 

	 Sum button : It is used to quickly 
insert sum function.

	 Input Line : This is used to show 
the contents of the current cell. It always 

shows actually what is typed in a cell. It 
can also be used to edit the contents. 

	
Name box / Address Box Input Line

Sum button
Fun c t i on 
Wizard

Fun c t i on 
button

Figure 9.4  Calc Formula bar

9.3.1.5 Scroll bar

	 Spreadsheet window also has two 
sets of scroll bars (1) Vertical Scrollbar 
and (2) Horizontal Scrollbar  (Refer Figure 
9.5)

Vertical Scroll bar : It is used to move the 
screen up and down.

Horizontal Scroll bar : It is used move 
the screen left and right.

Scroll buttons : used to move the screen 
to the relative distance.
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Upward 
Scroll arrow

Scroll button

Downward
Scroll arrow

Right Scroll 
arrow

Scroll button
Left Scroll

arrow

Vertical Scroll bar

Horizontal Scroll bar

Figure 9.5  Calc Scrolling bar

9.3.1.6 Row, Column, Cell and Cell 
Pointer

	 Below the formula bar contains 
the worksheet of work area which consist 
of grid cells  The worksheet has number 
of rows and columns, where each column 
is labelled as A, B, C, D ….. AA, AB, AC 
….. and the rows are numbered from 1, 2, 
3 …. (Figure 9.6).

	 OpenOffice Calc version 4.1.5 
contains 1024 columns ands 10,48,576 
rows. Column heading starts from A and 
end with AMJ. In the case of Microsoft 
Excel 2016, there are 16,384 columns  
(A to XFD) and 10,48,576 rows. 
(OpenOffice Calc Version 4.1.5). 

Cell

	 Intersection of each row and 
column is a box which is called as a 
“Cell”. Each cell has a unique address. 

Cell address is the combination of column 
heading and row number.  For example, 
the intersection of column B and row 4 
makes a cell B4. (Figure 9.7). Every cell is 
thus identified by its unique cell address.

	 Cell pointer is a rectangular box 
which can be moved around the worksheet. 
The cell in which the cell pointer is currently 
located is known as “Active cell”. When you 
type any content, it will appear in the active 
cell. The address of the active cell is displayed 
in the Name box / Address box. Active cell’s 
column name and row number will be 
highlighted. Using this visual clue, one can 
easily identify an active cell. Moreover, the 
contents of an active cell will be displayed in 
the formula bar.
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Figure 9.6  Calc Rows, Columns, Cells 

Current Cell Address Highlighted Column Heading

Highlighted Row Number

Active all

Figure 9.7  Cells, Rows and Columns

9.3.1.7 Worksheet tabs

Active Sheet

Sheet Count
Sheet Navigation buttons

Figure 9.8  Calc Sheet Tab
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	 At the bottom of the grid of cells 
are the sheet tabs. By default there are 3 
sheets “Sheet1”, “Sheet2” and “Sheet3”, 
(Figure 9.8). When you open a new 
worksheet, sheet1 is the default active 
sheet. Active sheet tab will appear in white 
colour. If you click on another sheet, it 
will become active and its colour will turn 
white. Multiple sheets can also be selected 
by clicking the sheet and press the Ctrl 
button (Ctrl + Click). Selected sheets will 
turn to white colour. 

	 On the left of the sheet tab, four 
navigation buttons are used to move 
between worksheets (Figure 9.9). 

1 3

2 4

Figure 9.9  Calc Sheet tab and  
Navigation buttons

(1) Move to the First sheet
(2) Move to the previous sheet
(3) Move to Next sheet
(4) Move to the Last sheet 

	 Left corner of status bar shows the 
total count of sheets and the present active 
sheet number. For example, if the status 
bar shows sheet 3/12; 3 refers to the serial 
number of the current sheet and 12 refers 
to the total number of sheets available.

	 Each sheet name can be renamed. 
To rename a sheet, just double-click on 
the sheet, which will show a small box as 
shown in Figure 9.10.

Figure. 9.10  Rename Sheet dialog box

	 It shows the current name; delete 
or overwrite the existing name and type 
a new name; click OK button. New name 
will be displayed on the sheet.

9.3.1.8 Status bar
	 Below the sheet tabs and horizontal 
scrolling bar is the “Status Bar”. It shows 
the current status of the worksheet (Refer 
Figure 9.11). 

	 Sheets count:  Displays current 
serial number of the sheet / total number 
of sheets available.

	 Page Style: Displays the page style 
of the current sheet. To make changes, just 
double-click on “Default” and  it will show 
you the “Page Style” dialog box, which is 
used to change the margin, orientation, 
paper size, inserting header, footer, border 
style etc.,

	 Selection Mode: Displays the 
selection mode of the current sheet. There 
are three modes available to select the cells 
of a worksheet. They are, Standard (STD), 
Extend (EXT) and Add (ADD). 

Unsaved Changes: An asterisk ( * ) symbol 
indicates that the changes are made in the 
worksheet but not yet saved. If you have 
saved your changes, it will disappear. 
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Sheets count

Page Style Unsaved Changes cell information

Selection Mode Zoom

Figure 9.11 Calc Status bar

9.4 Working with Data

	 When you open a new worksheet, 
the cell pointer is located in cell A1. So, 
the cell A1 is known as “Home Cell”. Cell 
pointer can be moved anywhere in the 
worksheet using the direction keys. 

	 “Tab key” is used to move the cell 
pointer towards the right side or in the 
forward direction. “Shift+Tab” is used to 
move backward i.e. from right to left in 
a row. “Enter” key is also used to move 
the cell pointer. Enter moves the cell 
pointer to a cell below the current cell i.e. 
downwards. Four “direction keys” are 
used to move the cell pointer anywhere in 
the worksheet.

9.4.1 Entering Data:

	 Any data can be typed direc	
tly in any cell of the worksheet. But, the 
cell in which you type data should be an 
active cell. So, move the cell pointer to a 
particular cell to make it active cell; or 
click any cell to make it active cell. Then, 
start typing any data. When you type data, 
spreadsheet recognises the type of data 
entered in cells.

Data types: 

	 Data are of different types. Data 
are made up of alphabets, numbers, Date 
and time is also another data type even 
though it has numbers and symbols. In 

general, data types are classified as:

	 Alphabetic data type – consists 
of alphabets only, Numeric data type – 
consists only of numbers (whole number 
or fractional numbers), Alphanumeric 
data types – consists of a combination of 
alphabets and numerals, Date data type 
– consists only of date, Time data type – 
consists only time.

9.4.1.1 Entering Numbers:

	 Any numeric data can be entered in 
a worksheet. Entered numbers are aligned 
to the right side within the cell by default. 
Negative numbers may be entered with 
a minus sign or within brackets (Refer 
Figure 9.12). If you enter any number 
within the bracket, it will be changed as 
negative number i.e., number prefixed 
with minus. If any number starts with 0 
(zero), Calc will drop the leading zero.

Figure 9.12 Entering data

9.4.1.2 Entering Text:

	 Unlike numbers, any character can be 
entered as data in Calc. Entered text will be 
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aligned to the left side within the cell by default. 
When you enter any numeric value, if it is 
aligned left, it is understood that the entered 
content is not a number. If there is any number 
that starts with a single quote, Calc converts 
that number to text (Refer Figure 9.13). 

Figure 9.13 Entering Text

9.4.1.3 Entering Date and Time:

	 Before entering date, ensure the format 
of your system date. Calc accepts date as per 
the system date format. If your system has 
American date format i.e. month-date-year; 
you should enter dates in Calc spreadsheet as 
mm/dd/yy. If your system follows the Indian 
date format, date should be entered as dd/
mm/yy form in Calc.  

	 For example: if your system has 
American Date format, 18th December 2017 
should be entered as 12/18/17. As soon as the 
date is typed in the correct form, the entered 
date will be aligned on the right side within 
the cell, and if you place the cell pointer in 
that cell, the formula bar shows your date as 
“12/18/2017” (Figure 9.14). This is a visual 
clue to know whether the date is accepted or 
not. 

	 A Date format can be changed to any 
other valid form using “Cell Formatting” 
dialog box and it will be discussed later.

Figure 9.14 Entering Date

	 Like dates, for entering time, Calc 
follows the general format HH:MM:SS, 
where HH, MM and SS represent hours, 
minutes and seconds respectively.

Different Date Formats

Order styles Countries

DD/MM/YYYY

Asia (Central, SE, 
West), Australia, New 
Zealand, parts of Europe, 
Latin America, North 
Africa, India, Indonesia, 
Bangladesh and Russia 

YYYY/MM/DD

Bhutan, Canada, China, 
Koreas, Taiwan, Hungary, 
Iran, Japan, Lithuania, 
Mongolia.

MM/DD/YYYY
United States, Federated 
States of Micronesia, 
Marshall Islands

DD/MM/YYYY 
and

MM/DD/YYYY

Malaysia, Nigeria, 
Philippines, Saudi Arabia, 
Somalia

DD/MM/YYYY
and

YYYY/MM/DD

Afghanistan, Albania, 
Austria, Czech Republic, 
Germany, Kenya, Macau, 
Maldives, Montenegro, 
Namibia, Nepal, 
Singapore, South Africa, 
Sri Lanka, Sweden.

9.5 Creating Formulae

	 After entering the data in 
worksheet, you can perform calculations 
on the data in the worksheet. In order to 
create formulae, you first need to know 
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the syntax that describes the 
format for specifying a formula. 

	 In Calc, you can enter 
formulas in two methods, either 
directly into the cell or at the 
input line.  Formula in Calc may 
start with equal (=) or plus(+) 
or minus(–) sign followed by a 
combination of values, operators 
and cell references. But, as a 
general practice, all formulas 
should start with an equal sign. 
If any formula starts with a + or 
–, the values will be considered as 
positive or negative respectively.

9.5.1 Operators

	 Operators are symbols 
for doing some mathematical, 
statistical and logical 
calculations. Combination 
of values, operators and 
cell references is called as 
“Expression”. Calc supports a 
variety of operators which are 
categorized as: 

(1)  Arithmetic Opertors
(2)  Relational Operators
(3)  Reference Operators
(4)  Text Operator

9.5.1.1 Arithmetic Operators

	 Arithmetic operators are 
symbols for performing  simple 
arithmetic operations such as 

addition, subtraction, multiplication, division etc., 
These operators return a numerical result. 
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2 + Addition 98 25 = B2 + C2 123
3 - Subtraction 125 25 = B3 – C3 100
4 * Multiplication 25 5 = B4 * C4 125
5 / Division 90 10 = B5 / C5 9
6 ^ Exponent 25 2 = B6 ^ C6 625
7 % Percent 600 = B7 * 35% 210
8 Percentage (%) operator shows percentage of the content.

Table 9.1  List of Arithmetic Operators

	 Formula bar shows the formula what the user 
has entered. But, the cell shows the resultant value 
(Figure 9.15).

Formula Entered

Figure 9.15 Percentage Operator

9.5.1.2 Relational Operators

	 Relational operators are symbols used for 
comparing two values such as greater than, less than, 
equal to etc. The relational operators are also called 
as "Comparative operators". These operators return 
either a True or a False. 
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2 >
Greater 

than
98 100 =B2>C2 FALSE

3 >=

Greater 
than 

or equal 
to

85 72 =B3>=C3 TRUE

4 < Less than 54 24 =B4<C4 FALSE

5 <=
Less than 
or equal 

to
55 55 =B5<=C5 TRUE

6 = Equal to 12 12 =B6=C6 TRUE

7 <>
Not equal 

to
54 45 =B7<>C7 TRUE

Table 9.2  List of Relational Operators of cells. 

9.5.1.3 Reference Operator

	 Reference operators are used to 
refer cell ranges. A continuous group 
of cells is called as “Range”. There are 
three types of reference operators that 
are used to refer cells in Calc: they are 
(1) Range Reference Operator, (2) Range 
Concatenation (3) Intersection Operator.

Range Reference Operator

	 Colon (:) is the range reference 
operator. It is used to group a range of 
cells. An expression using a range operator 
has the following syntax:

reference left : reference right

where reference left is the starting cell 
address of a linear group of cells or upper 
left corner address of a rectangular group 

Reference right is the  last cell address of a 
linear group or lower right corner address 
of a rectangular group of cell.

Figure 9.16 Entering Relational Operator
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Example: 

(i)	 Linear group of cells A1, A2,A3,A4,A5 is referred as A1:A5

(ii)	 Rectangular group of cells A2, A3, A4, ….. B2, B3, B4,….D5, D6 is referred as 
A2:D6 (Refer Figure 7.17)

Range of Cells Highlighted Columns (Selected)
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ig

hl
ig

ht
ed
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ow

 (S
el
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d)

Figure 9.17 Range of selected cells

	 Name box shows the reference A2:D6 corresponding to the cells included in the 
drag operation with the mouse to highlight the range.

Reference concatenation operator:

	 Concatenation means joining together. Tilde (~) symbol is used as a concatenation 
operator in calc. An expression using a concatenation operator has the following syntax:

reference left ~ reference right

Example:

	 If you want to find the sum of the values from A1 to A6 and C3 to F3. The formula 
is =SUM(A1:A6 ~ C3:F3)

Note

SUM is a function to find the sum of a group of  values. (Refer Figure 9.18)
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Figure 9.18  Reference concatenation operator

Intersection Operator:

	 Intersection operator is used to join two set of groups. It is very similar to Range 
concatenation operator. The intersection operator is represented by an exclamation

reference left ! reference right

Example: (A2:D3 ! B2:E4)

A

1

2

3

4

B C D E F

Range - 1 A2 : D3

A1 B1 C1 D1 E1 F1

A2 B2 C2 D2 E2 F2

A3 B3 C3 D3 E3 F3

A4 B4 C4 D4 E4 F4

B2:D3
Intersection of
Range 1 and 
Range 2

B2:E4Range 2

Figure 9.19  Intersection operator

	 The result of (A2:D3 ! B2:E4) is referred by the range B2:D3, because these cells are 
both inside A2:D3 and B2:E4 (Refer Figure 9.19 and 9.20).



148 149

Figure 9.20  Worksheet with Intersection operator

9.5.1.4 Text Operator:

	 In Calc, “&” is a text operator which is used to combine two or more text. Joining two 
different texts is also known as “Text Concatenation” (Refer Figure 9.21). An expression 
using the text operator has the following syntax:

text reference1 & text reference2

Figure 9.21  Text operator

	 When arithmetic operators are used in a formula, Calc displays the results using 
the rule of precedence followed in Mathematics. The order is:

I.	 Exponentiation ( ^ )			   II.	 Negation ( - )	

III.	 Multiplication and Division ( *, /)	 IV.	 Addition and Subtraction (+, -)

Here is an example to illustrate how to create a formula:
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Illustration 1:

Create a Marks worksheet with the following data:

Reg. No Name Tam Eng CS Com Acc
12001 Jayashree J 147 136 105 163 162
12002 Kowsalya T 156 148 149 147 179
12003 Muskan S 149 165 123 168 179
12004 Ashia Stephy R 168 144 146 192 167
12005 Vennila T P 199 198 150 200 200
12006 Deepika M 187 141 98 130 178
12007 Tharani J 165 102 100 192 192
12008 Thulasi A 143 169 88 176 173
12009 Ayisha B 120 138 109 182 167
12010 Jenifer A 145 135 95 180 185

After completing the data entry, your worksheet will look as shown in Figure 9.22.

Small red triangle indicates the column width  
is not sufficient to display the entire text

Figure 9.22  Worksheet Illustration

9.5.2 Construction of formula

To construct a formula, follow the steps below:
•	 Cell pointer should be in the cell in which you want to display the result.
•	 Formula should begin with an = sign.
•	 While constructing a formula, BODMAS rule should be kept in mind.
•	 General Syntax of constructing a formula is: = cell reference1 <operator> cell 

reference2 <operator> ……………….
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•	 Cell references are of two types (i) Relative cell reference (ii) Absolute Cell reference.
•	 In Calc, while constructing formulae, cell addresses are "Relative cell reference" by 

default. 
•	 Examples of Relative Cell addressing: 

Adding values of A1, B1, C1, D1 =A1+B1+C1+D1

Subtract E4 from H3 = H3 – E4

Multiply  A5 and B5 = A5 * B5

Average of G1, G2, G3, G4 =(G1+G2+G3+G4)/4

•	 In the above table, all cell references are “Relative cell addressing:”.
•	 While using a formula, if you use the $ symbol in front of a column name and row 

number, it will become an “Absolute Cell addressing”. 
•	 Examples of Absolute cell addressing: 

Adding values of A1, B1, C1, D1 =$A$1+$B$1+$C$1+$D$1

Subtract E4 from H3 = $H$3 – $E$4

Multiply A5 and B5 = $A$5 * B5

Average of G1, G2, G3, G4 =($G$1+G2+$G$3+G4)/4

•	 In an expression, all cells need not necessarily be relative or absolute. You can mix 
both type of references.

•	 The following section explains the use of relative cell addressing. About “Absolute cell 
addressing”, you will be learn later in this chapter.

Finding Total to the above Illustration:
•	 Move the cell pointer to H2 (Total column)
•	 Type the following formula; after entering the formula, press “Enter” key
	 = C2+D2+E2+F2+G2 (Refer Figure 9.25)
•	 Now, you will get the sum of all the values of C2, D2, E2, F2 and G2
•	 The above-mentioned formula clearly states that, how worksheets are working with 

cells.
•	 While referring to the cell addresses in a formula, the worksheet reads the value inside 

the cell that you refer. This is a good practice of constructing a formula. Because, if 
you change any value, the worksheet recalculates it with a new value.
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After entering a formula the result is display as in Figure 9.23

Figure 9.23 Constructing formula in Worksheet

9.6 Save, Close and Open the Worksheet:

9.6.1 Saving Worksheet

	 The process of saving a worksheet is very similar to saving a document. Steps to 
save a worksheet are as follows:

Step 1:	 File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.

Step 2:	 If the worksheet has not been saved previously, the Save As dialog box will appear.

Step 3:	 Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored 
with extension .ods by default.

Step 4:	 Click “Save” button.

After clicking the save button, the given file name is displayed in the title bar as shown in Figure 9.24.
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File Extension:

	 A file extension or file name extension helps to identify the type of file. 
Following table gives the file extension of commonly used files.

Familiar File Type Extension

Text Files .txt

Microsoft Word Documents .doc / .docx 

OpenOffice Documents .odt

Microsoft Excel .xls / .xlsx

OpenOffice Calc .ods

Microsoft PowerPoint .ppt / .pptx

OpenOffice Impress .odp

Executable Files / 
Applications

 .exe

Web Pages .htm / .html

Portable Document Format .pdf

Photos 
.jpg / .jpeg (Joint 
P h o t o g r a p h i c 
Experts Group)

Animated Images
.gif (Graphic 
Interchange 
Format)

Audio .mp3

Audio / Video .mp4
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Note: The saved file is stored in the 
"Documents"  folder by default. 

 What is save?

Technically saving is a process of 
transferring or shifting contents 

from primary memory (RAM) to 
Secondary storage medium such as 
Hard disk, Pen drive, memory chip 
etc.

9.6.2 Auto Save:

	 OpenOffice saves a file at regular 
intervals. This is called as “Auto Save” 
feature. The default time interval is 15 
minutes. It can be reduced even to one 
minute. If any unexpected shutdown 
occurs, this feature will recover your file. 

	

File Name Application Name

Figure 9.24  Saved Spreadsheet

9.6.3 Closing a Worksheet

	 After saving the worksheet; it 
remains open. So, you can continue 
to working with it. When the work is 
finished, you should save using File → 
Save (or) Click “Save” icon (or) Ctrl + S 
and then to close the worksheet using File 
→ Close command (or) Press Ctrl + W.

9.6.4 Opening an existing worksheet

9.6.4.1 Using Open dialog box

	 To reopen an existing worksheet, 
the File → Open command (or) “Open” 
icon (or) Ctrl + O can be used. An Open 
dialog box appears as shown in Figure 
9.25 that is similar to “Save As” dialog 
box.

	 The name of the file to be opened 
can be chosen from the list or folder in 
which worksheet has been saved.
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Default location

Available Files 
and Folders

Read only 
Option

Figure 9.25 Open Dialog box

9.6.4.2 Using Recent documents

	 OpenOffice keeps a list of recently 
opened files. File → Recent Documents 
option can be used to open an existing 
worksheet from the list as shown in Figure 
9.26.

List of recently used files

Figure 9.26 List of Recent Documents

9.7 Copy, Cut and Paste
9.7.1 Copy and Paste Data (Coping Data)

•	 Select the cell or cells you want to 
copy

•	 Select Edit → Copy or Click “Copy” 
icon from the standard toolbar or Press 
Ctrl + C.

•	 Move the cell pointer to the cell in 
which you want to paste.

•	 Select Edit → Paste or Click “Paste” 
icon or Press Ctrl + V

9.7.2 Cut and Paste Data (Moving Data)

•	 Select the cell or cells you want to cut

•	 Select Edit → Cut or Click “Cut” icon 
from the standard toolbar or Press  
Ctrl + X

•	 Move the cell pointer to the cell in 
which you want to paste.

•	 Select Edit → Paste or Click “Paste” 
icon or Press Ctrl + V.
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9.7.3 Copy and Paste Formula

•	 The process of Copy and Paste data is used for copying formula.

•	 When you copy a formula from one cell to another cell, the address of the pasted 
formula will change according to its row. This is called “Relative Cell Reference” 
(Refer Figure 9.27). 

Example: 

While pasted it becomes = B3* C3

Originally typed formula = B2*C2

Row number

Figure 9.27 Copy and Paste formula to multiple cells
9.7.4 Copy a formula from one cell and paste it in multiple cells:

(For illustration 1 - Refer Figure 9.23)

Step 1:	 Copy the formula from H2 using Ctrl + C or Edit → Copy (or) click “Copy” icon.

Figure 9.28 Copy and Paste forumla to Multiple cells

Step 2:	 Select all cells (i.e. H3 to H11) in which you want to paste the addition formula.

Step 3:	 Paste the copied formula using Ctrl + V or Edit → Paste (or) Click “Paste” icon.
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1.	 Open the worksheet which was created in Illustration 1.

2.	 Add one more column heading “Average” in I1

3.	 Create a formula to find the average of all marks in I2.

4.	 Apply the formula to the remaining cells.

5.	 Save the changes and close the file

WorkShop Practice:

9.8 Auto Fill Feature:
 

	 You have learnt how to copy and 
paste a formula from one cell to other cells 
in the previous section. The process of Copy 
and Paste can be replaced by a click and 
drag and it is called as “Auto Fill”. This is an 
alternate way to copy and paste. 

	 Auto Fill feature fills the contents 
from one cell to all the dragged cells. The 
content may be a data or formula. If you fill 
a relative formula, all the addresses of filled 
formulae will be changed.

Drag Fill Handle

Figure 9.29 Drag fill handle

	 Cell pointer’s “Drag fill handle” 
is used to auto fill. Just click and drag this 
handle to fill the contents. It can be dragged 
towards right or down. Same can be achieved 
by Edit →Fill → Down (or) Edit → Fill → 
Right.

9.8.1 Auto Fill Series:

	 Auto Fill is also used to generate a 
series of values. For example, if you want 
to generate 1,2,3……. up to some value; it 
can be done by a simple clicking and drag 
process.

	 Generating whole number series: 
(Refer Figure 9.30).

Step 1:	 In cell A1, type as 1 (one) and press 
enter

Step 2:	 Click A1 to place the cell pointer

Step 3:	 Click “Drag Fill Handle” of cell 
pointer; now the mouse pointer becomes a 
small + sign

Step 4:	 Drag over the cells; while dragging,  
the generated values will be displayed.

Step 5:	 Release the mouse pointer. Selected 
cells will be filled with series of values.
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Drag
fill handle 

Drag Cells

Generated series

Figure 9.30  AutoFill series

9.8.2 Generating series using command  

	 Edit → Fill → Series Command is used to generate different set of series. Before using 
this feature, a set of cells should be selected. Using Fill Series feature, you can fill series 
of values at any direction. (Remember that, auto fill only fills either right or down). Refer  
Figure 9.31.

Direction : Down / Right / Up / Left  (Selected cell direction will be default)

Series type : 

Linear	 : To generate a sequence of series (Example 2,4,6,8,10…….)

Growth : To generate multiplication series (Example 2,4,8,16,32,64……)

Date	 : To generate date series (when you select date as series type; time unit section gets 
enabled)

AutoFill : To generate a continuous  series of values (1,2,3,…….). When you select “AutoFill”, 
Time unit section, End value and Increment text boxes become disabled.

Time Unit: (Enabled only when you select the series type as “Date”)

Day	 :	 To generate date series day-wise

Weekday	 :	 To generate date series weekday-wise

Month	 :	 To generate date series month-wise

Year	 :	 To generate date series year-wise



158 159

Start Value: 

•	 Initial value of the series should be typed

End Value:

•	 End value of the series should be typed

•	 If you fail to specify the end value, series will be generated upto the selected cells.

Figure 9.31  Fill series dialog box

•	 If your selection is less than the specified end value, series will be generated only upto the 
selected cells.

Increment:

•	 It is a difference value between the first and second value of your series. So, the next value 
(Third value) of the series will be generated based on this value.

•	 If you want to generate a decreasing order series, negative value should be specified as an 
increment value. 

(i)	 Generate Even number series from 2 to 20

(ii)	 Generate a series of 5, 10, 15, 20 ……. upto selected cells.

(iii)	Generate a series of 2,4,8,16,……… 2048

(iv)	Generate a series of 33, 30, 27 …… upto 3

(v)	 Assume, today is Friday and generate next 25 Fridays (Date series).

Self Practice:
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9.8.3 Date Arithmetic:

	 Manual date calculations can be tricky because you have to keep track of the number 
of days in a month. In spreadsheets, date calculations become very simple. Here you can	
 add a number to a date and arrive at a new date, find the difference between two dates 
and use a wide variety of function and formats to get what you want.

	 For example, enter a date 02/26/2018 in a cell, say A2. Suppose you want to calculate 
the date 80 days after this date. To do so, enter the formula, = A2 + 80, in another cell, say 
A4.

	 The date 05/17/18 appears in the cell.  

•	 Type today’s date in first cell.
•	 Type your birth date in second cell.
•	 Type the following formula in third cell = first_cell_reference – second_cell_

reference

To Find out how many days you were born? your birth?

Editing and Formatting Worksheet

9.9 Inserting Columns, Rows and Cells
	 In Calc, columns, rows and cells can be inserted individually or in groups.

9.9.1 Inserting a Column:

	 When you insert a new column, it is inserted to the left of the current column. The 
location of the cell pointer present, is the Current column. In Calc, you can insert a new 
column anywhere in the worksheet.

Step 1: 	Select the column where a new column to be inserted.

Step 2:	 Right-click on the selected column name. A pop-up menu  appears.

Step 3:	 click the “Insert Columns” option from the menu.
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Now, a new column will be inserted to the left of the current column.

Right Click here

To insert column click

Pop - up Menu appears
Figure 9.32  Insert Column pop-up menu

A new column can also be inserted using Insert → Columns command. (Refer Figure 9.32).
Click "Insert" menu

Select "Columns" option

Figure 9.33  Insert Column menu bar
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1.	 Open the worksheet which was created in Illustration 1.
2.	 Insert a new column between column E and F
3.	 Give the heading as “Eco” and Enter the Economics marks for all the students
4.	 Insert one more column between the columns, Name and Tamil marks. 
5.	 Give the heading as “Date of Birth” and Enter the date of birth for all the students.
6.	 Save the changes and close the file.

Workshop

9.9.2 Inserting Rows

	 When you insert a new row, it is inserted above the current row. The location of the 
cell pointer present is the current row. In Calc, you can insert a new row anywhere in the 
worksheet.

Step 1: 	Select the row where a new row to be inserted.

Step 2:	 Right-click on the row number, a pop-up menu appears

Step 3:	 click “Insert Rows” option from the menu.

Now, a new row will be inserted to above the current row.
Right Click here to select the row as well as get popup menu

Select "Insert Rows"
Figure 9.34 Insert Rows popup menu
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Insert → Rows command is used to insert a new row.  Refer Figure 9.35.

Click "Insert" menu

A new "Row" 
inserted 

above the 
selected row

Select "Rows" option

Figure 9.35  Insert Rows menu bar

1.	 Open the worksheet which was created in Illustration 1.

2.	 Insert 8 rows one by one, then insert the following student details

3.	 Save the changes and close the file.

Reg. No Name Date of Birth Tam Eng CS Eco Com Acc
12101 Sarika S 26/05/2001 145 135 145 125 180 196
12102 Jewees Celcya J 11/04/2001 102 165 134 95 180 134
12103 Yuvarani T 27/06/1999 172 130 107 155 162 130
12104 Meharunisha I 30/05/2001 132 146 112 185 192 176
12105 Priya W 07/03/2000 130 172 100 92 162 155
12106 Vijaya Vasavi K 03/06/2001 198 175 149 148 158 135
12107 Deepika B 14/03/2001 120 182 103 144 107 186
12108 Viji V 19/04/2001 137 173 128 148 125 177

Workshop
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9.9.3 Inserting Cells

•	 To insert a new cell between two existing cells, just right-click on any existing cell

•	 From the pop-up menu, select “Insert” option Figure 7.36 Insert cells

•	 The “Insert Cells” dialog box appear with four options

	 i) Shift cells down	 ii) Shift cells right	 iii) Entire row	 iv) Entire Column

•	 Any one of the four options can be selected. 

•	 Selecting “Shift cells down”, inserts a new cell in the present location and the existing 
cells are shifted downwards. 

•	 Selecting “Shift cells right”, inserts a new cell in the present location and the existing 
cells are shifted towards right.

•	 Selecting the “Entire Row” or “Entire Column” option, inserts a new row or a new 
column respectively. 

Figure 9.36 Insert cells

9.9.4 Inserting multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting one at a time.

•	 Select multiple rows or columns for insertion.

•	 Follow steps as in 9.9.1 and 9.9.2 

9.9.5 Inserting Columns, Rows and Cells using “Insert Cells” Toolbar

•	 Insert Cells floating toolbar is also used to insert cells, rows and columns

•	 Click View → Toolbars → Insert Cell

•	 A floating toolbar appears on the screen with four icons. Using these icons, you can 
insert cells, rows and columns. Refer Figure 9.37.
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Insert Rows

Insert 
Columns

Insert cell right
Insert cell down

Figure 9.37  Insert cell tool bar

9.10 Deleting columns and rows

	 A single or multiple columns or 
rows can be deleted.

	 All spreadsheets have some 
specific number of rows and 
columns, then is it possible to insert 
an additional row or column?

Technically this is NOT POSSIBLE.

	 Additional column, row or 
even cell cannot be inserted in any 
spreadsheet. When you insert a 
column or row, the contents within 
the column or row will be shifted to 
the next column or row. But visually 
it is felt that a new column or row has 
been inserted.

Inserting a new Column or 
row is really possible in a 
Spreadsheet?

9.10.1 Delete single column or row

	 A single column or row can be 
deleted by using the mouse:

•	 Select the column or row to be deleted.

•	 Choose Edit →Delete Cells from the 
menu bar.

(or)

•	 Right-click on the column or row 
header.

•	 Choose Delete Columns or Delete 
Rows from the pop-up menu.

9.10.2 Delete multiple columns or rows

	 Multiple columns or rows can be 
deleted at a time. Refer Figure 9.38.

•	 Select the required columns or rows 
to be deleted.

•	 Right-click on the selected columns 
or row.

•	 Choose Delete Columns or Delete 
Rows from the pop-up menu or  
Edit → Delete Cells.

1.	 Open the spreadsheet which was 
created in Illustration 1.

2.	 Delete the details of any 3 
students. Save the changes and 
close the file.

Workshop:

	 Same as inserting column or 
row, Deleting a column or row is 
also not possible. No one can delete 
any column or row in a spreadsheet. 
When you delete a column or row, all 
the contents will be removed from 
the column or row. Actually, this is 
also another kind of deleting contents 
from a column or row.

Deleting Column or Row is 
not Possible
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9.11 Formatting Worksheet

	 Formatting Data in a cell gives additional effect to the text. Additional effect 
includes changing the font style, font size, automatic wrapping, bold, underline, italic etc. 
The data in Calc can be formatted in several ways, using formatting icons.

Selected columns

To Delete Selected 
columns; click here

Figure 9.38  Delete multiple columns

9.11.1 Text Formatting

	 Making  the cell contents as bold, italics, underline, changing font style, size, colour 
etc., comes under text formatting. All text formatting options are available as icons in 
Formatting toolbar learnt in OpenOffice Writer. 

Moving handle
Bold Italic

Underline

Merge 
Cells

Align left, center, right 
and justfy icons

Styles Font Styles Font Size {

Figure 9.39 (a)  Text Formatting Toolbar
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Formatting 
Option

Keyboard 
Shortcut

Description

Font style Used to change Font style

Font size Used to change Font size

Bold Ctrl + B Used to make the data as 
Bold

Italic Ctrl + I Used to italicize  data 
Underline Ctrl + U Used to underline the data

Left Align Ctrl + L Left Align data within a 
cell 

Right Align Ctrl + R Right Align data  within a 
cell

Center Align Ctrl + E Center Align data within a 
cell

Justify Ctrl + J
Align the data evenly both 
on left and right side of a 
cell

Merge cell Makes selected cells as a 
single cell

9.11.2 Number formatting

	 Number formatting options are used to visually change the format of a numeric 
content. These formatting changes appear for visual as, it does not change the original 
value. For example, to display a number in currency form use Number format: Currency.  

Number format: Currency will be used as shown Figure 9.39(b).

Currency

Percentage
Delete 

Decimal

Add 
Decimal

Standard
Figure 9.39 (b) Formatting toolbar
Number 
Format

Keyboard
Shortcuts

Currency Symbol Ctrl+Shift+4
Percent Ctrl+Shift+5
Standard Ctrl+Shift+6
Add Decimal Place
Delete Decimal Place
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1.	 Open the worksheet which was created in Illustration 1.

2.	 Align all headings as center and make them bold.  

3.	 Align all Register numbers and marks in center 

4.	 Apply different font styles to the entire worksheet.

5.	 Save the changes and close the file

Workshop

Workshop 1 

1. Create a worksheet with following data

Emp. 
No

Name of Emp. Basic DA HRA CCA MA GPF IT HF

1001 Manivannan M 25500

25
 %

 o
f B

as
ic

%
15

 o
f B

as
ic

 a
nd

 D
A

600 300

12
 %

 o
f B

as
ic

%
10

 o
f G

ro
ss

250

1002 Kannan K 20200 600 300 250

1003 Gowrishankar N V 24300 600 300 250

1004 Lenin K 23400 600 300 250

1005 Suryanarayanan T 24100 600 300 250

1006 Ramesh K 18500 600 300 250
1007 Govindasami A 13200 600 300 250
1008 Kannan S 20250 600 300 250
1009 Penchil Rao K 28300 600 300 250

1010 Logeswaran M 30200 600 300 250

1011 Arumugam E 12000 600 300 250

1012 Vasu G N 25000 600 300 250

Based on the above data, 

(1)	 Calculate the Gross Salary, Total Deductions and Net Salary

(2)	 Insert “IT Cess” column and calculate 3% of cess to all employees
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(3)	 Delete the records of “Govindasami” and “Arumugam”.

(4)	 Insert four new rows and enter the following employee details.

(5)	 Calculate the Total amount of GPF, IT and Cess

Emp. 
No

Name of Emp. Basic DA HRA CCA MA GPF IT HF

2001 Murali G 24750
2002 Munirathnam A 23550
2003 Ramakrishnan V G 25500
2004 Srinivasan R 27500

Workshop: 2 

1. Create a new worksheet in OpenOffice Calc.

2. Enter the following stock and sales details of “Chennai whole sale Marketing Pvt. 
Ltd.” during the month of Jan-2018.
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 p

ri
ce
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100 Marie Gold 120 345 15 147 5%
101 Milk Bikis 85 106 10 63 5%
102 Dark Fantasy 75 147 25 43 3%
103 Nutri Choice 250 98 50 12 10%
104 Lays potato chips 52 172 15 152 4%
105 Oreo 120 112 25 85 6%

3. Calculate the following using formula

(i) Amount of Discount, Selling price and Amount of sales for each product 

(ii) Total amount of discount and Sales of the month

(iii) Closing stock of each product
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Workshop: 3 

1. Create a worksheet in OpenOffice Calc.

2. Enter the following details of loan sanctioned during the month of January 2018 of 
“Tamil Finance Corporation”.

A
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2001 Senthil 250000 02/01/2018 120 days 9.5%

2002 Kumar 175000 15/01/2018 150 days 9.5%

2003 Ibrahim 550000 16/01/2018 140 days 10.5%

2004 Valli 375000 21/01/2018 210 days 10%

2005 Charles 450000 28/01/2018 130 days 10.5%

3. Create the formula to calculate

(i) Interest, Total amount and due date.

(ii) Gross total of  loan amount, interest and total amount.

4. Insert 5 new rows between Kumar and Ibrahim and include the following details
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3001 Pari 250000 03/02/2018 125 days 9.5% 5%
3002 Arul 375000 07/02/2018 155 days 9.5% 5%
3003 Raman 350000 10/02/2018 130 days 10.5% 3%
3004 Givind 450000 10/02/2018 100 days 10% 10%
3005 Zeenath 800000 26/02/2018 90 days 10% 4%
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Points to Remember:

•	 Spreadsheet is a very useful office automation tool for organization, analysis 
and storage of data in a tabular form.

•	 Daniel Bricklin and Bob Frankston developed the first spreadsheet software 
called “VisiCalc” in 1979 for Apple II.

•	 OpenOffice Calc is a popular open source spreadsheet application software 
presently maintained by Apache Foundation.

•	 A worksheet is a grid of cells with a programmable calculator attached to each 
cell.

•	 OpenOffice Calc version 4.1.5 contains a total of 1024 columns and 10,48,576 
rows.

•	 Intersection of each row and column forms a rectangular box which is called as 
“Cell”.

•	 Cell pointer is a rectangle element which can be moved around the worksheet. 

•	 The cell in which the cell pointer is currently located is known as “Active cell”.

•	 All formula should start with an equal sign. 

•	 There are four types of operators supported by Calc.

Activity

Student Activity 

1. 	 Based on the concept of calculation using formula, make the students to create various 
worksheet data.

Teacher Activity

1. 	 To show the demo of working with spread sheets using simple example in class room.
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Evaluation

Part - I

Choose the correct answer

1.	 Which is the first electronic spreadsheet?
	 (A)Excel		  (B) Lotus 1-2-3	 (C) Visicalc		  (D) OpenOffice Calc

2.	 Which of the following applications is the parent to OpenOffice Calc?
	 (A)Visicalc		  (B) LibreCalc		 (C) Lotus 123		 (D) StarOffice Calc

3.	 Grid of cells with a programmable calculator:
	 (A)Spreadsheet				    (B) Database
	 (C) Word processor				    (D) Linux

4.	 A column heading in Calc is a
	 (A)Number		  (B) Symbol 		  (C) Date		  (D) Alphabet

5.	 Which key is used to move the cell pointer in the forward direction within the worksheet?
	 (A)Enter		  (B) Tab		  (C) Shift + Tab	 (D) Delete

6.	 A formula in calc may begin with
	 (A) =			   (B) +			   (C)     -		  (D) All the above

7.	 What will be the result of the following formula (Assume A1=5, B2=2)? + A1^B2
	 (A) 7			   (B) 25			  (C) 10		 (D) 52

8.	 What will be the result of the following expression (Assume H1=12, H2=12)? = H1<>H2
	 (A) True		  (B) False		  (C) 24		 (D) 1212

9.	 Which of the following symbol is used to make a cell address as  absolute reference?
	 (A) +			   (B) %			   (C) &		  (D) $

10.	  Which of the following key combination is used to increase the width of the current 
column?

	 (A)Alt + Right arrow				    (B) Ctrl + Right arrow
	 (B)Alt + Left arrow	  			   (D) Ctrl + Left arrow

Part – II
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Answer to the following questions (2  Marks)

11.	 What are the types of toolbars available in OpenOffice calc?

12.	 What is a cell pointer? 

13.	 Write about the text operator in OpenOffice Calc.

14.	 Write the general syntax of constructing a formula in Calc.

15.	 What are the keyboard shortcuts to cut, copy and paste?

16.	 Can you edit the contents of a cell? If yes, explain any one of the method of editing the 
cell content.

17.	 What are the options available in “Insert Cells” dialog box?

18.	 Match the following

A B
(a) Cut, Copy and Paste (1) Absolute Cell
(b) Cell pointer (2) Status bar
(c) Selection Mode (3) Standard Toolbar
(d) $A$5 (4) Active cell

19.	 Define the following (i) Text Operator  (ii) Rows and Columns of spreadsheet

20.	  Differentiate between Copy -Paste and Cut-Paste

Part – III

Answer to the following questions (3  Marks)

21.	 Write a short note on OpenOffice Calc.

22.	 Write about inserting columns and rows in Calc.

23.	 Differentiate Deleting data using Backspace and Delete Keys

24.	 Write any three formatting options.

25.	 In cell A1=34 A2=65 A3=89 write the formula to find the average.

Part – IV
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Answer to the following questions (5  Marks)

1.	 Explain about changing the column width in Calc.

2.	 Write the steps to generate the following series. 5, 10, 20 ….. 2560

3.	 Read the following table

A B C D E
1 Year Chennai Madurai Tiruchi Coimbatore
2 2012 1500 1250 1000 500
3 2013 1600 1000 950 350
4 2014 1900 1320 750 300
5 2015 1850 1415 820 200
6 2016 1950 1240 920 250

	 Above table shows the sales figures for “Air Cooler” sold in four major cities of Tamilnadu 
from the year 2012 to 2016. Based on this data, write the formula to calculate the following.

(1)	 Total sales in the year 2015.

(2)	 Total sales in Coimbatore from 2012 to 2016.

(3)	 Total sales in Madurai and Tiruchi during 2015 and 2016.

(4)	 Average sales in Chennai from 2012 to 2016

(5)	 In 2016, how many “Air Coolers” are sold in Chennai compared to  Coimbatore? 
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Spreadsheet Sheet of paper that shows accounting or other data in rows and 
columns

What-if analysis It is a process of changing the values in a cell to see how these 
changes will affect output.

VisiCalc The first electronic spreadsheet application
GUI Graphical User Interface
Excel Familiar spreadsheet application developed by Microsoft 

Corporation. 
Cell Intersection of rows and columns.
Cell Pointer A rectangular box, highlighting the cell in a spreadsheet.
Active cell A cell in which the cell pointer is presently located.
Formula A formula is an expression that tells the computer what 

mathematical operation to perform on a specific value.
Operator A symbol that usually represents an action or process
Range Group / Collection of cells
BODMAS Rule Order of mathematical calculation:

Brackets - Orders (powers or square roots) -  Division – 
Multiplication – Addition - Subtraction.

Drag fill handle A small black box at the bottom right corner of the cell pointer.
Function Predefined formula / a group of instructions to return a single 

result or a set of results.
Chart Graphical representation of data.
Database A large quantity of indexed digital information.
Flat file database Single table, non relative database
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